You are Here:
Linux Lite 6.0 Final Released - See Release Announcements



Slow startup of Linux Lite 5.6

Author (Read 1614 times)

0 Members and 1 Guest are viewing this topic.

Slow startup of Linux Lite 5.6
« on: December 30, 2021, 04:15:00 PM »
 

Jan Mertens

  • New to Forums
  • *
  • 3
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.6 64bit

  • CPU: Intel(R) Core(TM) i3-5005U CPU @ 2.00GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel HD Graphics 5500
Hi,
I installed Linux Lite 5.6  on an old Medion Laptop - it works fine once started up but the boot process takes a long time.

Browsing the forum I tried a number of things but without any significant improvement.
Would someone have a piece of advice for me? Help would be highly appreciated!

systemd-analyze
Code: [Select]
Startup finished in 4.943s (kernel) + 1min 3.829s (userspace) = 1min 8.772s
graphical.target reached after 1min 3.791s in userspace


systemd-analyze blame
Code: [Select]
32.943s networking.service                                  
21.053s networkd-dispatcher.service                         
17.484s snapd.service                                       
13.055s accounts-daemon.service                             
12.178s dev-sda2.device                                     
12.043s systemd-udev-settle.service                         
11.882s udisks2.service                                     
11.029s NetworkManager-wait-online.service                  
 8.832s polkit.service                                      
 8.369s systemd-journal-flush.service                       
 8.229s NetworkManager.service                              
 8.165s avahi-daemon.service                                
 8.160s bluetooth.service                                   
 7.835s ModemManager.service                                
 7.058s thermald.service                                    
 7.052s systemd-logind.service                              
 7.030s wpa_supplicant.service                              
 6.982s nmbd.service                                        
 6.189s lightdm.service                                     
 6.177s plymouth-quit-wait.service                          
 5.547s secureboot-db.service                               
 4.486s gpu-manager.service                                 
 3.423s teamviewerd.service  

critical chain
Code: [Select]
graphical.target @1min 3.791s
└─multi-user.target @1min 3.790s
  └─smbd.service @1min 759ms +3.030s
    └─nmbd.service @53.771s +6.982s
      └─network-online.target @53.763s
        └─network.target @53.763s
          └─networking.service @20.818s +32.943s
            └─apparmor.service @18.737s +2.080s
              └─local-fs.target @18.735s
                └─snap-snapd-14295.mount @18.385s +350ms
                  └─dev-loop5.device @18.733s +670ms

System information
Code: [Select]
System:
  Host: jan-D17D Kernel: 5.4.0-91-generic x86_64 bits: 64
  Desktop: Xfce 4.14.2 Distro: Linux Lite 5.6 LTS
Machine:
  Type: Laptop System: Medion product: D17D v: 1.0
  serial: <superuser/root required>
  Mobo: Medion model: D17D v: 1.0 serial: <superuser/root required>
  UEFI: American Megatrends v: 703 date: 04/10/2016
Battery:
  ID-1: BAT0 charge: 34.7 Wh condition: 36.0/43.5 Wh (83%)
CPU:
  Topology: Dual Core model: Intel Core i3-5005U bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 1516 MHz min/max: 500/1900 MHz Core speeds (MHz): 1: 1384 2: 1404
  3: 1288 4: 1307
Graphics:
  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel
  Display: x11 server: X.Org 1.20.13 driver: modesetting
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.0.3
Audio:
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
  Device-2: Intel Wildcat Point-LP High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-91-generic
Network:
  Device-1: Intel Wireless 3160 driver: iwlwifi
  IF: wlp2s0 state: up mac: 2c:6e:85:95:dc:97
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp3s0 state: down mac: c0:7c:d1:fa:2f:74
Drives:
  Local Storage: total: 1.48 TiB used: 43.39 GiB (2.9%)
  ID-1: /dev/sda vendor: Seagate model: ST1500LM006 HN-M151RAD
  size: 1.36 TiB
  ID-2: /dev/sdb model: SSD 2.5 PHISON 128GB PS3110-S10C size: 119.24 GiB
Partition:
  ID-1: / size: 1.34 TiB used: 43.39 GiB (3.2%) fs: ext4 dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 57.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 232 Uptime: 1h 41m Memory: 5.73 GiB used: 1.95 GiB (34.1%)
  Shell: bash inxi: 3.0.38
 

Re: Slow startup of Linux Lite 5.6
« Reply #1 on: December 31, 2021, 09:33:02 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8361
    Posts
  • Reputation: 779
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Thread moved to correct forum Section.

Start with disabling nmbd smbd services if you don't plan to do any network sharing. Then set a static ip address. I see also snap is installed, if you don't want that uninstall and disable the service. Those will improve times. Not much else to tweak unless you don't have bluetooth.
 

Re: Slow startup of Linux Lite 5.6
« Reply #2 on: January 01, 2022, 04:18:10 AM »
 

WytWun

  • PayPal Supporter
  • Occasional Poster
  • *****
  • 82
    Posts
  • Reputation: 13
  • Linux Lite Member

  • Linux Lite: 5.6 64bit

  • CPU: Atom z8300

  • MEMORY: 2Gb

  • VIDEO CARD: Intel integrated

  • Kernel: 5.x
Code: [Select]
[quote author=Jan Mertens link=topic=8439.msg57260#msg57260 date=1640898900]
  Local Storage: total: 1.48 TiB used: 43.39 GiB (2.9%)
  ID-1: /dev/sda vendor: Seagate model: ST1500LM006 HN-M151RAD
  size: 1.36 TiB
  ID-2: /dev/sdb model: SSD 2.5 PHISON 128GB PS3110-S10C size: 119.24 GiB
Partition:
  ID-1: / size: 1.34 TiB used: 43.39 GiB (3.2%) fs: ext4 dev: /dev/sda2

You installed to a slow laptop class hard drive, even though the system seems to have an SSD.  If you don't need the SSD for another OS, installing Lite to a partition on that and keeping the hard drive purely for user data would make for a noticeably faster boot sequence.
 

Re: Slow startup of Linux Lite 5.6
« Reply #3 on: January 01, 2022, 06:33:25 AM »
 

Jan Mertens

  • New to Forums
  • *
  • 3
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.6 64bit

  • CPU: Intel(R) Core(TM) i3-5005U CPU @ 2.00GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel HD Graphics 5500
Thanks for the advices! Will re-install on SSD and see what the result is.
 

Re: Slow startup of Linux Lite 5.6
« Reply #4 on: January 01, 2022, 08:41:43 AM »
 

Jan Mertens

  • New to Forums
  • *
  • 3
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.6 64bit

  • CPU: Intel(R) Core(TM) i3-5005U CPU @ 2.00GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel HD Graphics 5500
This means a happy start of the year  :027:
Same system, but installed on the (available) SSD disk.
Had to remove Windows, which I did.

Code: [Select]
Startup finished in 3.724s (kernel) + 11.836s (userspace) = 15.560s
graphical.target reached after 11.810s in userspace
 

 

-->
X Close Ad

Linux Lite 6.0 Final Released - See Release Announcements