You are Here:
Linux Lite 7.0 Final Released - See Release Announcement Section

Shutdown Problems and/or Sluggish System w/ AMD Graphics?

Author (Read 33137 times)

0 Members and 1 Guest are viewing this topic.

Re: Shutdown Problems and/or Sluggish System w/ AMD Graphics?
« Reply #3 on: January 19, 2016, 04:08:42 PM »


  • New to Forums
  • *
  • 5
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: AMD A4 1200

  • MEMORY: 2Gb

  • VIDEO CARD: Radeon HD 8180 (APU)
APU AMD A4-1200 with Radeon HD 8180

LL 2.6, kernel 3.13 worked with opensorce driver and proprietary
but kernel 4.4 worked only with opensource

P.S.: general system performance was improved
« Last Edit: January 19, 2016, 04:10:44 PM by rafa »

Re: Shutdown Problems and/or Sluggish System w/ AMD Graphics?
« Reply #2 on: April 18, 2015, 03:55:58 PM »


  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8831
  • Reputation: 806
  • Linux Lite Member
    • View Profile
    • Linux Lite OS

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 6.x
Awesome sauce, gold_finger and N4RPS :)

Shutdown Problems and/or Sluggish System w/ AMD Graphics?
« Reply #1 on: April 18, 2015, 01:16:51 PM »


  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
  • Reputation: 325
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
If you are experiencing shutdown/logout problems and/or are experiencing unusually sluggish performance when trying to perform certain tasks (eg. using "gksu" to run a gui program as root) and have an AMD graphics card, below is a possible solution.  (These types of problem do not apply to all AMD cards -- just a few.  So if you are not having any problems, leave your system alone.)

Big thank you to member N4RPS for finding and posting this solution.  Here is the original post he made while helping someone here on the forum.  Below, I just copy/pasted everything he wrote in that post to here so that people can easily find this if it applies to them.  (If this post helps you thank N4RPS, not me.)



With some help from its creator, I was able to successfully complete the procedure documented in the YouTube video.

I created your script on the desktop, and made it executable. So far, it seems to work right away, This is very good, because in an actual install, the action button is just as slow to respond as the Whisker Menu is. Additionally, the gksu/gksudo command, or anything else requiring root password (except terminal sudo/su) takes 30-40 seconds to appear after being called on.
Just remembered, it could be the AMD Graphics driver. Are you using propriatary  or free drivers?

It IS a driver issue with certain AMD Radeon HD video cards!. As I see it all, seem AMD, the X11 folks, and XFCE are blame-shifting the whole thing back and forth. Meanwhile....

The Full Story:

Let's see... I had figured out that X11 had something to do with it - specifically, X11 as XFCE uses it. Misko's reference to the video driver was the missing piece of the puzzle.

If you're affected by this in LL and XFCE, creating the following file should fix it. If the fixes the OP's issue, then I guess this one can be flagged as SOLVED.

Code: [Select]
sudo mkdir -p /etc/X11/xorg.conf.d/
Code: [Select]
sudo nano /etc/X11/xorg.conf.d/20-radeon.conf
Copy  the following lines, and paste them into nano with [SHIFT-CTRL-C]:

  Section "Device"
      Identifier "Radeon"
      Driver "radeon"
      Option "AccelMethod" "EXA"

Press [CTRL-O] then [ENTER] to save, and [CTRL-X] to exit. Reboot. For me, LL is now as snappy as it ought to be!

If  anyone doesn't know what kind of video card they have, as you see below, if the output of

Code: [Select]
sudo lshw -c video
says AMD or ATI, please reply with the model number. This way, we can get an idea of which models are affected - and which ones aren't. We already know that Radeon HD 8250 is, but Radeon HD 6320 is not...
Not sure, but it just MIGHT be the issue:
rob@N4RPS-3135-LL:~$ sudo lshw -c video
[sudo] password for rob:

30-45 seconds later...

       description: VGA compatible controller
       product: Temash [Radeon HD 8250/8280G]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 1
       bus info: pci@0000:00:01.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:81 memory:e0000000-efffffff memory:f0800000-f0ffffff ioport:3000(size=256) memory:f0200000-f023ffff memory:f0260000-f027ffff

On my Samsung, which has no latency issues, this report also took a bit of time to generate. IT has a Radeon HD *6320*, and the width is *32 bits*. Same driver  - radeon. (I wonder if THAT could have something to do with it?)

I sure hope an overall solution is out there for this. These long delays are going to drive me to forget about running LL on this particular netbook...

« Last Edit: April 18, 2015, 01:19:21 PM by gold_finger »
Try Linux Beginner Search Engine for answers to Linux questions.


X Close Ad

Linux Lite 7.0 Final Released - See Release Announcement Section