Hardware - Support > Start up and Shutdown

Moving LL HD to another PC - not booting normally

(1/1)

Alan_uk:

Hi

I've spent many weeks installing and customising a LL 1.0.8 x32 bit system along with a whole range of apps including Wine and VBox. This was on an ASUS box:

Asus A88XM-Plus AMD Socket FM2+ Motherboard
AMD A4 5300 3.4GHz Socket FM2 Dual Core
    Integrated Radeon HD 7480D Graphics
G.Skill RipjawsX 8GB DDR3 2133MHz Dual Channel
Western Digital Black 1TB SATA III 3.5" Hard Drive
XFX Pro 550W Power Supply Unit
Generic 22x DVD+/-RW Drive
Samsung 19" LED screen Model S19A450BR   LS19A450BRT

I've now decided to move the whole system to an older EPOX box:

Epox Ep-9npa+ Ultra
AMD Athlon 64 3000+ 939 pin / 1800MHz 512KB L2 Cache 1600MHz Hyper Transport Link
256MB Leadtek PX6200TC-TDH PCI-E - NVIDIA GeForce 6200 Turbocache
Corsair TwinX XMS3200 3GB  DDR400 / CAS : 2-3-3-6*
Western Digital Black 1TB SATA III 3.5" Hard Drive
525W Hiper HPU4S525 PCI-Ex
Sony DW-Q28A OEM
Floppy Disk Drive


On ASUS the Secure Boot (UEFI) Bios was removed and set to OtherOS before installing LL 1.0.8 x32 bit
Also whilst the graphics driver was installed for the HD 7480D the system profile said it was not active.

I cloned the ASUS HD to an identical HD and once the Swap partition was formated it worked OK in the ASUS.

On inserting it into the EPOX the PC LinuxOS logo appeared and then it went into CLI mode asking for user ID and password. On entering these it said:

--------------------
Welcome to Linux Lite 1.0.8 (GNU/Linux 3.8.0-34-generic i686)

Your current Hardware Enablement Stack (HWE) is no longer supported
since 2014-08-07..................

Upgrade command ..................
----------------------------
(see attachment for screen shot)

The Epox does run a live CD of LL 1.0.8 x32 bit

Here's a System Report on the EPOX PC booting with the Live CD
http://www.alancooper.me.uk/docs/Lian-Epox-LL-HD-hardinfo_report.html
(or see attached for pdf)

Suggestions please, hopefully not re-installing everything  ;)

FURTHER INFO

I looked at xorg.config and it's very basic and no driver info but exactly as the working Asus system:


--- Code: ---Section "Screen"
    Identifier    "Default Screen"
    DefaultDepth    24
EndSection

Section "Module"
    Load    "glx"
EndSection

--- End code ---

Could/should I
1) Reinstall xorg: sudo apt-get install xorg
2) Edit xorg.conf to add: Driver "vesa"
3) Install nvidia drivers:  sudo apt-get install nvidia-current  - will that work for a legacy card?
Give up and
4) Transfer all my packages to a clean install as here - onto the cloned hard disk (so all my data and configuration is maintained)
 

[attachment deleted by admin, more than 25 days old]

gold_finger:
First, I'd recommend putting drive back into Asus machine and run the "Install Drivers" program.  If it does show that the proprietary AMD drivers are installed, uninstall them and move back to generic "ati, radeon" drivers.  The machine you're switching to has NVidia so you don't want AMD drivers on there.  You can install NVidia drivers after get the system booted properly in the computer you're moving to.

However, that is not your main problem.  LL 1.0.8 is based on Ubuntu 12.10 and uses that kernel hardware stack, which is now unsupported.  I have no experience fixing this type of thing, but found some info for you to look through.  Seem that you have two choices:

1.  Install the hardware stack for 14.04 (Trusty) to the LL 1.08 system, or

2.  Install LL 2.0 or 2.2 and restore your data files from a backup.  Can also follow "Method #2" of your link above to create a list of programs to reinstall on the new installation.

Here's info regarding hardware stack and how to install new one:  https://wiki.ubuntu.com/Kernel/LTSEnablementStack.  Here is one pertainent quote that applies to your situation:


--- Quote ---
11.  The 12.10 enablement stack will only be supported in Precise from the time it appears in the 12.04.2 point release until the 14.04.1 time frame.

12.  When the 12.10 enablement stack reaches its EOL, 12.10 enablement stack users will NOT be automatically upgraded to the 14.04 enablement stack in Precise. Users will need to manually upgrade to the 14.04 enablement stack in order to continue receiving official support (ie security updates and bug fixes).  We will aggressively message (ie MOTD, USN, update-manager, etc.) when the 12.10 enablement stack is reaching its EOL and provide instructions on updating to the 14.04 enablement stack.
--- End quote ---

Before you do anything, I recommend making a full backup of your /home folder and also make that list of your currently installed packages just in case something goes terribly wrong.

If you have a separate /home partition, everything will be much easier if you go with installing LL 2.0 or 2.2.  Can give guidance on that if you need it.

Alan_uk:
Many thanks for your informative reply, Gold_finger.

I had found some similar issues and done part of your solution, namely install the 14.04 (Trusty) stack to the LL 1.08 system:


--- Code: ---sudo apt-get install xserver-xorg-lts-precise
--- End code ---
This went OK. Then:


--- Code: ---sudo apt-get install -V libglapi-mesa-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty xserver-xorg-input-all-lts-trusty xserver-xorg-video-all-lts-trusty libgl1-mesa-dri-lts-trusty x11-xserver-utils-lts-trusty libglapi-mesa-lts-trusty:i386 libgl1-mesa-dri-lts-trusty:i386 libgl1-mesa-glx-lts-trusty:i386 libgles2-mesa-lts-trusty libglapi-mesa-lts-trusty mesa-vdpau-drivers-lts-trusty
--- End code ---
This failed with loads of

--- Code: ---Err http://archive.ubuntu.com/ubuntu/ precise-updates/main libglapi-mesa-lts-trusty i386 10.1.3-0ubuntu0.1~precise1
  404  Not Found [IP: 91.189.88.153 80]
--- End code ---
and similar and a final

--- Code: ---E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
--- End code ---
I then tried a short version:

--- Code: ---sudo apt-get install linux-generic-lts-trusty linux-image-generic-lts-trusty
--- End code ---
with similar 404s


I beginning to think it's best to cut my losses and install LL 2.0. As the LL 1.0.8 was my first Linux custom install (i.e. more than just installing a basic distro) I've made extensive notes covering all the packages installed such as Wine + apps, Virtual Box + XP, Samba, Networking, Virus Protection, Backup, Scheduling, User Groups, etc. With a fair wind I might rebuild in 2 days :) Hopefully I will get quite a few years life out of it before LL3


Question please: If I copy my Home partition to retain all / most of my customisation could this cause any problems with LL2 or packages that are being reinstalled with a later version (my 1.0.8 was installed last March but I have been running Updates since). I'm thinking maybe config files may have changed format or config values may be erroneous).

Many thanks
Alan

gold_finger:
When I read through the info on that link it sounded rather confusing.  Wasn't sure how that would work out.  I agree probably best to just forget about it and do new install with LL 2.0 or 2.2 when it comes out (probably soon).  Though I really don't know if LL 2.2 will end up having similar problem as 1.8 did down the line.  2.0 won't, so no need to worry about that version.  Jerry would be the one to answer whether 2.2 will have that problem.  Maybe he'll see this and chime in.


--- Quote from: Alan_uk on November 26, 2014, 01:02:38 PM ---Question please: If I copy my Home partition to retain all / most of my customisation could this cause any problems with LL2 or packages that are being reinstalled with a later version (my 1.0.8 was installed last March but I have been running Updates since). I'm thinking maybe config files may have changed format or config values may be erroneous).

--- End quote ---

If you have a separate partition for Home right now, then you can re-use it with the new installation instead of wiping it out and starting over.  Chances are good that most of the current config files will continue to work.  If one or two programs have glitches you can just delete those particular config files and the program(s) will create a new standard config when they are opened for the first time after that.  Refer to your notes for things like Samba and Wine.  I don't use those programs so not sure if files for them from other parts of the system may need to be saved in addition to whatever is in the Home partition or folder.

If you were referring to the /home folder that is contained within the main Root partition, then you would need to make a full backup of that folder and restore it to the new install.  Type this command in a terminal to see what partitions you have:

--- Code: ---lsblk
--- End code ---

You'll see your partitions listed and the ones that are being used by LL will have mount points designated for them.  You'll see at least a "/" (for root) and "[SWAP]".  If you also see one with "/home" next to it, then you do have a separate partition for Home.  If not sure how to do the install and designate to re-use the Home partition, post back and ask first.

If you find out that it is not on its own partition, then use a backup program to backup the entire /home/your-username folder to either a USB stick or external drive.  Do the new install, then restore the data to your new home.  Do yourself a favor and use the same username on the new installation that you currently have now.  Otherwise you'll end up with file ownership and permissions headaches when trying to reuse old home files.

From feedback here on the forum, it was decided that backup program called Deja-Dup would be used in LL 2.2 because many people said they liked it and found it easy to use.  I've never used it myself, but took a quick look at it and it does look like backing up /home/your-username will be very easy with that program.  You can install it to your current LL and use it to make the backup.  (Unless you already have a preferred backup program.)  Just run this command in a terminal to install it:


--- Code: ---sudo apt-get install deja-dupe
--- End code ---

I think it'll show up under Menu -> Accessories.

If you do a full restore of Home you won't need this, but giving you link to a useful post for future reference if you ever need it:  https://www.linuxliteos.com/forums/index.php?topic=1136.msg6929#msg6929.


P.s.  If you don't currently have a separate partition for /home, you might want to consider doing that on this next installation.  It will make re-installations in the future much easier.

Navigation

[0] Message Index

Go to full version