Hardware - Support > Start up and Shutdown

LL boots up sluggish, becomes 'snappy' on logoff/logon

(1/3) > >>

Cedarviola:
What I see is sluggish UI behavior, for example dragging a window across the desktop, or hovering over a list. When dragging, the window lags way behind the cursor; when hovering it takes a perceptible amount of time for the item to highlight. Also benchmarks -- e.g. Blowfish gives a score around 38. This is after a fresh power-up boot.

It seems like someone, some process is holding interrupts disabled for too long a time.

But the good news is, that if I log off and back on, LL is delightfully quick and responsive with a Blowfish score around 16! This is very consistent, and I just discovered the log on/off sortof by accident.

I've been using htop and cpufreq-info looking for clues but no joy so far. Curiously when sluggish, Task Manager shows about 50% CPU usage (nothing else running) with Task Manager itself consuming most of that. When snappy, Task Manager shows only 4..5% CPU and again, Task Manager is responsible for most of that -- which seems most reasonable.

I submit this, wondering if anyone has similar experience, additional clues or a possible solution.

Thanks for listening.
Jim





bitsnpcs:
Hello Jim,

I am wondering could it be the graphics driver ?
Which driver are you using ?

Do you have UFW (firewall) enabled ?

trinidad:
This fairly common behavior for Ubuntu, but is generally caused by the unattended updates (automatic update and automatic kernel removal) system. As far as I know LL uses manual kernel removal tools and does not run a full unattended updates version like Ubuntu, however the cause may still be backgrounded there. When you first login wait until the cpu usage drops off to a low figure, (single digit %). If it falls off and performs normally in a few minutes I expect update utilites are the most likely culprit. Use lite tweaks to remove old kernels and before your next update run: sudo apt-get update from the terminal, and then exit and update normally from the GUI. Also check syaptic for packages with broken dependencies.

TC   

Cedarviola:
Well, I've been trying this or that to nail it down, and the one reproducible step is that booting up from a power-off state triggers the problem. A reboot from the GUI, or log off/on it works fine.

Other things I've tried ...
Drivers -- no 3rd party drivers are installed.
Updates -- are set to manual and that was accomplished this morning picking up just a few things.
Originally it was set to auto-logon, so I edited lightdm.conf to turn it off and same problem.
Created a new user with same admin priviledges NO problem with or without auto-login.
Tried live boot from the USB and no problem.

Thinking that this is either a bug or user error, I tried sudo 'apt-get redemption', but that did not help at all :)
Seriously perhaps it is some UI tweak I've made or something I've installed.
Installations include Pale Moon, psensor, gqrx (rtl-sdr software) and think that's all. I could try backing those out...

Or I could try the restore point I made. Or I could re-install the whole thing. Or I could live with it 'cause when she is good she's very very good. LL has breathed new life into this old laptop.

regards
Jim


trinidad:
The radio software may be the culprit- gqrx (rtl-sdr software). Set it not to load on startup. You may have to use systemd to do so. Also check your session and startup menu to disable unneccessary startup items.

Also do you have the corrected port version since Deb 9 release? I would check Deb 8 and 9 backports to see if Deb 9 port is avaliable and change to Deb 9 for gqrx if upgrade is available.

TC

Navigation

[0] Message Index

[#] Next page

Go to full version