You are Here:
Linux Lite 4.8 Final is now available for download and installation



[ SOLVED ] Lite now taking 3 minutes to boot

Author (Read 2545 times)

0 Members and 5 Guests are viewing this topic.

Lite now taking 3 minutes to boot
« on: September 03, 2019, 10:22:18 PM »
 

arky217

  • New to Forums
  • *
  • 36
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Pentium Gold G5400

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 610

  • Kernel: 4.x
I had Linux Lite (4.6) installed in a triple boot on a 120Gb SSD.
I went to use Timeshift to make a backup of Linux Lite, but
it failed saying that there was not enough disc space.
I checked and sure enough, there was only a few Gb of free
space on the Lite partition.

So, booting to a live Lite USB, I deleted one of the other os's
and then resized Lite to a greater partition size.

Well, it did something to grub and when I rebooted, it booted
to the grub rescue mode.

Well, using another computer to get some grub rescue mode
instructions, I was then able to boot into Lite.
Then I reinstall grub to /dev/sda and did a grub update.

It all appears to work now except that whereas before the time
to boot into Lite was about 30 seconds, now it takes 3 minutes
to boot.

Any idea what could have made the boot time go from 30 sec to 3 minutes ?

Here is a copy of my grub file:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=saved
#GRUB_DEFAULT=0
GRUB_SAVEDEFAULT=true
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='Linux Lite'
#GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_DISTRIBUTOR=`lsb_release -d 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Linux Lite Grub background
GRUB_BACKGROUND="/boot/grub_linux_lite.png"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
GRUB_GFXPAYLOAD_LINUX="keep"
GRUB_VIDEO_BACKEND="vbe"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


Edit: I just looked at the boot log and
there are seemingly countless occurances
of starting light display manager and within
each occurance it is trying to start vboxadd.service.

Could this have anything to do with the slow boot time ?
Last Edit: September 04, 2019, 06:24:42 PM by arky217
 


Re: Lite now taking 3 minutes to boot
« Reply #1 on: September 04, 2019, 04:20:46 AM »
 

Artim

  • Always Learning
  • PayPal Supporter
  • I come here a lot
  • *****
  • 396
    Posts
  • Country: us
  • Reputation: 56
  • small but still awesome
    • Confessions of a Technophobe

  • Linux Lite: 3.8 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz

  • MEMORY: 3Gb

  • VIDEO CARD: Mobile GM965/GL960 Integrated Graphics Controller

  • Kernel: 5.x
Yup.  It's the vboxadd.service that is likely the issue.

You can uncheck it from the startup routine using Menu--> Settings --> Session & Startup, then click on the Application Autostart tab and UNCHECK vbox.


 

Re: Lite now taking 3 minutes to boot
« Reply #2 on: September 04, 2019, 10:17:14 AM »
 

arky217

  • New to Forums
  • *
  • 36
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Pentium Gold G5400

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 610

  • Kernel: 4.x
Yup.  It's the vboxadd.service that is likely the issue.

You can uncheck it from the startup routine using Menu--> Settings --> Session & Startup, then click on the Application Autostart tab and UNCHECK vbox.

I did that and rebooted, but it made no difference; still takes nearly 3 minutes to boot.
 

Re: Lite now taking 3 minutes to boot
« Reply #3 on: September 04, 2019, 11:06:24 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7385
    Posts
  • Country: nz
  • Reputation: 694
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960

  • Kernel: 4.x
 

Re: Lite now taking 3 minutes to boot
« Reply #4 on: September 04, 2019, 12:18:38 PM »
 

arky217

  • New to Forums
  • *
  • 36
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Pentium Gold G5400

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 610

  • Kernel: 4.x
See the 'Performance Tips' here - https://www.linuxliteos.com/forums/release-announcements/linux-lite-4-0-final-released/

I unchecked vboxclient in the startup and I ran all the following:

Code: [Select]
sudo apt purge virtualbox*
sudo systemctl stop vboxadd.service
sudo systemctl stop vboxadd-service.service
sudo systemctl disable vboxadd.service
sudo systemctl disable vboxadd-service.service


Then I rebooted but still same slow boot, 3 minutes.
 

Re: Lite now taking 3 minutes to boot
« Reply #5 on: September 04, 2019, 04:50:16 PM »
 

arky217

  • New to Forums
  • *
  • 36
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Pentium Gold G5400

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 610

  • Kernel: 4.x
Well, I found the problem of the long boot time.
When I deleted the partition of another os on the drive,
I also deleted the swap partition which was 12Gb
because I never use more than 2 or 3 Gb of the 12
Gb of ram that I have.

I figured that with 12Gb of ram, the computer would never
use the swap partition.

So, I had to edit /etc/fstab and remove the reference to
that swap partition that I deleted so that the boot up
would not be trying to find a partition that no longer exists.

That changed the boot time from 3 minutes to 20 seconds.

But that raises a question:
If the computer ever did have to use swap, would it just use
a swap file ?
I've read that with Ubuntu 18.04 and its forks, a swap file is
automatically created upon installation.

When installing Lite from scratch, is a swap file created ?

I searched for a file called swapfile and
there is one. Does that mean that if the computer were to need
to use swap, would it automatically use that swap file, or is there
something that needs to be done to activate that swap file ?
 

Re: Lite now taking 3 minutes to boot
« Reply #6 on: September 04, 2019, 05:23:40 PM »
 

minesheep

  • Forum Regular
  • ***
  • 116
    Posts
  • Country: fi
  • Reputation: 9
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • MEMORY: 4Gb
Ubuntu 18.04 LTS and Linux lite 4.x won't create swap partition by default instead they make swapfile or use swap partition made by another distro. Not sure if they use both or not, partition (another distro) and file (own). When you installed one of your 2 other distros before installing linux lite thay made their own swap partition(s) and when you installed linux lite it just marked that partition so it was used by both distros.
 


Tags:
 


Linux Lite 4.8 Final is now available for download and installation