You are Here:
Download Linux Lite 5.6 RC1 for testing today - See Release Announcements

X Close Ad
X Close Ad
Computer cannot wake after auto-suspending itself

Author (Read 2938 times)

0 Members and 1 Guest are viewing this topic.

Computer cannot wake after auto-suspending itself
« on: January 13, 2018, 10:48:19 PM »


  • New to Forums
  • *
  • 1
  • Country: ca
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.6 64bit

  • CPU: MacMini 2.1, 2x Intel(R) Core(TM)2 CPU, T7200 @ 2.00GHz

  • MEMORY: 2Gb

  • VIDEO CARD: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

I have MacMini 2.1, Core2Duo @ 2 GHz, 2 GB RAM, running Linux Lite 3.6 (x64), kernel 4.4.0-93-generic.

LL runs very smoothly on it. I'm very pleased. The only problem is my MacMini cannot wake after being auto-suspended (based on Power Management setting). What is interesting is that if I see the computer going to sleep and shortly go and press the power button to wake it up, it will. Bit if I leave it overnight, the next day when I press the power button, it only shows a black screen and never wakes up (it just hangs) and I have to restart it.

I tried to fix this by reading various posts, but it's not working great. I have the following setting in GRUB:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=/de/sda3 video=1280x1024 reboot=warm,cold,bios,smp,triple,kbd,acpi,efi,pci,force"


In The Power Management settings I have:

System Sleep mode - suspend after 30 minutes being inactive

(the other settings I did not specify since  think they are not relevant to the problem)

I used this MacMini with Bootcamp which I usually booted to Win7 and the sleep/suspend modes were working correctly (same for the OSX on the maachine). Also, I could wake the computer by just clicking with the mouse or pressing a key (while with LL I had to press the power button).

I'd appreciate any help on my issue? Thank you!



Re: Computer cannot wake after auto-suspending itself
« Reply #1 on: November 16, 2019, 06:28:08 AM »


  • New to Forums
  • *
  • 41
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
I have the same problem, different box. Tried wiggling the mouse, hitting various keys, esc, ctrl, ..., and tapping the power button. Solid black screen. Had to reboot.

Here's my box info from:
Code: [Select]
sudo dmidecode -t 1
# dmidecode 3.1
Getting SMBIOS data from sysfs.
SMBIOS 2.6 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
Manufacturer: Acer
Product Name: Aspire Z5700
Serial Number: PWSDC020201110100D6900
UUID: 60EE8D30-EB60-DE69-64EC-4E45435F4349
Wake-up Type: Power Switch
SKU Number:                 

Thank you.
jerryc, not to be confused with the real Jerry who developed this distro.

Re: Computer cannot wake after auto-suspending itself
« Reply #2 on: March 02, 2020, 04:55:57 PM »


  • Forum Regular
  • ***
  • 137
  • Country: fi
  • Reputation: 11
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • MEMORY: 4Gb

  • Kernel: 5.x
Useless fix!
Nothing new to me try ctrl+alt+f2,f3,f4,f5,f6
log in with your username and password even when it is not shown when you type it. then hit enter
type sudo htop
type your password again and hit enter
use arrow keys and find Xorg
kill it with f9 and send "sigkill" to Xorg
press ctrl+alt+f7
Done all programs gone thats it. a faster way to fix it (Xorg fixed). Sometimes reboot needs to be more fun now it is.


X Close Ad
X Close Ad

Download Linux Lite 5.6 RC1 for testing today - See Release Announcements