You are Here:
Linux Lite 4.2 Final has been released. See the Release Announcements Section.



Alt-Gr+~+n does not work

Author (Read 225 times)

0 Members and 7 Guests are viewing this topic.

Alt-Gr+~+n does not work
« on: December 06, 2018, 09:00:05 AM »
 

gagudelop

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 2.4 64bit

  • CPU: i7

  • MEMORY: 8Gb

  • VIDEO CARD: Xeon E3-1200 v3/4th Gen
Hello,I just upgraded from LL 3.4 to LL 4.2. Unfortunatelly I can't write the Spanish character ñ
I am using English Language setting and a Microsoft Natural Ergonomic 400, German Keyword
Before upgrade I could use key combination Alg Gr+~ and then n to enter that character. Now this is not more working. It looks like the AlgGr does not work in that particular case, because the two keys combination (AltGr+q=@ or AltGr+e=€) works perfectly.
A combination with AltGt+0164 does not work as well.

Any help please?

Greetings
 


Re: Alt-Gr+~+n does not work
« Reply #1 on: December 06, 2018, 10:42:53 AM »
 

Moltke

  • Moderator
  • I come here a lot
  • *****
  • 392
    Posts
  • Country: ve
  • Reputation: 60
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750
Hola @gagudelop

Primero, este foro esta pensado para plantear inquietudes en idioma Español, no en Ingles, para eso esta el foro principal. Sin embargo, en relación a tu asunto, lo que puedo decirte es que en la netbook de mi esposa, el teclado no tiene la letra ñ, pero esta està luego de la letra L en donde se supone están estos dos signos ": ;", claro el teclado esta en Español así que no se si esto te sera de ayuda o no.
Without each others help there ain't no hope for us :)
 

Re: Alt-Gr+~+n does not work
« Reply #2 on: December 06, 2018, 08:11:01 PM »
 

gagudelop

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 2.4 64bit

  • CPU: i7

  • MEMORY: 8Gb

  • VIDEO CARD: Xeon E3-1200 v3/4th Gen
Hello Moltke,
Thanks for you answer. The layout of my keyboard is german. Beside the "l" is the letter "ö" located.
 

Re: Alt-Gr+~+n does not work
« Reply #3 on: December 07, 2018, 06:44:41 AM »
 

Moltke

  • Moderator
  • I come here a lot
  • *****
  • 392
    Posts
  • Country: ve
  • Reputation: 60
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750
Hello Moltke,
Thanks for you answer. The layout of my keyboard is german. Beside the "l" is the letter "ö" located.

Hmmm...well, maybe you should try changing your keyboard layout when writing in Spanish? Or, get/use a virtual keyboard with a Spanish layout. Sorry, but since I don't have and never have had this problem cause my keyboard's Spanish this is all I can think of.

EDIT: On a second thought, it might pay taking a look at keyboard settings and changing the keyboard type for something that supports "AltGr+n" so instead of "generic keyboard" try something like "dead keys" or whatever that works for you...just an idea.
Last Edit: December 07, 2018, 06:55:18 AM by Moltke
Without each others help there ain't no hope for us :)
 

Re: Alt-Gr+~+n does not work
« Reply #4 on: December 07, 2018, 07:01:24 AM »
 

Moltke

  • Moderator
  • I come here a lot
  • *****
  • 392
    Posts
  • Country: ve
  • Reputation: 60
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750
Hi @gagudelop 

Googling on your issue I found this post which describes a similar situation like yours and offers a solution so it might worth taking a look at it https://askubuntu.com/questions/779448/how-to-enable-alt-gr-on-ubuntu-16-04

Hope this helps! :)
Without each others help there ain't no hope for us :)
 

Re: Alt-Gr+~+n does not work
« Reply #5 on: December 07, 2018, 09:05:45 AM »
 

gagudelop

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 2.4 64bit

  • CPU: i7

  • MEMORY: 8Gb

  • VIDEO CARD: Xeon E3-1200 v3/4th Gen
Hi Moltke,
Thank again.
Nothing of that works. The LL4.2 is based on Ubuntu LTS 18.04.1 (not 16...). Setting->Keyword is different. The settings I have is correct except for typing a spacial character in 3 hints: AltGr+~ and then n. The key understand well (like I said) the other special characters showing in the key as a third character, like "\" or "{", etc.
 

Re: Alt-Gr+~+n does not work
« Reply #6 on: December 07, 2018, 09:33:12 AM »
 

Moltke

  • Moderator
  • I come here a lot
  • *****
  • 392
    Posts
  • Country: ve
  • Reputation: 60
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750
Hi Moltke,
Thank again.
Nothing of that works. The LL4.2 is based on Ubuntu LTS 18.04.1 (not 16...). Setting->Keyword is different. The settings I have is correct except for typing a spacial character in 3 hints: AltGr+~ and then n. The key understand well (like I said) the other special characters showing in the key as a third character, like "\" or "{", etc.

You're right @gagudelop , didn't think of that releases differences. I googled "getting Spanish characters in a german keyboard" and found this post http://www.spanishdict.com/answers/282262/how-to-type-spanish-letters-and-accents-from-paralee I don't know if that works but you can try and see if it does for you. 
Without each others help there ain't no hope for us :)
 

Re: Alt-Gr+~+n does not work
« Reply #7 on: December 07, 2018, 09:56:47 AM »
 

gagudelop

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 2.4 64bit

  • CPU: i7

  • MEMORY: 8Gb

  • VIDEO CARD: Xeon E3-1200 v3/4th Gen
Thanks.
No success.
Strange! The keyword is listed in the settings: MS Natural ergonimic 400, german Layout. It worked perfectly in all the former releases of LL. I think it has to do with the new release... Maybe a bug?
I write a lot in German and Spanish. I would not like to change my Keyword cos of ergonomic and of the layout. Till now I did not have any issues with it... But it is an issue to upgrade Linux...
 


Tags: keyword 
 


Linux Lite 4.2 Final has been released. See the Release Announcements Section.