You are Here:
Linux Lite 6.0 Final Released - See Release Announcements



System doesn't recognize sound-card

Author (Read 533 times)

0 Members and 3 Guests are viewing this topic.

System doesn't recognize sound-card
« on: July 27, 2022, 09:07:30 PM »
 

HantonTreeOne *

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 0
  • Hi!

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i5-10210U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel CometLake-U GT2

  • Kernel: 5.x
Hi, I'm been searching for this solution but it seems that there is no way to solve it xD
well, this are some outputs that I took

Code: [Select]
inxi -F
System:
  Host: hto-machine Kernel: 5.15.0-41-generic x86_64 bits: 64
  Desktop: Xfce 4.16.0 Distro: Linux Lite 6.0 LTS
Machine:
  Type: Laptop System: HUAWEI product: BOHB-WAX9 v: M1120
  serial: <superuser/root required>
  Mobo: HUAWEI model: BOHB-WAX9-PCB-B2 v: M1120
  serial: <superuser/root required> UEFI: HUAWEI v: 1.42 date: 03/25/2022
Battery:
  ID-1: BAT1 charge: 36.1 Wh condition: 41.5/41.6 Wh (100%)
CPU:
  Topology: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP
  L2 cache: 6144 KiB
  Speed: 900 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 900 2: 900
  3: 900 4: 900 5: 900 6: 900 7: 900 8: 900
Graphics:
  Device-1: Intel CometLake-U GT2 [UHD Graphics] driver: i915 v: kernel
  Display: x11 server: X.Org 1.21.1.3 driver: modesetting
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.0.1
Audio:
  Device-1: Intel Comet Lake PCH-LP cAVS driver: snd_hda_intel
  Device-2: ZhuHai JieLi JieLi AC46 type: USB
  driver: hid-generic,snd-usb-audio,usb-storage,usbhid
  Sound Server: ALSA v: k5.15.0-41-generic
Network:
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi
  IF: wlp0s20f3 state: up mac: 7c:70:db:2a:29:07
Drives:
  Local Storage: total: 476.94 GiB used: 57.77 GiB (12.1%)
  ID-1: /dev/nvme0n1 model: 311CD0512GB size: 476.94 GiB
Partition:
  ID-1: / size: 255.67 GiB used: 57.72 GiB (22.6%) fs: ext4
  dev: /dev/nvme0n1p8
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 297 Uptime: 1h 25m Memory: 7.51 GiB used: 1.89 GiB (25.2%)
  Shell: zsh inxi: 3.0.38

pulseaudio doesn't work either :(
here is a video
I have dual boot with Windows 10, in Windows the audio works fine, but when I switch to Linux Lite 6, the output of the audio mixer is dummy output
Thanks if someone can help  :)

« Last Edit: July 31, 2022, 02:50:41 PM by HantonTreeOne * »
 

Re: System doesn't recognize sound-card
« Reply #1 on: July 28, 2022, 02:26:23 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8426
    Posts
  • Reputation: 783
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Some tips for your post. Terminal output should be used with the code tags so people can search your issue simply by copying and pasting the output, pictures and videos need to be embedded, People are usually reluctant to click on external links for fear they could be malicious. See here for guidance - https://www.linuxliteos.com/forums/introductions/forum-posting-guidelines/

Also this is not a 'Bug' it's a sound issue that requires support. So it's been moved to the correct section.

https://www.linuxliteos.com/forums/security-bug-fixes/bug-reports-how-to/
« Last Edit: July 28, 2022, 03:39:41 AM by Jerry »
 

Re: System doesn't recognize sound-card
« Reply #2 on: July 28, 2022, 02:37:09 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8426
    Posts
  • Reputation: 783
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
See if the device is listed and or Muted in:

Code: [Select]
alsamixer
F6 to select sound card.

Show the output of:

Code: [Select]
inxi -zaA
« Last Edit: July 28, 2022, 02:40:27 AM by Jerry »
 

Re: System doesn't recognize sound-card
« Reply #3 on: July 31, 2022, 02:40:11 PM »
 

HantonTreeOne *

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 0
  • Hi!

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i5-10210U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel CometLake-U GT2

  • Kernel: 5.x
Hi!, thanks for the recommendations.
This are the images of the code
Code: [Select]
alsamixer



In the next image there's a second default device because I connected a USB speaker




Now this is the output of

Code: [Select]
inxi -zaA
Code: [Select]
Audio:
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: QUANTA
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:02c8
  Device-2: ZhuHai JieLi JieLi AC46 type: USB
  driver: hid-generic,snd-usb-audio,usb-storage,usbhid bus ID: 1-4:10
  chip ID: e5b7:0811 serial: <filter>
  Sound Server: ALSA v: k5.15.0-41-generic

The second device is the speaker that I'm using.
Those are all the outputs :)
« Last Edit: July 31, 2022, 02:44:01 PM by HantonTreeOne * »
 

Re: System doesn't recognize sound-card
« Reply #4 on: July 31, 2022, 04:11:24 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8426
    Posts
  • Reputation: 783
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
F6 to select sound card as requested please. Need a screenshot of the HDA Intel PCH device being selected.
 

Re: System doesn't recognize sound-card
« Reply #5 on: August 01, 2022, 09:00:10 PM »
 

HantonTreeOne *

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 0
  • Hi!

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i5-10210U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel CometLake-U GT2

  • Kernel: 5.x
Hi, here it is the image :)

« Last Edit: August 01, 2022, 09:01:58 PM by HantonTreeOne * »
 

Re: System doesn't recognize sound-card
« Reply #6 on: August 01, 2022, 09:48:25 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8426
    Posts
  • Reputation: 783
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Select Playback and send another screenshot please.

Sent from my Mobile phone using Tapatalk

 

Re: System doesn't recognize sound-card
« Reply #7 on: August 01, 2022, 10:29:37 PM »
 

HantonTreeOne *

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 0
  • Hi!

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i5-10210U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel CometLake-U GT2

  • Kernel: 5.x
It's already in playback :(
Here is with the All option


Btw, I ran the command
Code: [Select]
alsa-info and here's the output
http://alsa-project.org/db/?f=40685562cacba603acb577f9e0444831de6dcacc (I know it's a link but in the recommended way, crash the entire page)
« Last Edit: August 01, 2022, 10:33:04 PM by HantonTreeOne * »
 

Re: System doesn't recognize sound-card
« Reply #8 on: August 02, 2022, 04:25:22 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8426
    Posts
  • Reputation: 783
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
In a Terminal try:

Code: [Select]
sudo apt-get update
Code: [Select]
sudo apt-get -y install firmware-sof-signed
Reboot, and see if it shows up in Volume Control.
 

Re: System doesn't recognize sound-card
« Reply #9 on: August 02, 2022, 09:55:16 PM »
 

HantonTreeOne *

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 0
  • Hi!

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i5-10210U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel CometLake-U GT2

  • Kernel: 5.x
It says that the package is already installed

 

These are the volume settings in pavucontrol

 

 

Re: System doesn't recognize sound-card
« Reply #10 on: August 02, 2022, 10:17:32 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8426
    Posts
  • Reputation: 783
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
You'll probably just need to add a Kernel parameter then. You can either search for the correct string or wait for me to find it.

Sent from my Mobile phone using Tapatalk

 

Re: System doesn't recognize sound-card
« Reply #11 on: August 02, 2022, 10:57:21 PM »
 

HantonTreeOne *

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 0
  • Hi!

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i5-10210U

  • MEMORY: 8Gb

  • VIDEO CARD: Intel CometLake-U GT2

  • Kernel: 5.x
Okey, I'll wait  :)
( Also if I try something, I will post it here :) )
« Last Edit: August 03, 2022, 07:24:22 PM by HantonTreeOne * »
 

Re: System doesn't recognize sound-card
« Reply #12 on: August 03, 2022, 09:50:15 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8426
    Posts
  • Reputation: 783
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.0 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Try the following:

Open your /etc/default/grub as Administrator.

Change:

Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to:

Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"
Open a Terminal and do:

Code: [Select]
sudo update-grub
Reboot.

Cross your fingers (and toes) :)
 

 

-->
X Close Ad

Linux Lite 6.0 Final Released - See Release Announcements