Hardware - Support > Sound

Reboot needed to restore USB audio

<< < (2/4) > >>

oldwood:
I will give that a try. It is odd because sometimes I can re-plug the USB to the DAC and it pops up while other times it needs a reboot. I have tried turning the DAC off and back on but that does not do anything.

Thanks,
Gerry

oldwood:

--- Quote from: TheDead on January 04, 2021, 07:40:21 AM ---I have not checked if 5.x still uses pulseaudio and could be unrelated but just in case...

Before opening any apps, open a terminal and enter the command :

sudo pulseaudio --kill

Then check if the audio workz! ;)

I gave this a try and get the response, failed to kill daemon: no such process.

In ALSAMIXER pulse audio is listed so maybe I am doing something wrong?

--- End quote ---

oldwood:
So I am still trying to get the OS to see the Emotiva USB DAC on resume from sleep. Sometimes re-plugging works sometimes it does not, sometimes a re-boot works and sometimes it does not.

I tried alsactl restore and got a more informative output but it does not connect the DAC. I have attached the screenshot, it is a png file.

I have a Asus Xonar U7 mk2 DAC and it is found and is connected on resume from sleep but I would like to use the Emotiva DAC if possible. The Xonar USB is USB powered so maybe that is why it is seen and connected on resume?

I don't know what triggers the connection of the USB DAC or if I can force it to re-scan and connect.

Any and all suggestions are welcomed.

Thanks,
Gerry

TheDead:
Hi,

Your problem seems "deeper" than just the sound engine.
Maybe a Linux guru (or a web search?) could tell you how reset a linux "device" and not just the sound engine.

Maybe activating the "Plug and play" function in the BIOS? but that seems like a shot in the dark.

oldwood:
So I might have found a solution. I think the problem is related to USB auto suspend. I disabled auto suspend by following this guide.

https://ywjheart.wordpress.com/2018/07/17/disable-usb-auto-suspend-in-ubuntu-debian/

I will post back after a while when I know if it stays connected.

Thanks guys for your suggestions.

Gerry

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version