Linux Lite Forums

Hardware - Support => Sound => Topic started by: crunch182 on February 14, 2014, 05:51:03 AM

Title: No sound
Post by: crunch182 on February 14, 2014, 05:51:03 AM
hi guys,

I am a newbie and recently I was troubleshooting my sound - which at the time was crackling - but now I have no sound, to which I sound card is not detected or is deleted.  Can you please help?  I tried following the sound troubleshooting in the manual options for my OS and this is what I got up to.

I really can't stand no sound - no music, no videos, mo' problems.  Anywho, so I have browsed a lot of different areas and I have no access capabilities which may be the problem? In the sound control panel I have no output or no sound cards to configure.

It seems to me the system is recognizing drivers and all that and when looking I'm not I have the right compatitibility either:

The first link shows the troubleshooting I have done in terminal (sorry if it's a bit excessive):



I have attached files for any hopefully helpful information.

[attachment deleted by admin, more than 25 days old]
Title: Re: No sound
Post by: shaggytwodope on February 14, 2014, 07:18:48 AM
I need you to upload full contents of two files, both the file:


Now I ask you, have you edited /etc/modprobe.d/alsa-base.conf before issues began?

Just FYI, the system report attached isnt complete. If you can attach a full report that'd be good.
Title: Re: No sound
Post by: crunch182 on February 14, 2014, 10:23:23 AM
In all honesty I can't remember whether I modified the files, but I do know what during my troubleshooting I entered a command to 'kill' or 'killall' something?


I'll regenerate the system report to make solving this problem easier.

System report:
Title: Re: No sound
Post by: shaggytwodope on February 14, 2014, 10:52:24 AM
The contents of the file
Code: [Select]
options snd-hda-intel model=dell-headset-multi
sudo alsa force-reload
sudo gedit /etc/modprobe.d/alsa-base
options snd-hda-intel dell-headset-multi
killall pulseaudio

sudo alsa force-reload

pulseaudio -D


Is made up of items you do not need, most likely saved from using some text editor, (the .save part)
(it's also an exact duplicate of alsa-base.conf )
Let us remove this file entirely typing this into a terminal:

Code: [Select]
sudo rm /etc/modprobe.d/

Now proceed to attempt loading the module:

Code: [Select]
sudo modprobe snd_hda_intel

Please report back on success or failure, and we can try a few other steps if need be. You may need to reboot to make reloading things easier.
Title: Re: No sound
Post by: Jerry on February 14, 2014, 11:33:16 AM
Folks, please don't attach photos. Use an external website or we will run out of disk space in time. I recommend Thank you :)
Title: Re: No sound again! Cannot figure how to stop stuttering once installed?!
Post by: crunch182 on February 24, 2014, 10:12:42 AM
Ok, back in this circle track again! Getting really frustrated pretty much same situation again.  Tried configuring my sound card somehow to stop stuttering audio - and now I have lost it again.

I believed I have the right modules etc. but cannot install

Code: [Select]
sudo modprobe snd_hda_intel [code]

Help please.
Title: Re: No sound
Post by: crunch182 on February 25, 2014, 05:19:27 AM
I do believe I have a problem with my configuration files in the path /etc/modprobe.d/ the alsa base files as I am unable to edit them and cannot load or unpack the driver files to have an output for sound.

My current system state is incredulously annoying and no doubt annoying to others.  I have tried following the audio installation guide but am stuck instantly and many directions I follow lead to permissions denied or unknown command or even directory not found or similar.
Title: Re: No sound
Post by: Jerry on February 25, 2014, 05:32:13 AM
crunch, documentation and instruction are your only resources. Perhaps a fresh install and some practice in a virtual machine would be better at your current level. Until you get used to playing around with linux. Linux shouldn't be difficult to use, you just have a peice of hardware that is not well supported. That is no fault of linux, the hardware vendors have to step up and provide better drivers etc.