You are Here:
Download Linux Lite 5.4 RC1 today - See Release Announcements



[ ABANDONED ] Set Default Playback Device HDMI

Author (Read 6580 times)

0 Members and 1 Guest are viewing this topic.

Set Default Playback Device HDMI
« on: May 12, 2016, 06:30:23 PM »
 

Duckeenie

  • Occasional Poster
  • **
  • 93
    Posts
  • Country: 00
  • Reputation: 11
  • Linux Lite Member

  • Linux Lite: 2.6 64bit

  • CPU: Intel i3-4130

  • MEMORY: 6Gb

  • VIDEO CARD: Nvidia 740
Unlike on Ubuntu 16.04 vanilla, on  a new install of any of the 2.x, 3.x series of Linux Lite my default playback device is always set to HDMI  even though my monitor doesn't have speakers.  My audio device is a USB DAC that works fine with LL once I change the default sink.


Small thing I know but it mars the out of the box experience slightly for me, is it something you can/is worth addressing?
Last Edit: September 20, 2016, 01:05:13 AM by Jerry
Don't believe half of what you see and none of what you hear

- Lou Reed
 


Re: Set Default Playback Device HDMI
« Reply #1 on: May 12, 2016, 06:41:07 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1564
    Posts
  • Country: us
  • Reputation: 254
  • * Forum Moderator *

  • Linux Lite: 4.8 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

  • Kernel: 4.x
Duckeenie,

How do you change the default?  Whenever I connect my laptop to my television, I always have to open the Volume Control, go to the Configuration tab, and select the appropriate Profile.  I have to reverse this when I disconnect my laptop from my television.
Want to thank me?  Click my [Thank] link.
 

Re: Set Default Playback Device HDMI
« Reply #2 on: May 12, 2016, 06:55:34 PM »
 

Duckeenie

  • Occasional Poster
  • **
  • 93
    Posts
  • Country: 00
  • Reputation: 11
  • Linux Lite Member

  • Linux Lite: 2.6 64bit

  • CPU: Intel i3-4130

  • MEMORY: 6Gb

  • VIDEO CARD: Nvidia 740
Duckeenie,

How do you change the default?  Whenever I connect my laptop to my television, I always have to open the Volume Control, go to the Configuration tab, and select the appropriate Profile.  I have to reverse this when I disconnect my laptop from my television.

It's been a while(haven't got around to it on 3 yet, just disabled hdmi as quick workaround) but from my bookmark and memory I believe I used the first two lines of the answer found here: http://askubuntu.com/questions/14077/how-can-i-change-the-default-audio-device-from-command-line

Update: Just tried the above, seems on my machine default is set to 1, 0 would be the correct sink.

However, I sense that you're looking for it to auto-switch when you change the device though, in which case my method won't work for you. I just don't want LL to set the device that has no audio capability as default.
Last Edit: May 12, 2016, 07:36:42 PM by Duckeenie
Don't believe half of what you see and none of what you hear

- Lou Reed
 

Re: Set Default Playback Device HDMI
« Reply #3 on: May 26, 2016, 05:46:13 PM »
 

jcoles

  • New to Forums
  • *
  • 14
    Posts
  • Reputation: 4
  • Linux Lite Member

  • CPU: AMD

  • MEMORY: 2Gb

  • VIDEO CARD: don't know
I had the same problem on an Asus eeePC X101CH. There was no sound from the speaker, even with volume at 100%.

A partial solution is to change the channel being controlled to Headphone. In the panel, right-click the volume control and click Preferences. It's only a partial solution because Lite always starts with the sound level at 0. You can easily turn up the volume, but if you plug in headphones and then unplug them, the volume control once again returns to zero.
Last Edit: May 26, 2016, 10:08:08 PM by jcoles
 

Re: Set Default Playback Device HDMI
« Reply #4 on: May 26, 2016, 06:20:32 PM »
 

Wirezfree

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1484
    Posts
  • Country: gb
  • Reputation: 404
  • Linux Lite "Advocate"

  • Linux Lite: 2.8 64bit

  • CPU: i7-4790S

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD4600 (Integrated)
Not sure if it's the same.?
But when my HDMI default changed,
I opened volume control, Output Devices tab and click on the tick mark to make it default, the tool tip says "Set as fallback"
Upgrades WIP 2.6 to 2.8 - (6 X 2.6 to 2.8 completed on: 20/02/16 All O.K )
Linux Lite 3.0 Humming on a ASRock N3070 Mobo ~ btrfs RAID 10 Install on 4 Disks :)

Computers Early days:
ZX Spectrum(1982) , HP-150 MS-DOS(1983) , Amstrad CPC464(1984) ,  BBC Micro B+64(1985) , My First PC HP-Vectra(1987)
 

Re: Set Default Playback Device HDMI
« Reply #5 on: June 02, 2016, 07:58:53 PM »
 

Duckeenie

  • Occasional Poster
  • **
  • 93
    Posts
  • Country: 00
  • Reputation: 11
  • Linux Lite Member

  • Linux Lite: 2.6 64bit

  • CPU: Intel i3-4130

  • MEMORY: 6Gb

  • VIDEO CARD: Nvidia 740
@Wirezfree My problem is more with LL setting a non audio device as default. It seems to assume that anything attached to an HDMI cable does audio, monitors more often that not don't.
Don't believe half of what you see and none of what you hear

- Lou Reed
 

Re: Set Default Playback Device HDMI
« Reply #6 on: June 02, 2016, 08:29:43 PM »
 

Wirezfree

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1484
    Posts
  • Country: gb
  • Reputation: 404
  • Linux Lite "Advocate"

  • Linux Lite: 2.8 64bit

  • CPU: i7-4790S

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD4600 (Integrated)
So if I understand correctly..??
Your USB Audio device is showing on that "Output Device" page.??
But it will not retain the "Set as fall-back" [X] selection, after a re-boot.

Does this help?: http://askubuntu.com/questions/398030/change-default-sound-device
See the pacmd comands/comments by bak202

Mine shows the on-board Audio,
and my HDMI in my monitor, which is clicked to "Set as fall-back"
Upgrades WIP 2.6 to 2.8 - (6 X 2.6 to 2.8 completed on: 20/02/16 All O.K )
Linux Lite 3.0 Humming on a ASRock N3070 Mobo ~ btrfs RAID 10 Install on 4 Disks :)

Computers Early days:
ZX Spectrum(1982) , HP-150 MS-DOS(1983) , Amstrad CPC464(1984) ,  BBC Micro B+64(1985) , My First PC HP-Vectra(1987)
 

Re: Set Default Playback Device HDMI
« Reply #7 on: June 03, 2016, 08:13:27 AM »
 

Duckeenie

  • Occasional Poster
  • **
  • 93
    Posts
  • Country: 00
  • Reputation: 11
  • Linux Lite Member

  • Linux Lite: 2.6 64bit

  • CPU: Intel i3-4130

  • MEMORY: 6Gb

  • VIDEO CARD: Nvidia 740
@Wirezfree No! :)

Mine shows both HDMI, which LL sets as default and my USB audio device.  The irritation here is that the HDMI cable in question isn't connected to an audio device , therefore shouldn't even be in Output Devices,  let alone set as default.
Don't believe half of what you see and none of what you hear

- Lou Reed
 

Re: Set Default Playback Device HDMI
« Reply #8 on: June 03, 2016, 10:41:08 AM »
 

Wirezfree

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1484
    Posts
  • Country: gb
  • Reputation: 404
  • Linux Lite "Advocate"

  • Linux Lite: 2.8 64bit

  • CPU: i7-4790S

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD4600 (Integrated)
Hi,

It looks like it is being mis-read, and thinks it's a HDMI device.?
If you run the command pacmd in that link I gave, it should show "2" devices, #1 & #2
You maybe able to see a difference.?,
and then use the other commands to force it to use the device you want

I just checked with a Syba USB Audio device I have, it's a C_Media, shown with lsusb
It see's it correctly, and I can set it as default if I wanted.
Note,
I'm still on 2.8, so yes, something may have changed in 3.0.?

Upgrades WIP 2.6 to 2.8 - (6 X 2.6 to 2.8 completed on: 20/02/16 All O.K )
Linux Lite 3.0 Humming on a ASRock N3070 Mobo ~ btrfs RAID 10 Install on 4 Disks :)

Computers Early days:
ZX Spectrum(1982) , HP-150 MS-DOS(1983) , Amstrad CPC464(1984) ,  BBC Micro B+64(1985) , My First PC HP-Vectra(1987)
 

Re: Set Default Playback Device HDMI
« Reply #9 on: June 24, 2016, 12:18:27 AM »
 

aus9

  • Occasional Poster
  • **
  • 54
    Posts
  • Country: au
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 3.0 64bit

  • CPU: 4 core i5-4590 CPU @ 3.30GHz

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Corporation Xeon E3-1200
Good Luck
 


Tags:
 


Download Linux Lite 5.4 RC1 today - See Release Announcements