Hardware - Support > Sound

libasound2 not working after update

(1/5) > >>

j8a:
Hi,
Today I did an update, Thunderbird was updated.
Then, I realize that the sound is lost, the volume control pops up frequently, whether I check the configuration in the Manual and run alsamixer I have no idea what is happening.
I upload the report of my system in order to recieve any help.
I could see the sound in the audio control panel and also while I run a test in the terminal with the command:
speaker-test -c 2


Regards

j8a:
I recieved the updates attached today.
I did try to listen mp3 files with vlc, but I have no success.
I also check the audio on the speakers with another pc, I can hear videos and audio without problems.

I booted on a different kernel BTW, but nothing happened.

That's all for today, regards.

j8a:
I also tried to boot on live LL 5.0 and the same problem continues.

Then, under LL 5.4 I run journalctl -f and the following message appeared:

jochoa-pc pulseaudio[2275]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply.
Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply,
the reply timeout expired, or the network connection was broken.jochoa-pc pulseaudio[2275]: GetManagedObjects()
failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply,
the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I could not saw any messages running journalctl -f whether I tried to play either a mp3 music track or a Youtube video.

I also run lsmod | grep video and lsmod | grep audio and the terminal outputs where the following:

lsmod | grep audio
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek

lsmod | grep video
video                  49152  1 nouveau

Hope this help, regards.

TheDead:
Hi!
Could be old news since I used this in 4.x, but...
If you have your monitor in HDMI, it could be that the output tries to go there, check in the audio outputs that the right one is selected.
You could also try this... when everything is closed, open a terminal and do : sudo pulseaudio -k (or --k, can't remember) to "kill" the audio outputs, running an application after should restart this process automatically.

j8a:
Hi @TheDead ,
Thank you for your answer.

I tried sudo pulseaudio -k and the following message apperared.
 [pulseaudio] main.c: The daemon could not be stopped. The process does not exists.

I also tried,
systemctl status pulseaudio-enable-autospawn.service
● pulseaudio-enable-autospawn.service
     Loaded: masked (Reason: Unit pulseaudio-enable-autospawn.service is masked>
     Active: inactive (dead)

At last I run,
journalctl -f -t pulseaudio and the following message appeared:
may 10 09:23:23 jochoa-pc pulseaudio[2251]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I have PolicyKit Authentication Agent enable in the Session and Startup section under autostart commands, while the system is booting.
I also the following autostart commands in this panel.
System Sound Pulse Audio
Login Sound (which I can not hear anymore)



Regards

Navigation

[0] Message Index

[#] Next page

Go to full version