You are Here:
Install Updates Gimp Error - see Security & Bug Fixes Section Sticky



linux lite 3.8 sound problem

Author (Read 1465 times)

0 Members and 1 Guest are viewing this topic.

linux lite 3.8 sound problem
« on: March 04, 2019, 05:14:42 PM »
 

PsaCrypt

  • New to Forums
  • *
  • 11
    Posts
  • Country: es
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit
i have a problem with lite 3.8 and mint 17.3:  booting them in one of my machines, sound does not run.  does not recognize speakers.  alsa runs fine, i think the problem is caused at pulseaudio.  booting that machine using tinycore linux, with alsa and pulseaudio too, sound system runs fine with speakers.  that machine is toshiba nb110.   :-(

anyone can help with this error?
 


Re: linux lite 3.8 sound problem
« Reply #1 on: March 04, 2019, 06:12:59 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1168
    Posts
  • Country: us
  • Reputation: 225
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880
May want to ensure the volume is up and not muted, there is a mute check box from the toolbar (increasing volume doesn't necessarily un-mute it).
Also, open Volume Control (from Menu), ensure under Playback and under Output Devices, options are not muted - hover over the speaker icon..
On mine the toolbar mute and Output Devices will mute each other - Playback does not if one set is muted - no sounds..

If all are not muted, may want to post the output of the below to ensure not a driver issue...
Code: [Select]
inxi -Fxz
Last Edit: March 04, 2019, 06:14:39 PM by firenice03
LL 4.6 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 4.4 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 

Re: linux lite 3.8 sound problem
« Reply #2 on: March 04, 2019, 08:13:53 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3185
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
To check alsa and pulseaudio open your terminal and type

Code: [Select]
alsamixer

press enter
press F6 key and leave as default, or use up down arrow keys to select the sound card.
After selecting the soundcard check here for mute and move through the channels using left and right arrow keys , there is more than one full screen of the channels, so keep checking across right, adjust the volume levels for each of the channels of your soundcard how you like it to sound, so it is nice.
To exit F6 selections or mixer use Esc key.
Last Edit: March 04, 2019, 08:41:08 PM by bitsnpcs
 

Re: linux lite 3.8 sound problem
« Reply #3 on: March 06, 2019, 08:17:04 PM »
 

PsaCrypt

  • New to Forums
  • *
  • 11
    Posts
  • Country: es
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit
hello bitsnpcs and firenice03,

inxi command appears to be good, dhows hda_intel device.  sound works fine running alsamixer and pressing f6 to select hda_intel instead of default.  is there any way to select by default hda_intel device?  or ... is there any way to link hda_intel device to default profile?

thank you.  :-)
 

Re: linux lite 3.8 sound problem
« Reply #4 on: March 07, 2019, 04:06:55 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3185
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Hello PsaCrypt,

when you select the hda_intel device on F6, if you press Esc, then adjust it to how you like the sound.
Press Esc again, now back at the command line, to save the settings so it loads on restart, in your terminal type - 

Code: [Select]
sudo alsactl store
Enter your password when it requests it.
Is it working okay now ?

Sometimes it is needed to open 2 terminal windows, in the first do F6 and change your settings, leave it on the settings screen.
On the second terminal do the command above .
Then close both terminal windows.
Last Edit: March 07, 2019, 04:14:40 PM by bitsnpcs
 

Re: linux lite 3.8 sound problem
« Reply #5 on: March 08, 2019, 06:15:45 AM »
 

PsaCrypt

  • New to Forums
  • *
  • 11
    Posts
  • Country: es
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit
hello bitsnpcs,

the command sudo 'alsactl store' stores sound card state, but after rebooting the sound card snd_hda_intel (card name intel) is not selected by default.  how to make snd_hda_intel as default device instead of 'default' device?

thank you.  :-)
 

Re: linux lite 3.8 sound problem
« Reply #6 on: March 22, 2019, 04:25:22 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3185
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Hello PsaCrypt,

this link has instruction on how to select the sound card that will be used - https://superuser.com/questions/626606/how-to-make-alsa-pick-a-preferred-sound-device-automatically

Scroll to #2 answer on the link that has this command -

Code: [Select]
cat /proc/asound/modules
and follow along the tutorial from this, to select and save your choice of sound card.
 

Re: linux lite 3.8 sound problem
« Reply #7 on: March 23, 2019, 06:28:06 AM »
 

PsaCrypt

  • New to Forums
  • *
  • 11
    Posts
  • Country: es
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit
hello bitsnpcs,

i saw in other forums how to select default soundcard, forget to write here.  thank you.  after selected default soundcard and storing default soundcard values problem persists, there is no sound at boot.  i think is a soundcard hardware incompatibility.

thank you to all.  :-)
 


Tags: sound speakers error 
 


Install Updates Gimp Error - see Security & Bug Fixes Section Sticky