You are Here:
Download Linux Lite 5.2 today - See Release Announcements



[ SOLVED ] I have to run alsactl restore in the terminal at every boot

Author (Read 7126 times)

0 Members and 7 Guests are viewing this topic.

 

T1125P

  • Forum Regular
  • ***
  • 110
    Posts
  • Country: us
  • Reputation: 4
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Intel i5-3340M

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 4000

  • Kernel: 5.x
I also have a sound issue with LL 3.4. In order for me to have sound out of my netbook I have to run alsactl restore in the terminal at every boot.
I can confirm that with previous version of LL I had no issues. Is there a way to make this command run at start up so I do not have to enter it every time I restart?

Thanks
Last Edit: October 16, 2018, 03:01:31 AM by Jerry
 


Re: I have to run alsactl restore in the terminal at every boot
« Reply #1 on: July 14, 2017, 07:03:47 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3180
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Hello T1125P,

please see here -

https://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/

under titles - first, and second alternate methods to fix no sound.
 

Re: I have to run alsactl restore in the terminal at every boot
« Reply #2 on: July 14, 2017, 07:35:49 PM »
 

T1125P

  • Forum Regular
  • ***
  • 110
    Posts
  • Country: us
  • Reputation: 4
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Intel i5-3340M

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 4000

  • Kernel: 5.x
Thanks so much, I will look at that link ^_^
 

Re: I have to run alsactl restore in the terminal at every boot
« Reply #3 on: July 14, 2017, 07:58:37 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3180
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
You are welcome  :)
I hope it helps you solve the sound problem.
 

Re: I have to run alsactl restore in the terminal at every boot
« Reply #4 on: July 14, 2017, 08:10:22 PM »
 

T1125P

  • Forum Regular
  • ***
  • 110
    Posts
  • Country: us
  • Reputation: 4
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Intel i5-3340M

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 4000

  • Kernel: 5.x
Well I just tried every method on that page and even this link someone else posted in the comments: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS
Still no sound. If there was a way to get alsactl restore command during the boot up to execute that would work. But for now I have to enter that in the terminal and run it if I want to use sound.
 

Re: I have to run alsactl restore in the terminal at every boot
« Reply #5 on: July 15, 2017, 07:13:28 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1213
    Posts
  • Country: us
  • Reputation: 192
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 5.0 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
Because of the LL updater I'm not sure you can get the change you need to persist. You can make the change you need as root (not sudo) but it may mess up the LL updater. Have you considered adding the command as a menu item with an icon in the tray?

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: I have to run alsactl restore in the terminal at every boot
« Reply #6 on: July 15, 2017, 09:47:03 PM »
 

T1125P

  • Forum Regular
  • ***
  • 110
    Posts
  • Country: us
  • Reputation: 4
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Intel i5-3340M

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 4000

  • Kernel: 5.x
Hmm, that is a good idea trinidad, I think that would work for me :)  You mean go to panel, add new items, then launcher? Then I just add alsactl restore?
 

Re: I have to run alsactl restore in the terminal at every boot
« Reply #7 on: July 15, 2017, 10:05:27 PM »
 

T1125P

  • Forum Regular
  • ***
  • 110
    Posts
  • Country: us
  • Reputation: 4
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Intel i5-3340M

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 4000

  • Kernel: 5.x
OK I think I got it to work in the panel. Made a folder with alsactl restore inside as a text file picked a nice sound icon as well, so now when I click on it, after the netbook boots up the sound is back :D
I was wondering, is there a way to make this panel item autostart when the netbook starts up so I don't have to click on it :D Maybe I'm asking to much :)
Last Edit: July 15, 2017, 10:07:00 PM by T1125P
 

Re: I have to run alsactl restore in the terminal at every boot
« Reply #8 on: July 15, 2017, 11:36:44 PM »
 

supergamer

  • Forum Regular
  • ***
  • 163
    Posts
  • Country: us
  • Reputation: 27
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: AMD Phenom 565

  • MEMORY: 12Gb

  • VIDEO CARD: 550 ti
Here is what I did to fix the sound not playing on vlc after playing sound on youtube. Add this to the client.conf(at the bottom) of the file in the /etc/pulse/ folder using sudo and reboot and it will fix sound for at least my issue for all users.


Code: [Select]
enable-shm = no
Last Edit: October 16, 2018, 03:01:10 AM by Jerry
 

Re: I have to run alsactl restore in the terminal at every boot
« Reply #9 on: July 16, 2017, 03:58:24 PM »
 

T1125P

  • Forum Regular
  • ***
  • 110
    Posts
  • Country: us
  • Reputation: 4
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Intel i5-3340M

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 4000

  • Kernel: 5.x
Thanks supergamer, I tried it, sound is still muted though. I have the command alsto start my audio in my taskbar panel. I'm trying to find a way to make this command autostart once the computer boots up :D
Last Edit: July 16, 2017, 04:01:19 PM by T1125P
 

Re: I have to run alsactl restore in the terminal at every boot
« Reply #10 on: July 16, 2017, 06:44:00 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7849
    Posts
  • Country: nz
  • Reputation: 741
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.2 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Topic split off from original thread started by another member with a different issue. Folks, please don't cut into other people threads with your issues, keep them separate. Thank you.

@T1125P have you tried adding it to Menu, Settings, Session and Startup ?
Application tab, Add.

Name: Restore sound
Description: Restore sound
Command: alsactl restore
 

Re: I have to run alsactl restore in the terminal at every boot
« Reply #11 on: July 17, 2017, 05:32:50 PM »
 

T1125P

  • Forum Regular
  • ***
  • 110
    Posts
  • Country: us
  • Reputation: 4
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Intel i5-3340M

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 4000

  • Kernel: 5.x
Thank you , sorry about that Jerry.
I just tried that, add it to my startup like you said, same thing. But for now It's ok,  I have in my taskbar I can just click on my icon and the sound works.
Thanks for all the help guys :)  Other than that, I love LL 3.4 super smooth overall for my little Netbook :D Fantastic work.
Last Edit: July 17, 2017, 06:13:49 PM by T1125P
 


Tags:
 


Download Linux Lite 5.2 today - See Release Announcements