You are Here:
Download Linux Lite 5.4 RC1 today - See Release Announcements



How to change audio output jack?

Author (Read 5016 times)

0 Members and 1 Guest are viewing this topic.

How to change audio output jack?
« on: August 22, 2015, 08:31:56 AM »
 

webodan

  • New to Forums
  • *
  • 2
    Posts
  • Reputation: 1
  • Linux Lite Member

  • CPU: Phenom II X4 555

  • MEMORY: 4Gb

  • VIDEO CARD: Radeon R7 250X
Hello,

I have a Soundblaster Live 5.1, and this card is known to output better sound quality through its headphone (black) jack. The OS outputs Stereo (2.0) sound by default over the speaker (green) jack. I can't modify this behavior, the only way for the system to output Stereo sound is if I choose 5.1 or 4.0 audio output, but then it also outputs part of the sound through other jacks I don't use, hence some applications sound distorted.

Is there any way to force Stereo sound over the headphone jack only? This works under Windows using the kX audio drivers.

I've tested changing it with HDA Analyzer but since the card is not an HD Audio card, it won't show up on its list.

Thanks in advance.
 


Re: How to change audio output jack?
« Reply #1 on: August 22, 2015, 09:49:24 AM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1564
    Posts
  • Country: us
  • Reputation: 254
  • * Forum Moderator *

  • Linux Lite: 4.8 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

  • Kernel: 4.x
Want to thank me?  Click my [Thank] link.
 

Re: How to change audio output jack?
« Reply #2 on: August 22, 2015, 10:02:58 AM »
 

webodan

  • New to Forums
  • *
  • 2
    Posts
  • Reputation: 1
  • Linux Lite Member

  • CPU: Phenom II X4 555

  • MEMORY: 4Gb

  • VIDEO CARD: Radeon R7 250X
This link might be a start. https://mylinuxramblings.wordpress.com/2009/04/01/clear-5-1-surround/

Following this advice, and knowing that my headphone jack is labeled as Rear speakers in ALSA applications, I edited /etc/pulse/daemon.conf , uncommented default-sample-channels = 2 and default-channel-map = front-left,front-right , and renamed this last part to rear-left-,rear-right . Then I configured PulseAudio volume control to Stereo output. It is still using the front speakers (green jack). I'll keep checking on this blog post, but I don't know what else to test at the moment.

The ideal setting would be that when I select Stereo output in PA, it outputs to Rear speakers instead of using Front speakers as default. Then every application should output Stereo only instead of using all the other channels when selecting 4.0 or 5.1 sound.
Last Edit: August 22, 2015, 10:12:36 AM by webodan
 


Tags:
 


Download Linux Lite 5.4 RC1 today - See Release Announcements