You are Here:
Download Linux Lite 5.2 today - See Release Announcements



[ SOLVED ] ALC268 speakers ok no headphones sound

Author (Read 5467 times)

0 Members and 1 Guest are viewing this topic.

ALC268 speakers ok no headphones sound
« on: June 13, 2015, 11:18:58 AM »
 

Madalin Andrei

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 2

  • CPU: Core2Duo T5550 @1.83GHz

  • MEMORY: 2Gb

  • VIDEO CARD: Mobility Radeon HD 2400 128Mb
So I think this is the fifth time i reinstalled LL 2.4 trying to solve my issue. 

I have an Intel HDA ALC268 sound card on a Toshiba Satellite p200. On any Ubuntu/Debian based distro (LL included) I installed, the headphones won't work, while the speakers work just fine. I searched forums, documentation, installed the realtek linux driver, tried all that alsamixer - pulseaudio advice, on this last LL 2.4 fresh install I even installed the 3.15 kernel from here https://www.linuxliteos.com/forums/installing-software/linux-lite-kernel/ .

Nothing, headphones don't work. I'm out of options. I was planning on making LL 2.4 my base OS, instead of Windows, but because of this issue I've delayed that.
Last Edit: February 11, 2016, 11:19:24 PM by Jerry
 


Re: ALC268 speakers ok no headphones sound
« Reply #1 on: June 13, 2015, 03:15:48 PM »
 

rokytnji

  • Friganeer
  • Platinum Level Poster
  • **********
  • 1255
    Posts
  • Country: us
  • Reputation: 137

  • Linux Lite: 3.6 64bit

  • CPU: Intel Core2 Duo U9600

  • MEMORY: 4Gb

  • VIDEO CARD: Intel Mobile 4
What in terminal does

Code: [Select]
cat  /var/lib/alsa/asound.state
show? Just poking and hoping here. If a headphone readout shows in the text file. See if it says false anywhere on headphone. Might need too change to true.
Last Edit: June 13, 2015, 03:18:18 PM by rokytnji
LL 3.6,2.8
Dell XT2 > Touchscreen Laptop
Dell 755 > Desktop
Acer 150 > Desktop
I am who I am. Your approval is not needed.
 

Re: ALC268 speakers ok no headphones sound
« Reply #2 on: June 13, 2015, 03:47:52 PM »
 

Madalin Andrei

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 2

  • CPU: Core2Duo T5550 @1.83GHz

  • MEMORY: 2Gb

  • VIDEO CARD: Mobility Radeon HD 2400 128Mb
Thanks for your response. So I looked at the feedback from the command you posted and found this:
Code: [Select]
control.23 {
      iface CARD
      name 'Mic Jack'
      value false
      comment {
         access read
         type BOOLEAN
         count 1
      }
   }
   control.24 {
      iface CARD
      name 'Line Jack'
      value false
      comment {
         access read
         type BOOLEAN
         count 1
      }
   }
   control.25 {
      iface CARD
      name 'Front Headphone Jack'
      value false
      comment {
         access read
         type BOOLEAN
         count 1
      }
   }
Haven't tested the microphone jack, but apparently it doesn't work also.
 

Re: ALC268 speakers ok no headphones sound
« Reply #3 on: June 13, 2015, 05:08:14 PM »
 

rokytnji

  • Friganeer
  • Platinum Level Poster
  • **********
  • 1255
    Posts
  • Country: us
  • Reputation: 137

  • Linux Lite: 3.6 64bit

  • CPU: Intel Core2 Duo U9600

  • MEMORY: 4Gb

  • VIDEO CARD: Intel Mobile 4
Make a backup 1st of asound.state

Code: [Select]
sudo cp /var/lib/alsa/asound.state /var/lib/alsa/asound.state.old
then cd into /var/lib/alsa  like so, and make sure your backup was made a listed

Code: [Select]
cd  /var/lib/alsa
Hit enter/return key

then

Code: [Select]
ls
to list what is in alsa folder. Your asound.state.old should now be listed if you follwed my steps right.

Then while staying in terminal (while inside of folder /var/lib/alsa) .

Code: [Select]
sudo leafpad  asound.state
Edit any false entries to true. See if it fixes anything. Reboot may be necessary after this edit. You will be unmuting ports and cards and jacks
with what I am showing you. You have the original as a backup in case you screw
up. You can always use it to copy and paste the original text back into
your edited asound.state to start over in case you scew up for any reason.

Good Luck. Happy Trailz, Rok
LL 3.6,2.8
Dell XT2 > Touchscreen Laptop
Dell 755 > Desktop
Acer 150 > Desktop
I am who I am. Your approval is not needed.
 

Re: ALC268 speakers ok no headphones sound
« Reply #4 on: June 13, 2015, 06:17:23 PM »
 

Madalin Andrei

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 2

  • CPU: Core2Duo T5550 @1.83GHz

  • MEMORY: 2Gb

  • VIDEO CARD: Mobility Radeon HD 2400 128Mb
Tried it. Nothing.  :(
 

Re: ALC268 speakers ok no headphones sound
« Reply #5 on: June 13, 2015, 11:49:43 PM »
 

rokytnji

  • Friganeer
  • Platinum Level Poster
  • **********
  • 1255
    Posts
  • Country: us
  • Reputation: 137

  • Linux Lite: 3.6 64bit

  • CPU: Intel Core2 Duo U9600

  • MEMORY: 4Gb

  • VIDEO CARD: Intel Mobile 4
Tried it. Nothing.  :(

Sorry. It was a poke and hope on my end. I had my own drama today as well

http://antix.freeforums.org/viewtopic.php?f=16&t=5656
LL 3.6,2.8
Dell XT2 > Touchscreen Laptop
Dell 755 > Desktop
Acer 150 > Desktop
I am who I am. Your approval is not needed.
 

Re: ALC268 speakers ok no headphones sound
« Reply #6 on: June 14, 2015, 01:05:19 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7859
    Posts
  • Country: nz
  • Reputation: 741
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.2 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Known issue on the P200 - https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1213485

Try the #4 fix. File is in: /etc/modprobe.d/alsa-base.conf
 

Re: ALC268 speakers ok no headphones sound
« Reply #7 on: June 14, 2015, 07:43:28 AM »
 

Madalin Andrei

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 2

  • CPU: Core2Duo T5550 @1.83GHz

  • MEMORY: 2Gb

  • VIDEO CARD: Mobility Radeon HD 2400 128Mb
It worked! I applied the fix, rebooted the laptop and it worked. Thank you all!
 

Re: ALC268 speakers ok no headphones sound
« Reply #8 on: June 14, 2015, 08:50:59 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7859
    Posts
  • Country: nz
  • Reputation: 741
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.2 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
You're welcome :)

Sent from my Nexus 6 using Tapatalk

 


Tags:
 


Download Linux Lite 5.2 today - See Release Announcements