You are Here:
Translations are underway - See Linux Lite Software Development Section



Network Connections auto connects to DHCP connection even if told not to

Author (Read 2035 times)

0 Members and 3 Guests are viewing this topic.

 

pentesterlab

  • New to Forums
  • *
  • 2
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 6.0 64bit
I use Linux Light in Virtualbox. I have this same problem. Every time Linux Light Restart, the Enp0S3 connect. My settings are not auto connect I have done to become Manual.
Is there a solution?
 

Network Connections auto connects to DHCP connection even if told not to
« Reply #1 on: March 29, 2022, 07:13:50 PM »
 

shmarko25

  • New to Forums
  • *
  • 3
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.8 64bit
Hello,

Have come across what I think is a bug in Linux Lite or one of its components.  Have done some bug hunting and come to the following conclusions:

I am using Oracle VirtualBox

The VM is configured as follows:

Hardware
OS: 64Bit Ubuntu
Ram: 4gb
Hdd: 10gb
Network: NAT Network with CIDR 192.168.1.0/24
Everything Else: Default

Linux Lite Configuration

Latest Version 64bit
Fully Updated
Webmin
openssh-server
Samba shared folder which is accessible from my other VM's(Ubuntu Mate)

Where is the Bug

The bug is in Network Connections

Network Settings

I have two connections, one for Internal traffic between the VM's and one for external traffic to the internet

INTERNAL
IP: Static: 192.168.1.20/24 no Default Gateway or DNS Servers
Other Settings: Connect Automatically with Priority - On

One for External

EXTERNAL
IP: DHCP
Other Settings: Connect Automatically with Priority - Off

The Problem

When these changes are made, the setting are saved.  However, whenever the VM is restarted either properly or improperly, Linux Lite will connect automatically to the DHCP connection(EXTERNAL).  If no DHCP enabled connection exists it will create one under the name of the Ethernet card, in my case: enp0s3 with DHCP settings and connect to it instead of the static IP connection(INTERNAL).  If the connection is set to DHCP and a static IP is added the same occurs

Originally I though it might be connecting alphabetically.  It wasn't.  I then tried removing and adding the connections in a different order, still didn't work.

Replicating the Problem

Problem can be replicated

Other Distros

The other two VM's on my VNet are Ubuntu Mate with identical Network configurations and Hardware Specs and Do Not have this issue

Machine 1

INTERNAL
IP: Static: 192.168.1.10/24 no Default Gateway or DNS Servers
Other Settings: Connect Automatically with Priority - On

One for External

EXTERNAL
IP: DHCP
Other Settings: Connect Automatically with Priority - Off

Machine 2


INTERNAL
IP: Static: 192.168.1.30/24 no Default Gateway or DNS Servers
Other Settings: Connect Automatically with Priority - On

One for External

EXTERNAL
IP: DHCP
Other Settings: Connect Automatically with Priority - Off

Other Than That
Came across Linux Lite a few days ago looking for a Guest OS for VM's for projects.  Clean, fast, small download, small install, easy to configure.  Probably going to become my default Linux OS on VM's
« Last Edit: March 29, 2022, 07:17:02 PM by shmarko25 »
 

 

-->
X Close Ad

Translations are underway - See Linux Lite Software Development Section