General > Security & Bug Fixes

Lite Tweaks kernel remover in 6.0 Bug

(1/2) > >>

I was able to replicate the bug. It will be fixed in 6.2

Sent from my Mobile phone using Tapatalk

Şerban S.:

--- Quote from: Jerry on June 13, 2022, 05:28:57 AM ---Thank you :)

--- End quote ---
Hi, Jerry! :)
It seems weird to me and as it looks, it is machine dependent.
On the machine I use (Dell Precision T1700), I removed all the kernels previously to the current without having this kind of annoyance.
It is very difficult to me to figure out how this is a Linux Lite bug, since it worked on my machine all the time.
I used this feature from the beginning because I found it handy, but mostly, because it always worked. My current kernel is, and the Kernel Remover says nothing about any other kernels.
In a previous answer, you pointed to "linux-image-unsigned". I never skipped this package when Kernel Remover listed it so, maybe this might be the cause that triggered some weird dependencies that prevent the removal of the said kernel version (5.15.0-33).
Now, as far as my understanding goes, this can only be an user error otherwise, I was supposed to get the same error long ago already and this never happened so far.
However, I used synaptic many times to remove kernel packages so, if this still keeps appearing, the other approach is listing all kernel packages with Synaptic, then marking the ones that belong to the older versions than remove all those remainders.
For someone less experienced with Synaptic, this is risky, I know, but it is a way to get the job done.
While I was testing kernels that were downloaded from (way ahead from the standard distro release), I installed and removed many kernels using this procedure and I never had trouble. All it takes is a little extra-caution regarding the running kernel version packages.
As of today, the running version is This means that all the other kernel packages can be removed using Synaptic.
Maybe if I'll make a short screencast, will be of some help.

Best regards! :)

Hi Jerry

Run the sudo apt command as per your instructions and has made no difference. Not really a problem but thought you should know.

Many tnx.

Thank you :)

Ok, many tnx.


[0] Message Index

[#] Next page

Go to full version