Linux Lite Forums

General => Security & Bug Fixes => Topic started by: lucasmz0800 on October 26, 2018, 11:29:51 AM

Title: Firewall doesn't open
Post by: lucasmz0800 on October 26, 2018, 11:29:51 AM
based on gufw firewall gui, my linux lite's 4 doesn't open it... I've been trying for a little longer solve this issue by myself but nothing happen. bellow you can see the debug app trogh therminal code any idea how can I solve it?




sudo gufw
[sudo] senha para lucas:
Traceback (most recent call last):
  File "/usr/share/gufw/gufw/gufw.py", line 21, in <module>
    from gufw.view.gufw  import Gufw
  File "/usr/share/gufw/gufw/gufw/view/gufw.py", line 18, in <module>
    import gi
ModuleNotFoundError: No module named 'gi'
Title: Re: Firewall doesn't open
Post by: DeepThought on October 26, 2018, 11:47:58 AM
Looks like the python-gi module is missing, you could try manually installing it.

Code: [Select]
sudo apt-get install python-gi
Title: Re: Firewall doesn't open
Post by: lucasmz0800 on October 26, 2018, 11:50:39 AM
here says it's already the new version

sudo apt-get install python-gi
[sudo] senha para lucas:
A ler as listas de pacotes... Pronto
A construir árvore de dependências       
A ler a informação de estado... Pronto
python-gi is already the newest version (3.26.1-2).
Title: Re: Firewall doesn't open
Post by: DeepThought on October 26, 2018, 12:30:04 PM
A post on Linux Mint forums :

https://forums.linuxmint.com/viewtopic.php?t=275451

suggests the following:

Code: [Select]
sudo apt-get install --reinstall gufw python3-gi
Title: Re: Firewall doesn't open
Post by: Jerry on October 26, 2018, 03:56:14 PM
No issue here with the latest updates.
Title: Re: Firewall doesn't open
Post by: bernard stafford on June 20, 2019, 12:20:22 PM
In the synaptic package manager: select installed packages: look for the package for the firewall : their is an option when you right click mouse - Re-install package..apply... Restart ...please.
Title: Re: Firewall doesn't open
Post by: trinidad on June 22, 2019, 07:34:31 AM
You can open the editable xml page for your firewall with the following command: sudo ufw status verbose

You can change settings with the CLI. Make sure the defaults are deny (incoming) allow (outgoing) first, then you can allow or disallow ports.

See the link below for what it looks like:
https://www.dbts-analytics.com/webserv3.html

TC