You are Here:
Linux Lite 4.4 Final has been released. See the Release Announcements section for more information.



[ SECURITY ] Firewall doesn't open

Author (Read 1218 times)

0 Members and 1 Guest are viewing this topic.

Firewall doesn't open
« on: October 26, 2018, 11:29:51 AM »
 

lucasmz0800

  • New to Forums
  • *
  • 3
    Posts
  • Country: br
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Intel core i7

  • MEMORY: 4Gb

  • VIDEO CARD: Intel graphic card
based on gufw firewall gui, my linux lite's 4 doesn't open it... I've been trying for a little longer solve this issue by myself but nothing happen. bellow you can see the debug app trogh therminal code any idea how can I solve it?




sudo gufw
[sudo] senha para lucas:
Traceback (most recent call last):
  File "/usr/share/gufw/gufw/gufw.py", line 21, in <module>
    from gufw.view.gufw  import Gufw
  File "/usr/share/gufw/gufw/gufw/view/gufw.py", line 18, in <module>
    import gi
ModuleNotFoundError: No module named 'gi'
 


Re: Firewall doesn't open
« Reply #1 on: October 26, 2018, 11:47:58 AM »
 

DeepThought

  • Forum Regular
  • ***
  • 146
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.2 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
Looks like the python-gi module is missing, you could try manually installing it.

Code: [Select]
sudo apt-get install python-gi
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: Firewall doesn't open
« Reply #2 on: October 26, 2018, 11:50:39 AM »
 

lucasmz0800

  • New to Forums
  • *
  • 3
    Posts
  • Country: br
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Intel core i7

  • MEMORY: 4Gb

  • VIDEO CARD: Intel graphic card
here says it's already the new version

sudo apt-get install python-gi
[sudo] senha para lucas:
A ler as listas de pacotes... Pronto
A construir árvore de dependências       
A ler a informação de estado... Pronto
python-gi is already the newest version (3.26.1-2).
 

Re: Firewall doesn't open
« Reply #3 on: October 26, 2018, 12:30:04 PM »
 

DeepThought

  • Forum Regular
  • ***
  • 146
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.2 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
A post on Linux Mint forums :

https://forums.linuxmint.com/viewtopic.php?t=275451

suggests the following:

Code: [Select]
sudo apt-get install --reinstall gufw python3-gi
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: Firewall doesn't open
« Reply #4 on: October 26, 2018, 03:56:14 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6826
    Posts
  • Country: nz
  • Reputation: 628
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
No issue here with the latest updates.
 

Re: Firewall doesn't open
« Reply #5 on: June 20, 2019, 12:20:22 PM »
 

bernard stafford

  • KoFi Supporter
  • New to Forums
  • *****
  • 24
    Posts
  • Country: us
  • Reputation: 0

  • Linux Lite: 4.4 64bit

  • CPU: AMD A-65400B 2-core 3.6 -3.8 Ghz /32 or 64bit

  • MEMORY: 8Gb

  • VIDEO CARD: AMD ARUBA Radeon HD Graphics
In the synaptic package manager: select installed packages: look for the package for the firewall : their is an option when you right click mouse - Re-install package..apply... Restart ...please.
Last Edit: June 20, 2019, 01:07:57 PM by bernard stafford
Linux Lite 4.4 Release:18.04 Bionic 64bit Kernel 5.1.0 #1.
LINUX RULES THE INTERNET ...[test_updates]_Expected... 
The Impossible is only Improbably Possible.
Thank You For Being You **Click_THANK**_<<=== 
<<===
 

Re: Firewall doesn't open
« Reply #6 on: June 22, 2019, 07:34:31 AM »
 

trinidad

  • Gold Level Poster
  • *******
  • 937
    Posts
  • Country: us
  • Reputation: 165
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.2 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D
You can open the editable xml page for your firewall with the following command: sudo ufw status verbose

You can change settings with the CLI. Make sure the defaults are deny (incoming) allow (outgoing) first, then you can allow or disallow ports.

See the link below for what it looks like:
https://www.dbts-analytics.com/webserv3.html

TC
"You can't depend on your eyes when your imagination is out of focus."
 


Tags:
 


Linux Lite 4.4 Final has been released. See the Release Announcements section for more information.