Development > Scripting and Bash

Cron job to automate backup????

<< < (3/3)

Thanks for the replies......yes, I thought it might be a permissions things as well. I have a copy of in a user folder with my user ownership and a copy in /usr/bin/ with root ownership. Neither one seem to run, yet I can double click either and it launches fine. All I seem to get in syslog for this line is this....

Dec 14 08:15:01 kenneth-OptiPlex-755 CRON[8245]: (root) CMD (/usr/bin/
Dec 14 08:15:01 kenneth-OptiPlex-755 CRON[8244]: (CRON) info (No MTA installed, discarding output)

I am not trying to mail anything, as the file should launch and I should see grsync start running when it hits the correct time. It looks like it is "trying" to run???? But nothing is happening.....maybe I am wrong here?

Not sure if it's similar..??
I had some permissions issue trying to run some tasks...
If you run gnome-scheduler from the System menu,
The tasks are only run as "normal user".

But if you open a terminal and do:

--- Code: ---gksu gnome-scheduler

--- End code ---

It now run's as root, so anything you now schedule this way run's with root privileges.
If you open Scheduler from the menu, you do not see the(se) root tasks.

I'm not a CRON expert but....
If not executing, maybe a permissions issue??
Any error's when running?? May have to pipe it out to a txt file to see errors..

kjacobs: I am trying to automate a weekly backup of my home folder. I did try the built in backup option in LL, but simply do not like the tons of zip files created during backup. I really only want mirror copies of the home folder on my NAS.

I installed grsync to setup the backup......and the backup works fine. I then created a file to run the grsync backup session, made it executable, and tested works fine as well.

Now I tried to add the script to a crontab job......this is where it all fails. I cannot get the file to run at all. I have tried MANY options.....I have added the path to the script to crontab.....tried adding the path in the script.......tried copying the script to the /bin folder.......tried standing on one foot while patting my head. I simply cannot get the file to launch using crontab. I have spent a number of hours looking up the correct formatting on google to get this right and it still fails to run.

I also tried installing gnome-scheduler to do this in a gui and it fails to run as well. Soooooo, what in the world am I missing to get this function to run automagically????

Any help would be great......thanks.


[0] Message Index

[*] Previous page

Go to full version