You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
Bash Prompt

Author (Read 11731 times)

0 Members and 1 Guest are viewing this topic.

Bash Prompt
« on: July 05, 2018, 10:37:28 AM »
 

dave61430

  • New to Forums
  • *
  • 1
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: Intel Dual Core

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Chipset
Running a trial of LL on both a virtual machine and live boot, I cannot change the prompt. PS1="\$ " works on any other distribution I've used but not on LL. No error message, just no change. Even put it in .bashrc. I've checked shell and it is bash. Any ideas or is this a bug.
Currently using Mint 18.3, but seriously considering LL.
 


Re: Bash Prompt
« Reply #1 on: July 05, 2018, 03:10:10 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3237
    Posts
  • Country: 00
  • Reputation: 305
    • Try to Grow

  • Linux Lite: 3.2 64bit

  • Kernel: 4.x
Hello dave61430,

it can be changed on desktop installed LL 3.2 , LL 4 series uses different terminal, maybe a member using 4 series can try also ?



^Here I backup default prompt, echo backup to check it is correct, change prompt to PS1="\$ ", run cal to show new prompt holds after additional command, then restore to the backup of default prompt.
Last Edit: July 05, 2018, 03:23:11 PM by bitsnpcs
 

Re: Bash Prompt
« Reply #2 on: June 26, 2019, 08:02:24 PM »
 

thomasd

  • New to Forums
  • *
  • 3
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: VM
I have the same problem, running LL 4.4, I cannot change the bash prompt in any terminal.  I've tracked it through all the normal config files and changed everything I thought might have an effect, to no avail.

One suspicious thing, the definition for PS1 when you echo it is fully expanded:
Code: [Select]
 thomasd  ~  echo $PS1
\[\] thomasd \[\] \[\]~ \[\] \[\]
 thomasd  ~  

so it looks like some service somewhere is setting PS1 in the background.

Help!
 

Re: Bash Prompt
« Reply #3 on: June 29, 2019, 04:58:35 PM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1324
    Posts
  • Country: us
  • Reputation: 205
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 5.6 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
Not quite sure of your question here. Are you saying you are running the "live" ISO or an installed system? You can certainly customize the prompt on any Linux/Unix system ... except for many "live" ISOs and "safe" mode mods.

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Bash Prompt
« Reply #4 on: June 30, 2019, 12:59:21 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8178
    Posts
  • Country: nz
  • Reputation: 761
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Thread hijacks don't require a response other than from a Mod to delete said post. Thanks TC.

Sent from my Phone using Tapatalk

 

Re: Bash Prompt
« Reply #5 on: April 24, 2020, 09:19:10 PM »
 

zeozod

  • New to Forums
  • *
  • 2
    Posts
  • Country: us
  • Reputation: 2
  • Linux Lite Member

  • Linux Lite: 4.8 64bit
There is a shell variable PROMPT_COMMAND that is interfering with all of the normal means of setting the bash shell prompt. The following in your .bashrc should fix it.


unset PROMPT_COMMAND
PS1=whatever:
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements