General > Release Announcements

Linux Lite 5.2 Final Released

(1/5) > >>

@GraemeA this is an announcement thread, if you need help, please start a thread in the correct Support section of these Forums. Thank you.

thank you

Hi Jerry,
I like Linux Lite *A LOT*, having installed version 5.0 in July 2020 on my HP Stream x360 Convertible Netbook, which only has 32 GB of SSD, and was useless with Windows 10! Linux Lite v 5.0 gave it a new lease of life; I guess you hear that all the time.
HOWEVER, updating LL has become a big problem for me, since Kernel was issued, because it caused the computer to COMPLETELY disregard its built-in keyboard; - I can attach a keyboard via USB, but that destroys the idea of a netbook, doesn't it!
I taught myself to cope with this, with the help of someone else with a similar problem on the forum, by reverting the latest kernels that got installed back to (or before; - my Timeshift restore point has, which also works). That 'coping' process seems to have prevented the installation of later kernels in routine updates, which I have been doing regularly, which is sort of OK, but a bit worrying in the long-run)...
However, sometime in November a routine update caused the Netbook to fail to recognize its Wifi adapter, which I'm sure you will agree is a bit terminal for a netbook, with NO wired internet port!!! When I restored the netbook to working state I found that the WiFi hardware is 'Intel Wireless 7265', which uses 'iwlwifi' driver, but that was completely absent after the update that killed the Wifi. Incidentally, I'm pretty sure that update also killed the Bluetooth adaptor AND the sensors on the Netbook :-(
My only solution was to revert to that Timeshift Restore point, which I made back in July. That gets the computer working, which is great, but it almost immediately wants me to install updates, and when I did that, I then end up back with NO WiFi (etc) AND no keyboard either. So I seem to be stuck in a loop where I can only live in the past with Linux Lite :-(
The reason I am posting here is because I *hoped* that a full update to v 5.2 might fix all these problems, so I created a live USB install drive with v5.2 and booted the netbook from that. Result; - WiFi was working, but there was no keyboard, so I couldn't enter my network password. So GOTO previous paragraph, and repeat FOREVER! :-(
...I would be grateful for any ideas on how to progress this. Even if I have to stay on the v5.4.0.40 kernel from back in July. But if I do that, how can I get updates to applications (which I presume are necessary for security reasons, as well as feature updates), without automatically getting kernel updates and whatever else kills the netbook?

Hello liunx-liters, I installed 5.0 on old laptop, and want to live upgrade to 5.2, the problem is both "lite upgrade" menu and "sudo apt dist-upgrade" can't upgrade OS to 5.2.
I've tried both GUI and terminal way many times, the "lite upgrade" menu always report "computer not connected to internet", and "sudo apt dist-upgrade" always report " 0 upgraded .. 0 not upgraded."
Is it geolocation (ip and apt package list mirror) problem?
If that's the cause, how to work around to upgrade live to 5.2 instead of using 5.2 installation media?

P.S. I remember I changed software repo to local (China PR), but not the main one which is
deb emerald main
in /etc/apt/sources.list.d/linuxlite.list.

I just tried "ping", ended up 33.3333% packet loss, and one of taiwan mirror had some packet loss too when pinged last week.

Thank you, @firenice03

I'm sure it's the stable version. I know where I downloaded it and it's also the one I use in my laptop (that I upgraded to 5.2 without problems).

Also, I have already updated LL5.0. Not only using Lite Updates, but with
--- Code: ---apt update
--- End code ---
--- Code: ---apt-get update
--- End code ---
, as well upgraded with
--- Code: ---apt upgrade
--- End code ---
--- Code: ---apt-get upgrade
--- End code ---

Maybe you know any other way to try it.

Edit: The problem was solved. The issue here was that the LL repository is down, but Jerry pointed it to one of the mirrors and now everything is good. My machine is now LL5.2.


[0] Message Index

[#] Next page

Go to full version