Hardware - Support > Printing and Scanning

there was an error during the CUPS operation server error internal error

(1/2) > >>

kat:
HI,
I just downloaded Linux Lite 5.0 RC1 over 4.8. Everything runs fine, except when I went to set up my wireless network printer, I get "there was an error during the CUPS operation server error internal error". When I go to add a printer, it sees my printer in the network section, I choose it, but at the end it says that error. At the first try, it said it would set the firewall for me for it to work, but I wonder if it did. Help. What should I do? In past, I've had no problem setting up my printer. 

firenice03:
@kat
Had the printer worked in LL.4x? What type of printer and how was it set up? -- Might help point..


If you haven't set it up yet try looking here - https://www.linuxliteos.com/manual/hardware.html#printer
Towards the end there is a section for most drivers...



kat:
Yes, my Canon TS5000 set up easily in Linux-Lite 4x, the latest was 4.8. Yesterday, I put Linux-Lite 5.0 RC1 over 4.8. It sees my printer, and "sometimes" will try to connect even to the test print page, but a few seconds later, it will say that it can't connect even though my printer is on and connected to the internet. I checked it with my windows 10 this morning and it is working fine wirelessly. I click on "Firewall" in Linux 5.0 RC1, and I don't see anywhere to shut it off. So, I delete the supposedly connected printer and try again to connect, and sometimes it will say, "there was an error during the CUPS operation server error internal error". I went to the bottom of the help manual page to look for my driver like you said, but there isn't one for Canon TS5000. *Firewall?


*UPDATE*


Got it working! Yay! I found a command to turn off firewall, but I'm not sure if that was the trick, though maybe. I chose my Printer under the network choices, and then chose the "app socket" something, where it shows the "host and the port". It was filled out. It worked then. Maybe the firewall being off let it choose something that worked. Later, after restarting, I checked to see if firewall was back on. It was. That's good, and printer is still working.  :)

Jerry:
It would be the Firewall. I've done some research and ports: 5353, 631, 9100 should be enabled. I think for the future, I'm going to disable this Firewall by default. I can see it causing a lot of frustration amongst new folk to linux.

j8a:
Hi, I experienced the same problem with a network printer and tried to allowed CUPS service in the firewall without success.
Then, I disabled the firewall and the problem was solved.

Regards,

Navigation

[0] Message Index

[#] Next page

Go to full version