Hardware - Support > Printing and Scanning

there was an error during the CUPS operation server error internal error

<< < (2/2)

GraemeA:
Hi, I am a brand new user of LinuxLite, and so far I have found it BRILLIANT, *EXCEPT* that I cannot get it to configure my Epson Workforce WP-4545 printer as a network printer. I have experienced the same problem as described here in that the Add Printer tool allows me to find my printer on the network, then searches for a driver, and if I go all through the selection process is eventually tells me that "there was an error during the CUPS operation server error internal error". No installation!
AND I have tried *SO* many other variations, all to no avail! In other attempts, where I enter my printer's network IP address, the add printer tool reliably finds the 'epson-inkjet-printer-201113w' driver, (which I found from the help manual was the recommended driver), but when I accept the license terms and click 'Forward', there is a quick flash of some screen that I do not have time to read and then nothing happens. No installation!
I thought I had found the solution, when I found this thread, so I disabled the firewall via the Settings Manager and tried again, BUT NO JOY  :(
I have got UBUNTU 18.04 LTS installed on two other machines and they drive the printer just fine, but this little computer needs a lightweight OS...
Any ideas? I am at the end of my tether now, and I am on the verge of giving up and trying to install some other distribution, like LUBUNTU (based on 18.04). ...  :'(

*UPDATE*
By the time I posted the message above I had been working on the problem for hours and it was around 1 am, UK time... So I went to bed, leaving the computer turned on, in the hope someone would respond to the thread by the time I woke up...
That didn't happen, BUT guess what; when I woke up the next day, the problem had cured itself! The Printer Configuration manager responded to me entering the IP address of the printer in 'Find Network printer', and silently installed drivers and accepted the 'Apply', which had NEVER happened before. Then to my delight I could print a test page. PEACE and LOVE  :)
I thought I ought to let you all know, but I have NO IDEA why it played out this way. One thing I did notice was that at the time I was messaging this forum I was also unable to download LUBUNTU, so perhaps there was some global network issue, which is probably just as well, as I might have been on the way to being a LUBUNTU fan by now  ;). But I cannot see for the life of me why any networking issue should interfere with the installation of printer drivers that are presumably already downloaded within the distribution?
Also, for what it is worth, why might it be a good idea to disable a firewall; - I assume they exist for a good reason...
Anyhoo, I can now resume my love affair with this little machine with Linux Lite installed1 :)

Latteorwhat?:

--- Quote from: j8a on June 17, 2020, 10:47:36 AM ---Hi, I experienced the same problem with a network printer and tried to allowed CUPS service in the firewall without success.
Then, I disabled the firewall and the problem was solved.

Regards,

--- End quote ---

Hi all,
I've got the same problem i.e. my Epson XP-830 worked fine under LL 4.8 but now I'm encountering the a/m cups server error  >:(
Would you be so kind to explain how to disable the firewall?

Thanks in advance,

Thomas

Latteorwhat?:

--- Quote from: Latteorwhat? on October 23, 2020, 11:27:59 AM ---
Would you be so kind to explain how to disable the firewall?
--- End quote ---

Shame on me: meanwhile I disabled the firewall but the problem isn't solved  :(.

Could someone please provide help?

Thx,

Thomas

Navigation

[0] Message Index

[*] Previous page

Go to full version