Hardware - Support > Printing and Scanning

HP DeskJet 3700 printer/scanner issue

<< < (2/4) > >>

firenice03:
@Jan
From the link you posted - I see a few things... your printer ip ends in (URI) 223.1 (.1 is typically the gateway) but more so the missing dependencies.

If you're in the same state (haven't tried a bunch of stuff) try the following...
https://developers.hp.com/hp-linux-imaging-and-printing/install/manual/distros/ubuntu


I would do Step 2 == I assume that you may have already updated HPLIP, could skip 3


OR
and if most have been done, you could start/try past step 8 and run the below command to see what errors...
Still in the same URL -- https://developers.hp.com/hp-linux-imaging-and-printing/install/manual/hp_setup



--- Code: ---sudo hp-setup
--- End code ---





If all else fails - it might not hurt to start fresh with a prior state w/ Time Shift or a fresh install if able.. After updated make a TimeShift back up, always helps to have a fall back..


Then follow the Manual to the letter - try with the 1st steps and see what works and progress....


Good Luck

Greg:
Hi Jan,
I too had no end of trouble trying to get my HP3630 working, in the end I went through CUPS Home page and under CUPS for users selected Command Line Printing and options and followed instructions there. I can't remember if I uninstalled HPLIP or not.
Hope this helps.
PS used the ipp everywhere driver

Jacob Pertou:

--- Quote from: Jan Cerveny on March 21, 2021, 06:06:32 AM [email protected] Pertou

Thank you for the advice. Didn't work. 'HPLIP Status service' and 'Status Messages' in 'Printer Properties' "see" the printer but still says "Connection error"... :/

--- End quote ---

Try Timeshifting to a restore point, before you installed HPLIP, and then follow the steps I provided. I have a feeling it will work.

bitsnpcs:
Source -
https://itsfoss.community/t/device-communication-problems-with-hp-printer-on-ubuntu-20-04/5006/18

Look first at the advices -
visit - http://localhost:631/
Under the tab printers, see if your printer is listed.
Then under the tab Jobs, see if there are any jobs waiting, cancel the jobs.

Look second at -
remove the usb cable from the printer, then reboot the computer, and printer.
refit usb cable.
If still not working follow on to the other tasks.

Look third at -
make sure no jobs waiting, search results showed issues happen most often if hplip is installed when jobs are waiting, or groups choice during installation.
purge hplip,
reinstall hplip,
check carefully the groups selected during installation process.

Best to follow the "look third" above paragraph with the staff help on LL forum.

Look fourth at, as last resort -
On itsfoss link above look at the link to Ubuntu instructions, with LL staff advice, on how to purge and uninstall hplip, then how to install HP printers without using hplip at all.

For clarity I am not LL staff, I am just another user of the LL distro, and hplip, I use a HP printer (Lazer), before this on LL I used the Kodak AIO, before that I used a HP inkjet.

Jan Cerveny:
@Jerry

Tried to disable FW with no effect. Still "Device communication error - code 5012' in HPLIP Status Service...

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version