Hardware - Support > Printing and Scanning

HP DeskJet 3700 printer/scanner issue

<< < (4/4)

Jan Cerveny:
@Jacob Pertou

Thank you for the advice. Didn't work. 'HPLIP Status service' and 'Status Messages' in 'Printer Properties' "see" the printer but still says "Connection error"... :/

Jan Cerveny:

I tried do so (checked both websites, followed instructions, installed hplip-gui via terminal...) before I've posted here. Nothing of these worked. That's why I tried to find a help here... Thank you

Jacob Pertou:
I just happened to re-install my HP Deskjet 3630, after reinstalling LL5.2. It was very annoying, but my printer looks similar to yours, so maybe I can help.

First I printed out a network configuration page by pressing down both the network and information buttons on the printer, at the same time.

Then I activated the Wi-fi network for the printer. My network is called "DIRECT-A9-HP Deskjet 3630 series". The password is found on the print-out.

In "Printers" I chose "Add" => "Printer"

Under Select Device => Network Printer =>Find Network Printer => Internet Printing Protocol

Under Enter device URI I added the link from the print-out, found in the section "Wi-Fi Direct". Something like this: https://123.456.789.0
Then press forward.


Find HP on the list


Then your printer, and the "hpcups" option in the right hand side of the window


Then you can name the printer:


Then "Apply", and you should be able to print a test page.

When using simple-scan, make sure you choose the SSL option.


@Jan Cerveny

You  may want to have a look here: https://www.linuxliteos.com/manual/hardware.html#printer

Lots of good info for set up  but specifically just below (or https://www.linuxliteos.com/manual/hardware.html#rescomprint) you'll find a section "HP Printers on Linux Lite"
The 3700 is listed so following, you should be able to complete set up...

--- Code: ---sudo apt-get install hplip-gui
--- End code ---

Jan Cerveny:
Hi, here is my problem. OS recognizes the printer (like 3700 ser.), but does not print/scan (message "Printer may not be connected" in Printer-settings dialog window or Print Queue).
I'm trying to install latest HPLIP from https://developers.hp.com/hp-linux-imaging-and-printing/gethplip, but the process stucks in the phase:

sudo apt-get remove libhpmud0 libsane-hpaio printer-driver-postscript-hp

Anybody have an advice/solution pls??? Thank you! JC

(Acer Aspire 5315, Linux Lite 5.2, printer HP DeskJet Ink Advantage 3775)


[0] Message Index

[*] Previous page

Go to full version