You are Here:
Linux Lite 6.4 RC1 Released - See the Release Announcements Forum section

Missing Printer Driver Error Message Canon Image Class MF4570dw Printer

Author (Read 3459 times)

0 Members and 1 Guest are viewing this topic.



  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8641
  • Reputation: 795
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 6.2 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Thank you for posting this information.

Sent from my Nexus 6 using Tapatalk


Missing Printer Driver Error Message Canon Image Class MF4570dw Printer
« Reply #1 on: April 01, 2016, 12:07:01 AM »


  • New to Forums
  • *
  • 36
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: Acer Aspire 5517 AMD Athlon dual core L310 1200MHz laptop

  • MEMORY: 4Gb

  • VIDEO CARD: Windows Aero (not sure about the kernel below)

  • Kernel: 5.x
For some reason it seems that Canon Image Class printers are particularly difficult to install on Linux.

After completing the installation of Linux Lite 2.8 I went to the Help Manual and followed exactly the procedure outlined for installing Canon printers.  Everything seemed to go well.  As per the instructions, I then opened Menu → System → Install/Remove Software and searched for my printer name and – yup, there it was – Canon NF 4500w series CNUSB #1.  Unfortunately, there is still no driver and I get the error message, “Missing Printer Driver”.  For some reason, although the recommended printer driver has been downloaded, it's still not being detected, despite following the steps outlined above.

Fortunately, the remedy for this dilemma I found on the Ubuntu Forums.  (See topic titled: “Re: Canon Imageclass MF4570dn printer with Ubuntu 14.04 LTS” at

The most recent Linux_UFRII _PrinterDriver as of February 2016 is now version 3.10.  I followed the instructions from the Ubuntu forums website above, except that when I got to the terminal command

tar -zxvf Linux_UFRII_PrinterDriver_V280_uk_EN.tar.gz 

I substituted 310 for 280.

Since I have a 32 bit system, I changed the next line as well to reflect that, so the following line became

cd Linux_UFRII_PrinterDriver_V310_uk_EN/32-bit_Driver/Debian

After typing the command


the two files that appeared were

cndrvcups.common_3.40-1_i386.deb and cndrvcups-ufr2-uk_3.10_1i386.deb

therefore, the next two command lines I entered were

sudo dpkg -i cndrvcups-common_3.40-1_i386.deb

sudo dpkg -i cndrvcups-ufr2-uk_3.10-1_i386.deb

I continued to follow the procedure as listed on the ubuntu forums site and restarted the CUPS.

When I got to the part that reads:

 “we are looking for a reply like

Instead, my reply was

direct usb://Canon.MF4500w%20series?serial=01220B1185d&interface=1   
direct usb://Canon.MF4500w%20series?serial=01220B1185d&interface=2

Following this I entered the command

sudo /usr/sbin/lpadmin -p Canon-MF4500w -m CNCUPSIR 4500ZK.ppd -v lpd://direct usb/Canon-MF4500w -E

In response to the above I got an error message:

Unknown argument l padmin: usb/Canon-4500w.

Totally frustrated with my continued lack of progress, I went back to the Add printer screen and noticed the option to print a test page which had not been there before. 

Honestly, I just about fell off my chair when the printer printed it!

The Printer Test Page indicates the driver is: CNM4500ZK.PPD

I don't know why this has worked.  Because I'm very new to both Linux and Linux Lite, I don't understand what the above commands mean but thought I would document what I've done here with the hope it might be useful to others. 
« Last Edit: April 01, 2016, 06:51:33 PM by Jan »


X Close Ad

Linux Lite 6.4 RC1 Released - See the Release Announcements Forum section