You are Here:
Download Linux Lite 5.4 RC1 today - See Release Announcements



HP 2540 all in one printer not found

Author (Read 5653 times)

0 Members and 1 Guest are viewing this topic.

HP 2540 all in one printer not found
« on: April 22, 2014, 10:13:43 PM »
 

cnstill

  • Guest
I have a HP deskjet 2540, I had issues with the scanner being detected so I installed hplip and now it will not even detect my printer and scanner at all with my usb connection so I cant finish installing my printer/scanner . What did I do wrong?
The printer is still detected when i plug it into my xp computer so its not the cord or the printer.

os Linux Lite 1.0.8
 


Re: HP 2540 all in one printer not found
« Reply #1 on: April 22, 2014, 11:57:12 PM »
 

N4RPS

  • Donator
  • Platinum Level Poster
  • **********
  • 1149
    Posts
  • Country: us
  • Reputation: 154
  • Knows JUST ENOUGH Linux to be DANGEROUS
    • Orphans for Christ, Self Advocates of Mecklenburg

  • Linux Lite: 2.6 64bit

  • CPU: Several Different 32-bit & 64-bit CPUs, 2-8 GB RAM

  • MEMORY: 8Gb

  • VIDEO CARD: Several Different AMD and Intel GPUs
Hello!

I DID SEE *THIS* on the HPLIP website

http://www.hplipopensource.com/hplip-web/index.html

under the DeskJet 2540 AIO:

You have selected Ubuntu 12.04 using the HP Deskjet 2540 All-in-one Printer.

Ubuntu 12.04 supplies HPLIP 3.12.2 by default, which does not support your printer.

You must ensure latest HPLIP version (recommemded), or at least HPLIP 3.13.8 in order to use your printer with Ubuntu 12.04.
 

If you downloaded and installed HPLIP 3.14.4 (the current version), you can:

1. Start by removing and reinstalling the printer within HPLIP.

2. Per the instructions on the HPLIP website, remove the current HPLIP install, download HPLIP again, and reinstall it. If HPLIP is installed following their instructions to the letter, you shouldn't experience any problems.

There are so many things that can go wrong when installing HPLIP that unless someone walks you through it by phone or TeamViewer, it is virtually impossible to determine exactly where your install might have gone wrong.

Further support for HPLIP can be obtained by filing a trouble ticket here:

http://hplipopensource.com/hplip-web/support.html

As Linux users, we are BLESSED that HP cares enough about us to have made the effort to develop and maintain HPLIP. For virtually every other printer out there, Linux driver development support is either an afterthought, or it has been left up to the user community to develop their own solutions.

If HP only supported my LaserJet 3100 AIO. NOT happenin'; it's an 'orphan' printer... :'(

73 DE N4RPS
Rob
Last Edit: April 23, 2014, 12:27:01 AM by N4RPS


A gun in your hand is worth more than a whole police force on the phone.
 

Re: HP 2540 all in one printer not found
« Reply #2 on: April 23, 2014, 12:18:18 AM »
 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Country: us
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
N4RPS hit the nail on the head.  You likely have an older version of hplip installed and need a newer version of the package.  To see which version is installed, open a terminal and enter this:
Code: [Select]
dpkg -l | grep hplip
Look at the version #.  Like N4RPS said, it's probably 3.12.2 -- which does not support the printer.  You need a newer version.

Here is a link describing how to get the new version and it also has another link to a step-by-step tutorial for installing it:  http://www.liberiangeek.net/2013/08/hp-linux-imaging-and-printing-hplip-version-3-13-8-released-with-support-for-more-printers/.  Read through it a couple of times if necessary and take your time following the instructions.

Good luck.
Try Linux Beginner Search Engine for answers to Linux questions.
 

Re: HP 2540 all in one printer not found
« Reply #3 on: April 23, 2014, 12:29:11 AM »
 

N4RPS

  • Donator
  • Platinum Level Poster
  • **********
  • 1149
    Posts
  • Country: us
  • Reputation: 154
  • Knows JUST ENOUGH Linux to be DANGEROUS
    • Orphans for Christ, Self Advocates of Mecklenburg

  • Linux Lite: 2.6 64bit

  • CPU: Several Different 32-bit & 64-bit CPUs, 2-8 GB RAM

  • MEMORY: 8Gb

  • VIDEO CARD: Several Different AMD and Intel GPUs
Hello!

Thanks, gold_finger, for the additional info. As they say, iron sharpens iron...

73 DE N4RPS
Rob


A gun in your hand is worth more than a whole police force on the phone.
 


Tags:
 


Download Linux Lite 5.4 RC1 today - See Release Announcements