You are Here:
Download Linux Lite 5.2 today - See Release Announcements



[ SOLVED ] How to set printer to print in black and white by default?

Author (Read 7623 times)

0 Members and 4 Guests are viewing this topic.

How to set printer to print in black and white by default?
« on: June 27, 2017, 11:01:52 AM »
 

Vera

  • PayPal Supporter
  • Forum Regular
  • *****
  • 140
    Posts
  • Country: 00
  • Reputation: 16
  • Enjoying Linux Lite.

  • Linux Lite: 3.4 64bit

  • CPU: Intel Quad Core 1.6GHz

  • MEMORY: 8Gb

  • VIDEO CARD: AMD Radeon
I'm trying to set my HP printer to print in black ink (i.e. grayscale using black ink only) by default. This should be possible because before using Linux Lite, this same printer and same desktop PC could be set on Windows 7 to default to this setting. Then if I had a color document to print, I would change it to print in color for my document and afterward I would change it back to black ink only ready for next time. 

I can't figure out how to set it to default to black ink only in LinuxLite. Any suggestions please? Is there a setting I have somehow missed?

I've already set the following setting under Menu -> All -> Printers:

Screenshot A:


The problem is that despite this setting shown above, when I go to print, it still defaults to color (this happens whether printing via LibreOffice or via Chrome - those are the main things I print with). Sure, I can get it to print in black ink for the document or website at hand for the individual document being printed, but not as a default setting.

As an example, see below the example of how I have to do it with each document in Chrome:

Screenshot B:


If I hit the "Print" button at top, then it will print in color. If instead I go via "Print using system dialog" seen at bottom, I then get taken to the following dialog:

Screenshot C:


And here I can select black ink instead of color, but it only seems to work for that document only. If I want to print again in black ink, I have to go through "Print using system dialog" and change it to black ink again.

So this is clunky, having to go through this every time I want to print in black ink.  I want it to DEFAULT to black ink (and change/override that setting on the rare occasions I want to print in color), instead of the other way around which is what I have now. Any guidance would be appreciated.

Other info:

Linux Lite recognized my printer right away, I didn't have to install anything myself or do anything via command line. This is all out-of-the-box. I'm not sure if that info was relevant, but wanted to mention in case.
Last Edit: June 29, 2017, 10:05:40 AM by Vera
Using Linux Lite for everything now. I put it on my desktop and my laptop. Woohoo!
 


Re: How to set printer to print in black and white by default?
« Reply #1 on: June 27, 2017, 07:02:09 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7849
    Posts
  • Country: nz
  • Reputation: 741
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.2 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
You could try the HP Printer control panel:

Code: [Select]
sudo apt install hplip-gui
 

Re: How to set printer to print in black and white by default?
« Reply #2 on: June 27, 2017, 07:11:24 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1559
    Posts
  • Country: us
  • Reputation: 254
  • * Forum Moderator *

  • Linux Lite: 4.8 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

  • Kernel: 4.x
Consider opening a browser and going to the following:
http://localhost:631/admin

Then:
*  Click on Manage Printers
*  Select your printer
*  Using the Administration dropdown menu, select "Set Default Options"

Perhaps there will be an option to select ink color as a default.

Update:  Jerry and I posted at the same time.  His suggestion seems better.
Want to thank me?  Click my [Thank] link.
 

Re: How to set printer to print in black and white by default?
« Reply #3 on: June 28, 2017, 02:06:23 PM »
 

Vera

  • PayPal Supporter
  • Forum Regular
  • *****
  • 140
    Posts
  • Country: 00
  • Reputation: 16
  • Enjoying Linux Lite.

  • Linux Lite: 3.4 64bit

  • CPU: Intel Quad Core 1.6GHz

  • MEMORY: 8Gb

  • VIDEO CARD: AMD Radeon
Thank you @Jerry and @torreydale8)  I tried both your methods.

@Jerry : Thanks but the HP package did not solve my problem. What happened is that the default was also set onto black ink on the HP package, but it still made no difference: my printing still came out in color when I printed from Chrome. I'm glad I installed the HP package though, as it did have the advantage of being able to show me the ink levels, which I don't remember seeing (or at least not as conveniently) back when I was on Windows 7 with that printer. So while package did not solve problem, it helped for other stuff and I'm glad I have it.

@torreydale : thanks for your willingness to help, but your method also did not solve the issue. Using it, I was also able to set the default options for the printer, but the setting already showed as Output Mode: Black Only Grayscale. Same issue as above.

So overall, the problem is that no matter what I do, the default printer settings consistently show as black ink only using the methods you both suggested, but when I actually print something on Chrome (this is my most common usage of the printer), then it will by default actually PRINT in color. Unless of course I override it by "Print using system dialog" as seen in Screenshot B in my previous post. That requires extra clicks though.

If either or you or anyone else has any other thoughts or suggestions I'm more happy to try them out.

If this problem can't be solved it's not a big issue, because as mentioned I can still use black ink via the extra clicks every time I want to print. Compared with what's going on for Windows users these days (ransomware etc) I'm happy that my concerns on the computer are so minor and work-around-able.  ;)
Using Linux Lite for everything now. I put it on my desktop and my laptop. Woohoo!
 

Re: How to set printer to print in black and white by default?
« Reply #4 on: June 28, 2017, 10:24:38 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7849
    Posts
  • Country: nz
  • Reputation: 741
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.2 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
 

Re: How to set printer to print in black and white by default?
« Reply #5 on: June 29, 2017, 10:13:38 AM »
 

Vera

  • PayPal Supporter
  • Forum Regular
  • *****
  • 140
    Posts
  • Country: 00
  • Reputation: 16
  • Enjoying Linux Lite.

  • Linux Lite: 3.4 64bit

  • CPU: Intel Quad Core 1.6GHz

  • MEMORY: 8Gb

  • VIDEO CARD: AMD Radeon
Thanks for the info @Jerry  . Marked as solved.

The issue persists on Chrome only now, but I figure this is therefore something Chrome-specific. Chrome is my main browser so I hadn't tried printing with others, but today I tried FireFox and it prints correctly in black ink only. Likewise, printing with LibreOffice now prints in black ink, so looks like it is all fixed. Not sure why Chrome is different but I will just switch to FireFox for default browser. I'd only been using Chrome because on my laptop it looked better, but this is my desktop and both browsers render similarly on my desktop. I only print from desktop anyway.

Thanks to @Jerry and @torreydale:D
Using Linux Lite for everything now. I put it on my desktop and my laptop. Woohoo!
 

Re: How to set printer to print in black and white by default?
« Reply #6 on: June 29, 2017, 10:20:34 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7849
    Posts
  • Country: nz
  • Reputation: 741
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.2 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
What was the actual method that worked?
 

Re: How to set printer to print in black and white by default?
« Reply #7 on: June 29, 2017, 01:38:52 PM »
 

Vera

  • PayPal Supporter
  • Forum Regular
  • *****
  • 140
    Posts
  • Country: 00
  • Reputation: 16
  • Enjoying Linux Lite.

  • Linux Lite: 3.4 64bit

  • CPU: Intel Quad Core 1.6GHz

  • MEMORY: 8Gb

  • VIDEO CARD: AMD Radeon
As far as I can tell, it was installing the HP printer package that you mentioned which was the correct solution. I thought the solution had NOT worked, because after installing, I tested printing again with Chrome browser (which insists on printing in color no matter how the printer settings are configured - something I didn't realize at the time). I should have at that point also tried to print from LibreOffice, but did not because I had (incorrectly) assumed that the Chrome color-printing and the LibreOffice color-printing were caused by the same glitch. In actual fact, Chrome was a special case, something I had not realized.

After looking into the lpoptions command mentioned on the stackexchange link you gave (and making no changes after seeing that my printer looked to be correctly configured for black ink only), I at that point tested out the printing again from LibreOffice and from Firefox. Both printed by default in black and white. Chrome still prints in color by default, but as mentioned it seems to be a Chrome-specific issue. 

So, to sum up for anyone else facing the same problem that I did (with this type of printer):
1. Install the HP Printer Control Panel using the code that @Jerry gave above.
2. Make sure your settings are set for black ink only in the HP control panel.
3. All done. You should be printing in black ink only now. At least, it's working that way fine in Firefox and LibreOffice for me. Please note that (at least for me and my setup) Chrome by default still insists on printing in color. If you also see this behavior with Chrome, consider not using Chrome browser and using Firefox instead if default black ink printing is important to you.

(Or if you want to use Chrome to print in black ink then just override per-document every time you print from it; just use the printing option circled at the bottom of Screenshot B in my original post above and change from color to black ink in the dialog box that is pulled up).

Thanks so much Jerry for fixing my problem, and I'm sorry for complicating things when I didn't realize that the Chrome behavior and the LibreOffice behavior arose from different causes.
Using Linux Lite for everything now. I put it on my desktop and my laptop. Woohoo!
 

Re: How to set printer to print in black and white by default?
« Reply #8 on: June 29, 2017, 07:34:54 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7849
    Posts
  • Country: nz
  • Reputation: 741
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.2 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Thanks Vera, there's a chance that torrey's option worked as well since Chrome was being so inflexible.
 

Re: How to set printer to print in black and white by default?
« Reply #9 on: June 30, 2017, 07:05:06 AM »
 

Vera

  • PayPal Supporter
  • Forum Regular
  • *****
  • 140
    Posts
  • Country: 00
  • Reputation: 16
  • Enjoying Linux Lite.

  • Linux Lite: 3.4 64bit

  • CPU: Intel Quad Core 1.6GHz

  • MEMORY: 8Gb

  • VIDEO CARD: AMD Radeon
Good point Jerry. Users facing the same problem should try Torreydale's solution in addition to yours.
Using Linux Lite for everything now. I put it on my desktop and my laptop. Woohoo!
 


Tags:
 


Download Linux Lite 5.2 today - See Release Announcements