You are Here:
Linux Lite 5.0 Final is now available for download and installation



[ SOLVED ] gscan2pdf error message on startup?

Author (Read 4359 times)

0 Members and 2 Guests are viewing this topic.

gscan2pdf error message on startup?
« on: September 05, 2019, 11:53:07 AM »
 

lintek

  • Occasional Poster
  • **
  • 52
    Posts
  • Country: us
  • Reputation: 2
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Intel Core i3-2120 CPU @ 3.30GHz

  • MEMORY: 8Gb

  • VIDEO CARD: EVGA GT710
I get this error (?) message every time I start gscan2pdf scanner program.  Any ideas how to fix it?



Is it just a matter of installing something called PDFTK?
Last Edit: September 06, 2019, 11:46:07 AM by lintek
 


Re: gscan2pdf error message on startup?
« Reply #1 on: September 05, 2019, 12:17:15 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7694
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Code: [Select]
sudo apt-get install pdftk
 

Re: gscan2pdf error message on startup?
« Reply #2 on: September 05, 2019, 12:55:04 PM »
 

lintek

  • Occasional Poster
  • **
  • 52
    Posts
  • Country: us
  • Reputation: 2
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Intel Core i3-2120 CPU @ 3.30GHz

  • MEMORY: 8Gb

  • VIDEO CARD: EVGA GT710
tried that - no luck here were the results:

Quote
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package pdftk is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'pdftk' has no installation candidate
 

Re: gscan2pdf error message on startup?
« Reply #3 on: September 05, 2019, 10:49:18 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7694
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Where did you get gscan2pdf from?
 

Re: gscan2pdf error message on startup?
« Reply #4 on: September 06, 2019, 02:40:47 AM »
 

lintek

  • Occasional Poster
  • **
  • 52
    Posts
  • Country: us
  • Reputation: 2
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Intel Core i3-2120 CPU @ 3.30GHz

  • MEMORY: 8Gb

  • VIDEO CARD: EVGA GT710
http://gscan2pdf.sourceforge.net/

Quote
sudo apt-add-repository ppa:jeffreyratcliffe/ppa

sudo apt-get update

sudo apt-get install gscan2pdf
 

Re: gscan2pdf error message on startup?
« Reply #5 on: September 06, 2019, 03:30:27 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7694
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
You don't need a PPA, gscan2pdf is already available in 4.x

Uninstall the program, remove the PPA as per the Help Manual instructions.

Then:

Code: [Select]
apt policy gscan2pdf
should return something like:

Code: [Select]
gscan2pdf:
  Installed: (none)
  Candidate: 2.1.0-1
  Version table:
     2.1.0-1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu bionic/universe i386 Packages

if the version info is the same as above, then:

Code: [Select]
sudo apt-get install gscan2pdf
and in future, consult the Forums before adding PPA's, they are complicated. Cheers :)
 

Re: gscan2pdf error message on startup?
« Reply #6 on: September 06, 2019, 11:45:52 AM »
 

lintek

  • Occasional Poster
  • **
  • 52
    Posts
  • Country: us
  • Reputation: 2
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Intel Core i3-2120 CPU @ 3.30GHz

  • MEMORY: 8Gb

  • VIDEO CARD: EVGA GT710
...and in future, consult the Forums before adding PPA's, they are complicated. Cheers :)

THANKS - FIXED!  Will do.  Just trying to figure out things on my own instead of being so needy.  But you always come through, so THANKS!
 

Re: gscan2pdf error message on startup?
« Reply #7 on: September 06, 2019, 11:57:05 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7694
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
All good :)

Sent from my Mi Max Prime using Tapatalk

 


Tags:
 


Linux Lite 5.0 Final is now available for download and installation