You are Here:
Download Linux Lite 5.2 today - See Release Announcements



[ SOLVED ] Epson XP-245

Author (Read 10519 times)

0 Members and 1 Guest are viewing this topic.

Epson XP-245
« on: February 18, 2018, 12:28:45 AM »
 

aussie1

  • New to Forums
  • *
  • 9
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Intel Celeron Processor

  • MEMORY: 4Gb

  • VIDEO CARD: On board
Hello, today i went and bought a new Epson XP-245 printer and have connected it to the computer via a USB cable but can`t print anything. The copy works perfectly, just not print and scan.

Any help would be grateful.

 aussie1.
Last Edit: February 18, 2018, 10:01:32 PM by aussie1
 


Re: Epson XP-245
« Reply #1 on: February 18, 2018, 12:49:20 AM »
 

supergamer

  • Forum Regular
  • ***
  • 163
    Posts
  • Country: us
  • Reputation: 27
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: AMD Phenom 565

  • MEMORY: 12Gb

  • VIDEO CARD: 550 ti
I have to ask this. Did you try to set it up from the printers program that is in the menu?
 

Re: Epson XP-245
« Reply #2 on: February 18, 2018, 04:19:24 AM »
 

aussie1

  • New to Forums
  • *
  • 9
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Intel Celeron Processor

  • MEMORY: 4Gb

  • VIDEO CARD: On board
supergamer, i went into the menu - System - Printers and added the Generic-ESC-P-Dot-Matrix and it says connected to localhost.
 

Re: Epson XP-245
« Reply #3 on: February 18, 2018, 05:09:36 AM »
 

ptyerman

  • Occasional Poster
  • **
  • 62
    Posts
  • Country: gb
  • Reputation: 28
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Core i7 920

  • MEMORY: 16Gb

  • VIDEO CARD: Radeon RX580
You have to install the printer drivers supplied by Epson. Go to the Epson download centre and search for XP-245 Linux driver. They aren't mega hard to install but they aren't straightforward either, read the docs carefully.
I have the XP-830 Premium, and it works great in Linux with the Epson drivers, mine is connected by wireless network so I can print and scan from anywhere in the house.
 

Re: Epson XP-245
« Reply #4 on: February 18, 2018, 05:12:39 AM »
 

justme2

  • PayPal Supporter
  • Forum Regular
  • *****
  • 201
    Posts
  • Country: gb
  • Reputation: 25
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Intel i5 vPro

  • MEMORY: 8Gb

  • VIDEO CARD: Intel
supergamer, i went into the menu - System - Printers and added the Generic-ESC-P-Dot-Matrix and it says connected to localhost.

Its an inkjet printer, not dot matrix so I think that driver will not work.

Epson claim to provide linux drivers for some printers,
https://www.epson.co.uk/viewcon/corporatesite/products/mainunits/faq/3458/20002
See if yours is listed. :)
1) Lenovo T520 i5 LL3.8 8GB ram, fast & stable
2) Medion P4 32bit LL3.8 1GB ram, quite fast & stable
3) eeePC 901 32bit LL3.8 1GB ram, fast & stable
4) eeePC 701 32bit LL3.8 1GB ram, slower & stable but small and light enough to travel with me to New Zealand when visiting family in Blenheim.
 

Re: Epson XP-245
« Reply #5 on: February 18, 2018, 08:32:03 AM »
 

aussie1

  • New to Forums
  • *
  • 9
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Intel Celeron Processor

  • MEMORY: 4Gb

  • VIDEO CARD: On board
I went to the website http://support.epson.net/linux/en/imagescanv3.php?version=1.3.25 but which version do i download and how to install it ?
 

Re: Epson XP-245
« Reply #6 on: February 18, 2018, 09:13:40 AM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3180
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Hello aussie1,

based on the stats below your user name you would download the Ubuntu 16.04 LTS 32 Bit.
These are their installation instruction for this -
http://download.ebz.epson.net/man/linux/imagescanv3_e.html#sec6-1
 

Re: Epson XP-245
« Reply #7 on: February 18, 2018, 09:49:09 AM »
 

ptyerman

  • Occasional Poster
  • **
  • 62
    Posts
  • Country: gb
  • Reputation: 28
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Core i7 920

  • MEMORY: 16Gb

  • VIDEO CARD: Radeon RX580
Also, that's only the scanner driver. You will need the printer driver too, they are two separate packages.
Go here http://download.ebz.epson.net/dsc/search/01/search/searchModule and select Linux in the dropdown box, type xp-245 in the search box and press your enter key, it will take you to the downloads for your printer. There is 3 files to download, the printer driver, the Epson printer utility, and the scanner driver. The readme files tell you how to install them.
 

Re: Epson XP-245
« Reply #8 on: February 18, 2018, 03:16:17 PM »
 

aussie1

  • New to Forums
  • *
  • 9
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Intel Celeron Processor

  • MEMORY: 4Gb

  • VIDEO CARD: On board
I have downloaded the Ubuntu 16.04 LTS 32 Bit file and followed the instructions on how to install it from README.rst and try to install the file
Quote
dpkg --install ./core/imagescan_3.35.0-1epson4ubuntu16.04_amd64.deb ./plugins/imagescan-plugin-ocr-engine_1.0.0-1epson4ubuntu16.04_amd64.deb ./plugins/imagescan-plugin-gt-s650_1.0.0-1epson4ubuntu16.04_amd64.deb ./plugins/imagescan-plugin-networkscan_1.1.1-1epson4ubuntu16.04_amd64.deb

So i type in my superuser password and it says error: requested operation requires superuser privilege. I know my password so how can that be wrong ? or did i do something wrong.
Last Edit: February 18, 2018, 04:03:54 PM by aussie1
 

Re: Epson XP-245
« Reply #9 on: February 18, 2018, 07:38:40 PM »
 

ptyerman

  • Occasional Poster
  • **
  • 62
    Posts
  • Country: gb
  • Reputation: 28
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Core i7 920

  • MEMORY: 16Gb

  • VIDEO CARD: Radeon RX580
Not sure what's wrong, try installing the .debs using Gdebi instead of dpkg, I never used dpkg when installing mine. Install the printer drivers first followed by the print utility, lastly install the scanner driver.
The printer drivers are pretty much trouble free once installed and require no configuration beyond checking your defaults. The scanner ones can be a real headache to get working properly. However, my XP-830 is connected by wireless network and required extra steps, if your using straight USB it may be a straightforward procedure.
 

Re: Epson XP-245
« Reply #10 on: February 18, 2018, 08:22:44 PM »
 

aussie1

  • New to Forums
  • *
  • 9
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Intel Celeron Processor

  • MEMORY: 4Gb

  • VIDEO CARD: On board
What i did was installed the printer drivers first followed by the print utility, and when i was installing the scanner driver i followed the README.rst and when i got to the part ./install.sh and this is what i get:

Quote
Hit:1 http://repo.linuxliteos.com/linuxlite citrine InRelease                                                       
Hit:2 http://us.archive.ubuntu.com/ubuntu xenial InRelease                                                           
Hit:3 http://archive.canonical.com xenial InRelease                                           
Hit:4 http://ppa.launchpad.net/nemh/systemback/ubuntu xenial InRelease                         
Get:5 http://us.archive.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                       
Hit:6 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial InRelease                               
Get:7 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]                                   
Hit:8 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial InRelease
Get:9 http://us.archive.ubuntu.com/ubuntu xenial-proposed InRelease [253 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]                                                                                                                                 
Fetched 560 kB in 12s (43.4 kB/s)                                                                                                                                                                             
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libboost-filesystem1.62.0
E: Couldn't find any package by glob 'libboost-filesystem1.62.0'
E: Couldn't find any package by regex 'libboost-filesystem1.62.0'
E: Unable to locate package libboost-program-options1.62.0
E: Couldn't find any package by glob 'libboost-program-options1.62.0'
E: Couldn't find any package by regex 'libboost-program-options1.62.0'
E: Unable to locate package libboost-system1.62.0
E: Couldn't find any package by glob 'libboost-system1.62.0'
E: Couldn't find any package by regex 'libboost-system1.62.0'
E: Unable to locate package libjpeg62-turbo
derek@derek-desktop:~/Downloads/imagescan-bundle-debian-9-1.3.25.x86.deb$
 

Re: Epson XP-245
« Reply #11 on: February 18, 2018, 08:40:35 PM »
 

ptyerman

  • Occasional Poster
  • **
  • 62
    Posts
  • Country: gb
  • Reputation: 28
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Core i7 920

  • MEMORY: 16Gb

  • VIDEO CARD: Radeon RX580
Wait a minute! Quote from your post.

Quote
derek@derek-desktop:~/Downloads/imagescan-bundle-debian-9-1.3.25.x86.deb$

You have the wrong driver, your trying to install the DEBIAN driver, you need the UBUNTU x86 32 bit driver.
 

Re: Epson XP-245
« Reply #12 on: February 18, 2018, 09:03:06 PM »
 

aussie1

  • New to Forums
  • *
  • 9
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Intel Celeron Processor

  • MEMORY: 4Gb

  • VIDEO CARD: On board
I downloaded the Ubuntu 17.10 32bit (i386, is that the right one ?
 

Re: Epson XP-245
« Reply #13 on: February 18, 2018, 09:05:21 PM »
 

ptyerman

  • Occasional Poster
  • **
  • 62
    Posts
  • Country: gb
  • Reputation: 28
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Core i7 920

  • MEMORY: 16Gb

  • VIDEO CARD: Radeon RX580
No, you need Ubuntu 16.04 32 bit.
 

Re: Epson XP-245
« Reply #14 on: February 18, 2018, 09:30:16 PM »
 

aussie1

  • New to Forums
  • *
  • 9
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Intel Celeron Processor

  • MEMORY: 4Gb

  • VIDEO CARD: On board
This time i downloaded the right file and followed the readme and did this:

Quote
  tar xaf imagescan-bundle-ubuntu-16.04-1.3.25.x86.deb.tar.gz
   cd imagescan-bundle-ubuntu-16.04-1.3.25.x86.deb
   ./install.sh

Is the scanner driver now installed ?
 


Tags:
 


Download Linux Lite 5.2 today - See Release Announcements