Hardware - Support > Printing and Scanning

CUPS Samsung -m2070

(1/1)

Rosario Portoghese:
Hi
I'm new to linux.
I'm facing  a lot a problems with -m2070 printer.
When I open cups server and I look for available printers I find several entries of Samsung -m2070, here what I find:

Samsung M2070 Series (Samsung M2070 Series (SEC84251902B75C))
 Samsung M2070 Series (Samsung M2070 Series)
 Samsung M2070 Series (Samsung M2070 Series (driverless))

What does it mean? Should I install one of those printers?
Anyway even if I install one of the available printers at the end of the process, when _I try to print test page I get the message:"Filter Failed".
Does CUPS work properly with linux lite?

thanks

arky217:

--- Quote from: Rosario Portoghese on April 24, 2021, 01:37:38 PM ---Hi
I'm new to linux.
I'm facing  a lot a problems with -m2070 printer.
When I open cups server and I look for available printers I find several entries of Samsung -m2070, here what I find:

Samsung M2070 Series (Samsung M2070 Series (SEC84251902B75C))
 Samsung M2070 Series (Samsung M2070 Series)
 Samsung M2070 Series (Samsung M2070 Series (driverless))

What does it mean? Should I install one of those printers?
Anyway even if I install one of the available printers at the end of the process, when _I try to print test page I get the message:"Filter Failed".
Does CUPS work properly with linux lite?

thanks

--- End quote ---

I have a Samsung M4070FR network printer/scanner and I struggled for a long time
to get it to print and scan usings CUPS.
But, I finally have it down pat with the following instructions.
If your printer is a network printer (and it seems to be since it has an ethernet connection), you should be able to give it a static ip address via the panel
on the printer. If so, or if you use a print server with it, then these instructions
should work for you.

* Add printer using CUPS:
  First, enable and start cups with   sudo systemctl enable cups
  then  sudo systemctl start cups  then reboot
  Then turn on printer
  then install printer using the terminal with the command:

  lpadmin -p jimsprinter -E -v ipp://192.168.1.149 -m everywhere

  ( this method has worked every time for me)
 
  ( the -p option is the name you select for the printer, the -E option
    enables the printer and accepts new print jobs, the -v option sets the
    uri for the printer which for mine is ipp://192.168.1.149, the -m option is the
   driver which is called 'everywhere', (it's the CUPS generic driver))

Using this method, you don't have to install any Samsung drivers.

Now to get the scanner to work I had to open /etc/sane_d/xerox_mfp.conf
as root and add the line

tcp 192.168.1.149

The static address you give the printer has to be compatible with the
range of addresses that your router uses and depending on your router,
it should be 192.168.1or2.xxx

Navigation

[0] Message Index

Go to full version