You are Here:
Download Linux Lite 5.4 Final today - See Release Announcements



X Close Ad
X Close Ad
[ SOLVED ] Samsung M2070 CUPS internal server error

Author (Read 1408 times)

0 Members and 2 Guests are viewing this topic.

Samsung M2070 CUPS internal server error
« on: April 10, 2021, 02:17:30 AM »
 

gimble guy

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
I tried many different ways to install the Samsung M2070 Printer, USB and Network. But I get CUPS internal-server-error or something like that.

I'm using the latest LinuxLite. Firewall is disabled
Last Edit: April 12, 2021, 02:42:47 AM by Jerry
 


Re: Samsung M2070 CUPS internal server error
« Reply #1 on: April 10, 2021, 04:40:53 PM »
 

arky217

  • Occasional Poster
  • **
  • 52
    Posts
  • Country: us
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: Pentium Gold G5400

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 610

  • Kernel: 5.x
I also have a Samsung network printer, model M4070FR,
 and have finally figured out a simple way to get it and the built in scanner to work.

First of all, to get the scanner to work, in the printers menu, select network,
ipv4, change from DHCP to static and give your printer a static address.
Then edit as root, /etc/sane.d/xerox_mfp.conf  and add the line
tcp 192.168.x.xxx  the x should be either a 1 or 2 depending on
your router's address, and the xxx is the static address you give the printer.

To install the printer:

Go to printers in the LL menu, add new printer, click on network printers, select your printer,
select postscript.Samsung, select generic driver, select postscript, then OK.

That should install the printer using the generic cups drivers and
you won't have to mess with installing Samsung drivers.
 

Re: Samsung M2070 CUPS internal server error
« Reply #2 on: April 11, 2021, 10:18:55 PM »
 

gimble guy

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
On MXLinux, it automatically setup the IPP everything is automatic. Not sure why the CUPS is like this in Linuxlite

here's the syslog:

Apr 12 12:22:28 Thermalite kernel: [  160.887802] audit: type=1400 audit(1618194148.197:33): apparmor="DENIED" operation="open" profile="/usr/lib/cups/backend/cups-pdf" name="/etc/cups/" pid=2773 comm="cups-pdf" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
Apr 12 12:22:28 Thermalite kernel: [  160.893158] usblp2: removed
Apr 12 12:22:28 Thermalite kernel: [  160.917423] usblp 7-2:1.1: usblp2: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04E8 pid 0x3469

here's the output why running the system-config-printer software:
system-config-printer
/usr/share/system-config-printer/system-config-printer.py:315: DeprecationWarning: Gtk.ActionGroup.list_actions is deprecated
  for action in printer_manager_action_group.list_actions ():
/usr/share/system-config-printer/system-config-printer.py:316: DeprecationWarning: Gtk.Action.set_sensitive is deprecated
  action.set_sensitive (False)
/usr/share/system-config-printer/system-config-printer.py:324: DeprecationWarning: Gtk.ActionGroup.get_action is deprecated
  act = printer_manager_action_group.get_action (action)
/usr/share/system-config-printer/system-config-printer.py:354: DeprecationWarning: Gtk.UIManager.ensure_update is deprecated
  self.ui_manager.ensure_update ()
/usr/share/system-config-printer/system-config-printer.py:355: DeprecationWarning: Gtk.UIManager.get_accel_group is deprecated
  self.PrintersWindow.add_accel_group (self.ui_manager.get_accel_group ())
/usr/share/system-config-printer/system-config-printer.py:364: DeprecationWarning: Gtk.UIManager.get_action is deprecated
  action = self.ui_manager.get_action ("/new-printer")
/usr/share/system-config-printer/system-config-printer.py:365: DeprecationWarning: Gtk.Action.create_menu_item is deprecated
  newprinteritem = action.create_menu_item ()
/usr/share/system-config-printer/system-config-printer.py:663: DeprecationWarning: Gtk.Action.get_proxies is deprecated
  for widget in action.get_proxies ():
/usr/share/system-config-printer/system-config-printer.py:2236: DeprecationWarning: Gdk.threads_enter is deprecated
  Gdk.threads_enter ()
Caught non-fatal exception.  Traceback:
File "/usr/share/system-config-printer/newprinter.py", line 4241, in getNPPPD
    ppd = cups.PPD(f)
RuntimeError: ppdOpenFile failed
Continuing anyway..
Caught non-fatal exception.  Traceback:
File "/usr/share/system-config-printer/newprinter.py", line 1903, in setNPButtons
    uri = self.getDeviceURI ()
File "/usr/share/system-config-printer/newprinter.py", line 3531, in getDeviceURI
    type = self.device.type
AttributeError: 'NoneType' object has no attribute 'type'
Continuing anyway..
Caught non-fatal exception.  Traceback:
File "/usr/share/system-config-printer/newprinter.py", line 4241, in getNPPPD
    ppd = cups.PPD(f)
RuntimeError: ppdOpenFile failed
Continuing anyway..



Last Edit: April 11, 2021, 10:28:21 PM by gimble guy
 

Re: Samsung M2070 CUPS internal server error
« Reply #3 on: April 12, 2021, 12:04:30 AM »
 

gimble guy

  • New to Forums
  • *
  • 4
    Posts
  • Reputation: 0
So finally  :57: After installing the Samsung Linux Drivers, and I also stole the M2070PPD file from my MXLinux install. With these two combination noodles, I finally got my Samsung M2070FW Printer and Scanner working in the Network. All DHCP. OMG I am so happy. But please if someone out there can fix the CUPS to work properly like in MXLinux does. I would really appreciate it. :D

Peace!
 

Re: Samsung M2070 CUPS internal server error
« Reply #4 on: April 12, 2021, 09:07:34 AM »
 

TheDead

  • Gold Level Poster
  • *******
  • 881
    Posts
  • Country: ca
  • Reputation: 74
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 4.8 64bit

  • CPU: HAL9000

  • MEMORY: 2Gb

  • VIDEO CARD: Quantum State VR v.3

  • Kernel: 4.x
Have to leave for work... but maybe this would help.
https://blog.dzhuneyt.com/using-a-samsung-m2070-printer-on-ubuntu-linux/
Could be for the printer only though... got to go, keep me posted. ;)
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.4 Final today - See Release Announcements