Hardware - Support > Printing and Scanning

Cannot get Epson printer to work

(1/1)

finbarrus:
I have been through the posts on this forum but unable to find a solution to my problem.

I have replaced an HP printer with an Epson ET-4700.  The HP worked fine.

When I try to add the Epson, however, although my laptop can see it as a Network printer, it resolutely fails to install and the process returns the following error message:

CUPS Server Error, and says 'server-error-internal-error' 

I don't know how to get round this block; if anyone can help I will be eternally grateful.  I'm sure there'll be a simple solution but I am not experienced enough to find it!

UPDATE : have gone thru CUPS localhost:631 interface to add printer, which now appears in the printer list. Unfortunately still doesn't print. Tried to print a test page but received message  "Unable to locate EPSON51FAC0"

stevef:
Have you downloaded and installed the linux drivers for the product ?
If so did you complete the whole install ?

There is a thread discussing the firewall as being a potential cause, is your firewall disabled ?

stevef:
Might be worth looking through this tutorial.

https://tutorialforlinux.com/2021/06/05/step-by-step-driver-epson-et-4700-ubuntu-20-04-installation/

finbarrus:
Thanks Stevef,

yes firewall is disabled, I'm not sure about the drivers though as they don't seem to want to load automatically.  When I look at the epson download page there are five drivers and the on I *think* I need downloads as a file to be opened with VLC, which seemed weird and in any case wouldn't open! So I'm baffled by that.

I'll go through the tutorial tomorrow and report back on progress.

stevef:
If your system is trying to open a driver file with VLC then something is almost certainly wrong but you'd need to elaborate a bit about what you're seeing.

I think the Epson drivers that come with Linux Lite (version 5.x) are epson's v1.7.7 which dates back to January 2020.  It appears your printer became available at about the same time so the built in LL drivers might be ok - it's hard to tell from the information I can find.

If you followed the help manual instructions and came up with a failure to install then it might be the driver needs updating.  The current driver version on the Epson site is 1.7.18.

Did the printer come with any linux support information ?

Navigation

[0] Message Index

Go to full version