Hardware - Support > Printing and Scanning

Brother HLL2390dw install problem

(1/4) > >>

Ran the Driver install tool from Brother but it didn't give the Device URI as USB. I selected no when asked. Changed it to "usb://Brother/HLL2390DW but still wont see the printer. Checking on the CUPS:631 and it shows as USB now. Checked and the driver is installed.On the CUPS 631  it says to "Add device and driver" I select the device but not sure about the driver?Probably missing something simple but will only mess things up more if I keep farting around.I see three uninstaller scripts in the unzipped folder, not sure if they would be sudo bash etc. or not. I had ran the installer several times over top of the first, probably not helpful.
Starting to wish I had stayed with HP.Any ideas anyone?
Oh running LL 5.2 or 5.4 not sure. :-)

Hello waynebob,
maybe the different installs had conflicted.

Here is how to purge -

This page has a tutorial on installing it, it shows how to install differently than specified on the Brother tutorial, it may have some differences worth trying, on the install.


Thanks Bitsnpcs, I looked at the purge instructions and scratched my head. Not helpful at all.
I did the Brother uninstallers instead. got a couple messages about did not remove this or that because of this or that. :-)
Tried the alternate install method and got the same result, didn't work and the printer still shows the Device URI as an ipp instead of USB.Sometimes trying to print a page the printer will spring to life and start spitting out blank pages, I have to stop it, not sure how long it would go. lol.
Thanks anyway, maybe I will try installing it on my spare machine and see if anything different happens. It is a little slower but not scared to break it.I feel a bit like poor Kenneth trying to  get going with Google Earth.

Hello waynebob,

I found this link, it is for a different model of Brother printer -

It seems to have some information such as -

You enter No and do not enter the URI.
You enter Yes and do enter the URI

You state you entered No and entered the URI, can it be the issue ?

Also on the link -

--- Code: ---sudo lpinfo -v
--- End code ---

The resultant descriptor has serial # to it after printer name, for identifying ?

Hi bitsnpcs, I entered no but still didn't get USB setup.
I tried the same driver installer on my spare machine also with LL 5.2 with the same results.Installed Ubuntu on second HDD on spare machine and the printer was just there automatically. It prints a test page and a document page fine.Scan tries but fails.
I checked the sudo link and it shows this:[sudo] password for linuxlite: file cups-brf:/
network socket
network beh
network lpd
network ipp
network https
file cups-pdf:/
network http
direct hp
network ipps
network smb
serial serial:/dev/ttyS0?baud=115200
Not sure what it means.
My device URI shows this:ipp://HL-L2390DW._ipp._tcp.local/I tried putting in USB in place of the ipp but didn't work.


[0] Message Index

[#] Next page

Go to full version