Hardware - Support > Printing and Scanning

Brother HLL2390dw install problem

<< < (3/4) > >>

waynebob:
The sudo lpstat -s is : linuxlite  ~  sudo lpstat -s
[sudo] password for linuxlite:
system default destination: HLL2390DW
device for HLL2390DW: usb://dev/usblp0
I changed it to the other link, rebooted and still nothing.Wont print test page or self-test page.How do you show your terminal copy/paste, mine is terrible.

The Brother driver page shows how to verify the USB setting, I changed it but no difference.https://support.brother.com/g/b/downloadhowto.aspx?c=ca&lang=en&prod=hll2390dw_us&os=128&dlid=dlf103579_000&flang=4&type3=10283

firenice03:
@waynebob

Have you tried that in the manual?
https://www.linuxliteos.com/manual/hardware.html#printer

Directly from Brother...
https://support.brother.com/g/b/faqcategory.aspx?c=us&lang=en&prod=hll2390dw_us&ftype2=10066

- Cant print via USB..
https://support.brother.com/g/b/faqend.aspx?c=us&lang=en&prod=hll2390dw_us&ftype3=100257&faqid=faq00100729_000

bitsnpcs:

--- Quote from: waynebob on March 26, 2021, 12:23:34 PM ---How do you show your terminal copy/paste, mine is terrible.

--- End quote ---

I type the word, code , inside a pair of square brackets [  ] , (no spaces between the brackets and word) , then paste the terminal results, then after this I type, /code ,inside another pair of the square brackets.

You can alternatively press the hash button "#" shown above the emoticons 2 times and paste the terminal results between this, you need to then add a / before the word code inside the second pair of brackets (no spaces).
Otherwise anything you type after the code will appear inside the highlighted code box too, as it was not closed as there is no /

waynebob:
Hi firenice03
I didn't get anything when I plugged in the usb cable. I have tried the stuff in the help manual but can't get the right usb address I guess?
The Brother website says this: Depending on the connection type you are using (USB or Network), follow one of the steps below.
 
 (for USB Connection)
* Open a web browser and go to "http://localhost:631/printers".
* Check if the Device URI of your printer is "usb://Brother/(your printer's model name)"
 
 If the device URI is different from the example above, please go to "Modify Printer" of your printer to select proper device and driver.
 If your printer is not listed on "http://localhost:631/printers", please go to "http://localhost:631/admin" and click "Add printer" and select proper device and driver.I fooled around on the CUPS page and got nowhere.I tried your troubleshooting link (good find) uninstalled drivers, installed patch then reinstalled drivers.
The last line on the legacy patch said "No such device or address"As usual I don't know if that means anything or not.I have been using LL for several years now and love it. Printers seem to haunt me.Why does Ubuntu see the printer right off the bat and LL doesn't?Oh well, thanks guys will keep monkeying around.

waynebob:
Hi firenice03, I tried everybodys advice several times, looked around Ubuntu and Mint forums and still no luck.
Just now tried your link from Brother about can't print to usb for the third time and it worked. ? Still a win. :-)

https://support.brother.com/g/b/faqend.aspx?c=us&lang=en&prod=hll2390dw_us&ftype3=100257&faqid=faq00100729_000
Image Scanning Program not working? Failed to open device brother4:bus2;dev1: Invalid argument.
Document Scanner shows ready to scan but Unable to connect to scanner.

My mistake, the scanning works fine. I just realized that I need to turn on the scanner if it has gone into deep sleep.

Thank you for all of your help, Wayne.


Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version