Software - Support > Other

Yet Another Slow Laptop...

(1/2) > >>

Weeeell, things took a surprising turn. The Lenovo 330 ideapad was a failure.  It would run OK for about 24-hours after a clean install, then the next day, it would fail to boot.  (See LL 6.6 runs OK after clean install, but crashes after about 24-hours.

But when it did run, it was just as bad as the Dell!  It now has Windows 10 back on it and is serving as a controller for a bunch of printers.

I resurrected the Dell and it was getting reeeeal slow. Then programmes, such as Chromium and OpenOffice were not opening.  Aisleriot and Mines were OK, but I can't surf the net or write notes with them.

I went to move some files from a USB-stick to the laptop, not even big ones, less than a Meg.  Could do it due to lack of space. That raised an eyebrow.  I checked: sure enough, the file manager was showing 234,6 GB of 234,6 GB was used!

I had installed a few games and other programmes that I hardly or even never used, so I tried to use Synaptic, then apt-get to remove them.  I first tried WINE, but it would happen, as there was not enough space.  I removed some others first, which freed up space, then moved onto getting rid of WINE.

Also I ditched a few Gigs worth of personal files I have backed up elsewhere.  In the end, I cleared out just over 60 GB of junk.

Now the old Dell runs uite nicely - OK, it's not a lean, mean, gaming machine, but it is no longer frustratingly slow.

Problem solved  ;D :045:

And now we're back, with a bit better(?) laptop - a Lenovo ideapad 330 and... it's just as bad! Seriously, the fan is running pretty much all the time when using Chromium browser. In fact Chromium is even worse on this laptop than it was on  Dell Lattitude.

I have cleaned it out - took the case cover off, blasted with compressed air.

CPU: Dual Core AMD A6-9225 RADEON R4 5 COMPUTE CORES 2C+3G (-MCP-) speed/min/max: 1300/1300/2600 MHz
Kernel: 5.15.0-76-generic x86_64 Up: 20m
Mem: 1291.9/6817.2 MiB (19.0%)
Storage: 238.47 GiB (63.5% used)
Procs: 216
Shell: bash 5.1.16 inxi: 3.0.38

Thanks for giving this some thought.  Yes, I have looked at how the processor ramps up and down - I have the CPU Frequency Monitor down in the taskbar.  It shows an nice 1,8 GHz plus or minus a bit.  I set the power scaling to be for maximum performance when plugged into mains, which the laptop spends 99,9% of the time.

I have also opened up the case and given it a good blast with the compressed-air.

I hadn't considered that the thermal paste has dried out/degraded, but to be honest, I am reluctant to start stripping the hardware down, just in case it doesn't go back together properly.  I have stripped and rebuilt many, many laptops in the past, but at the moment, I only have one laptop/PC, so don't really want to be without it running for a couple of days.

Other than the apparent sluggishness, everything actually works, so I will leave things alone and just bear with it.

Again, thanks for thoughts.

I know you've more or less decided an outcome, but there are a couple of things you can investigate:
- because this is a laptop you might want to check the power saving settings (many defaults are to maximise runtime when on battery but perform a bit better when connected to line power).
- sort of related to the previous point, but check the CPU scheduler settings to make sure that the clock frequency is ramped up quickly (I've encountered this on a non-x86 platform but I've not seen similar on x86 platforms so this is fairly unlikely).
- you might want to check whether the fan/heatsink is clogged with dust etc too - fan activity like you report suggests the CPU might be thermally throttling which wouldn't help performance.  Perhaps the thermal paste between CPU and heatsink has broken down and needs replacing.

I've a number of older machines and I've not encountered a Linux installation that didn't perform at least as well as Windows, especially running from an SSD, hardware problems notwithstanding.  While I've not had any Dell laptops their hardware is usually not too bad.

Weeeeell... I had another, identical SSD, so I swapped them over and did a nice clean install of Windows 10.
It was just as bad.  Laggy, fan running quite often.  pretty much the same experience.  I guess it must have been rose-tinted glasses and dodgy memory when I remembered back to when it ran Windows before - then I remembered: It was Windows 7.

I guess then, it's CASE CLOSED - crap hardware.  :037:


[0] Message Index

[#] Next page

Go to full version