You are Here:
Linux Lite 7.0 RC1 Released - See Release Announcement Section



Turn off desktop grid snap

Author (Read 9685 times)

0 Members and 2 Guests are viewing this topic.

Re: Turn off desktop grid snap
« Reply #17 on: November 15, 2016, 12:16:07 AM »
 

JmaCWQ

  • Forum Regular
  • ***
  • 227
    Posts
  • Reputation: 44
    • View Profile
No probs for the help, hopefully you'll find an easy solution.

I like 2.8, it's also my goto distro when the others I'm playing with either won't do what I want or irritate me somehow, LOL.
Had no stability issues with 3.0 but there were a couple of things that I couldn't get working how I wanted, a result of the upgraded Ubuntu & Xfce versions I think.
Haven't tried 3.2 so far, one day when I get some free time I plan to.
And I'm not really a Systemd fan yet, it appears that occasionally it causes issues with my hardware that affects the network, not very often but only happens if I'm using a Systemd init distro.
2.8 uses Upstart which never seems to cause any problems with the hardware I have.
 

Re: Turn off desktop grid snap
« Reply #16 on: November 14, 2016, 03:00:54 PM »
 

kjacobs

  • Occasional Poster
  • **
  • 71
    Posts
  • Reputation: 5
  • Linux Lite Member
    • View Profile

  • CPU: 2x Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz

  • MEMORY: 4Gb
Well now......there is a part of me that wants to change the public machine over to LL as the first part of a migration.....LOL. Yes, I think Mint uses mdm, instead of lightdm, for the autologin.....there must be a slight difference in those. I will think very seriously about switching them over to LL.....as I always seem to return to LL when the other distros give me grief.....LOL.

BTW.....I find it interesting you are still on LL 2.8, as am I. I tested LL 3.0 on my daughters computer (who BTW loves linux) and another machine of mine and found some minor stability issues with it on those machines. Never brought myself to changing my main desktop over.....and am curious how the recent LL 3.2 will do.

Anyway, many thanks again for the help......

Ken
 

Re: Turn off desktop grid snap
« Reply #15 on: November 14, 2016, 02:03:42 PM »
 

JmaCWQ

  • Forum Regular
  • ***
  • 227
    Posts
  • Reputation: 44
    • View Profile
Interesting....I just enabled auto login on my LL-2.8 to try it & the icons stay in the locked position after a restart.
Unlocked them and restarted & they all jumped left.
Locked them again, turned off auto login, restarted & they stay locked, turned on auto login again, restarted & they stay locked....

I had to create the file /etc/lightdm/lightdm.conf and paste the lines below into it to enable auto login as it wouldn't work from Menu > System > Login Settings until I created that file & restarted, 'home' being the username I login with.

Code: [Select]
[SeatDefaults]
autologin-guest=false
autologin-user=home
autologin-user-timeout=0
autologin-session=lightdm-autologin
greeter-session=lightdm-webkit-greeter
user-session=xfce

I guess with your setup/s it's either something to do with having more than 1 account, or there's some little difference between LL Xfce & Mint Xfce that's triggering it.
« Last Edit: November 14, 2016, 02:06:26 PM by JmaCWQ »
 

Re: Turn off desktop grid snap
« Reply #14 on: November 14, 2016, 02:33:38 AM »
 

kjacobs

  • Occasional Poster
  • **
  • 71
    Posts
  • Reputation: 5
  • Linux Lite Member
    • View Profile

  • CPU: 2x Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz

  • MEMORY: 4Gb
Alrighty....a little more testing and I can confirm the issue causing the icons to not be locked is caused by the autologin function. As long as that is turned off, the icons will remain where locked. Once the autologin is turned on and the computer is rebooted, the icons revert back to the left.....go figure! I may have no choice but to switch back to the version they are running on the rest of the machines in order to maintain hardware compatibility with their computers........geeeeez.
 

Re: Turn off desktop grid snap
« Reply #13 on: November 14, 2016, 01:45:18 AM »
 

kjacobs

  • Occasional Poster
  • **
  • 71
    Posts
  • Reputation: 5
  • Linux Lite Member
    • View Profile

  • CPU: 2x Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz

  • MEMORY: 4Gb
OK....I tried locking the admin account, and the public account was already locked. I had only locked the public account once, so I was surprised to see the second file show up in the folder. Even after locking both account, the public account still boots with messed up icons now. Presently is have these two files in the public folder....

icons.screen0-1264x975.rc
icons.screen0-0x0.rc

The first is the one that was created and locked. It worked fine after a few reboots when I was testing. Then I set the account as a desktop user and auto login. After the next reboot, I got the second file and all the icons were on the left again. Of course, the second file has bogus info for icon position, so that explains the icon issue again. I just have no idea why it decided to create a new file on its own.

Oh yes.....I have not even setup the profile refresh part yet, this is just a 2 user setup at this point. It amazes me how long this project has taken.....LOL. I can build normal linux boxes in no time flat, but this one is beating me up.....
 

Re: Turn off desktop grid snap
« Reply #12 on: November 14, 2016, 12:09:50 AM »
 

JmaCWQ

  • Forum Regular
  • ***
  • 227
    Posts
  • Reputation: 44
    • View Profile
Did you try running the lock command while logged in as each different user?
I only use a single user on my setup so haven't tried it with multiple users, but I'm thinking the lock needs to be run when logged in to each account.

My folder has 14 of those files in it currently.
One of them shows today's date for last accessed, the others all show the date I performed the last lock command, the one with today's date for accessed would be the one it's reading the current icon positions from.
I think a new file is created each time I unlock, move things around on the desktop then relock again.
 

Re: Turn off desktop grid snap
« Reply #11 on: November 13, 2016, 11:22:29 PM »
 

kjacobs

  • Occasional Poster
  • **
  • 71
    Posts
  • Reputation: 5
  • Linux Lite Member
    • View Profile

  • CPU: 2x Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz

  • MEMORY: 4Gb
Well crud.....I thought we had this solved, but alas, not so much anymore. I had to recreate my public user profile again.....and I got all the icons lines up again and locked the file. Everything seemed fine until I switched the user to a desktop user and set auto login for the public user. Now when I restart the computer the icons are all on the left again. When it was working I only had one icon file in the xfce/desktop/ folder for the
icon layout. Now what I see in the xfce/desktop/ folder is an additional icon file that was not prior to changing the permission and auto login. I am baffled as to why it would change if its locked.......uggggg.
 

[Solved] Re: Turn off desktop grid snap
« Reply #10 on: November 13, 2016, 03:30:22 PM »
 

kjacobs

  • Occasional Poster
  • **
  • 71
    Posts
  • Reputation: 5
  • Linux Lite Member
    • View Profile

  • CPU: 2x Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz

  • MEMORY: 4Gb
Hi again.....so I tried the icon lock last night on the system and it works perfectly!!!! It even works great with the profile restore from a hidden folder.......a HUGE thank you for that one! You have been a great help solving this one....so I will consider this solved. Thanks again.
 

Re: Turn off desktop grid snap
« Reply #9 on: November 13, 2016, 12:45:12 AM »
 

JmaCWQ

  • Forum Regular
  • ***
  • 227
    Posts
  • Reputation: 44
    • View Profile
You're welcome Ken, hope it works.
LOL, yeah I know what you mean by sometimes it can be tolerated, I used to pretend it didn't happen or I couldn't see it though eventually it would annoy me enough to do something about it so I'd run the lock command to anchor them where I put them.
Now if I install a system with Xfce running that lock is one of the things I do to set the system up before I start using it in general.
I spent a considerable amount of time researching and trying to sort this issue for myself & several other people I installed Linux Lite for, but so far nothing seems to hold permanently except locking the icon file with the above command.
I've only ever used Mint with the KDE desktop though I imagine the command is Xfce specific & should work ok on Mint Xfce.

With removable drives shown on the desktop and their icons are locked to a certain position, if the unlock is run with them not mounted they'll lose their positions & when mounted again they'll but put default top left.
Workaround for that is if I need to unlock to rearrange something, have them mounted when unlocking & relocking with their icons in the required positions.
Then if they're unmounted & unplugged the icon will vanish as normal but when plugged in & mounted again the icon will appear in the position it was when the lock was run.
 

Re: Turn off desktop grid snap
« Reply #8 on: November 12, 2016, 08:40:07 PM »
 

kjacobs

  • Occasional Poster
  • **
  • 71
    Posts
  • Reputation: 5
  • Linux Lite Member
    • View Profile

  • CPU: 2x Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz

  • MEMORY: 4Gb
Wow!!! Thanks JmaCWQ for the detailed info. I will give that a try. Honestly, the library computer builds I am presently working on are Linux Mint XFCE. However, my main desktop is LL 2.8 and I have numerous Linux Lite laptops as well. Linux Lite is my goto distro for everything. If the library was not already using Linux Mint, I would switch those too.....LOL.

But yes, I have seen the same problem on a lot of XFCE desktop systems regardless of distro. I even fought it a bit with my own. Sometimes it can be tolerated....but not in this case. I will give your solution a try and see how it goes....and let you know how it works from a refreshed profile as well.

Thanks again,
Ken
18
 

Re: Turn off desktop grid snap
« Reply #7 on: November 12, 2016, 02:28:20 PM »
 

JmaCWQ

  • Forum Regular
  • ***
  • 227
    Posts
  • Reputation: 44
    • View Profile
Aah yes, the icons jumping left on a restart.
That is something that has annoyed me for quite some time & only seems to happen with the Xfce desktop environment.
I currently have installs of Linux Lite 2.8, Linux Lite 3.0, Debian Jessie and MX-15, all with Xfce & all have the same issue.
I've never been able to find a permanent cure for it but there is a way of locking the desktop icons in position so they don't all jump left upon a restart.

I'm not sure if this method will work with a hidden profile that's refreshed at every restart as I've never used or tried it like that, only one way to find out I guess...

Get the icons where you want them then open Terminal & enter the following command:

Code: [Select]
sudo chattr +i ~/.config/xfce4/desktop/icons*
That should lock the positions of the icons so they don't move around on a restart, it does that by locking the file the icon positions are read from so it can't be written to or changed.
They can still be moved around on the desktop by dragging but a restart or desktop refresh (F5) will realign them to the positions they were in when the lock command was run.

To unlock the icons again use this command:

Code: [Select]
sudo chattr -i ~/.config/xfce4/desktop/icons*
Even with the icons locked any new icons added to the desktop will be placed top left, they can be moved around & will usually hold position until a restart but for them to be permanently moved to a new location the unlock command has to be run, the new icon/s placed in the desired location, then the lock command run again.
If they're not locked & F5 is hit I find they all jump to the top left again, which is the hardcoded Xfce default.
They can be deleted while locked without any problems.

There's a couple of other threads here about the same jumping left issue and there are different solutions in those threads that have worked for other people, though locking the icon file as described above is the only way I have found to permanently keep them where I put them.


« Last Edit: November 12, 2016, 02:30:40 PM by JmaCWQ »
 

Re: Turn off desktop grid snap
« Reply #6 on: November 12, 2016, 01:18:16 PM »
 

kjacobs

  • Occasional Poster
  • **
  • 71
    Posts
  • Reputation: 5
  • Linux Lite Member
    • View Profile

  • CPU: 2x Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz

  • MEMORY: 4Gb
Thanks again.....I have made progress on my public library computer build....am finally happy with icon placement, etc. However, now I am having issues with the icons wanting to auto arrange at reboot time. So, a short explanation.....

The public computer profile is copied to a hidden folder....at each reboot, the main profile is erased and a fresh copy is copied from the hidden folder. The machine starts with a fresh profile each morning when it is turned on....and this provides a quick fix if a user messes up the machine somehow, a library worker can simply restart and it is ready to go again. However, each time I reboot the icon placement is destroyed and all the icons are stacked down the left side of the desktop. The hidden profile folder has the correct desktop layout, so this is happening at reboot. How can I turn off the auto-arrange so my desktop remains intact???
 

Re: Turn off desktop grid snap
« Reply #5 on: November 11, 2016, 03:22:14 PM »
 

JmaCWQ

  • Forum Regular
  • ***
  • 227
    Posts
  • Reputation: 44
    • View Profile
No probs Ken,
It doesn't turn off the grid as such, but allows adjustment of the spacing between icons on the grid.
To fine tune it a bit more you could possibly try changing the value of the line XfdesktopIconView::cell-text-width-proportion = 2.0 to 1.5 or perhaps even 1.0.
It controls how much space is used to display the text under each icon.
It works on multiples of the icon size in pixels, so if you have a 20 pixel icon & it's set at 2.0, Xfce will reserve 40 pixels for the text.
It centres each icon in it's display area so it'll reserve 10 pixels either side of the icon + the 20 pixels of the icon itself.
If you change that number to 1.0 it keeps the text at the same width as the icon allowing them to be put closer together if desired.
Logout & back in again anytime you edit that file.
« Last Edit: November 11, 2016, 03:31:52 PM by JmaCWQ »
 

Re: Turn off desktop grid snap
« Reply #4 on: November 11, 2016, 02:51:07 PM »
 

kjacobs

  • Occasional Poster
  • **
  • 71
    Posts
  • Reputation: 5
  • Linux Lite Member
    • View Profile

  • CPU: 2x Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz

  • MEMORY: 4Gb
Hi trinidad.....the library has quite a few icons on the desktop and they are grouped under headings built into the wallpaper.....ie Office Apps, Job Searching, Media, etc....the users have been using the computers this way for quite a while now, so they are used to it like this.

JmaCWQ.....that info was helpful thanks. I tried using your code in the .gtkrc-2.0 file and it did help, although I still could not get the icons placed any ol' place I wanted as they were still on a grid. However, I was able to adjust the wallpaper a bit and move the icons enough to fit well on the desktop.....so the results turned out fine, thanks again for the input.

Ken
 

Re: Turn off desktop grid snap
« Reply #3 on: November 11, 2016, 07:49:33 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1484
    Posts
  • Reputation: 215
  • Linux Lite Member
    • View Profile
    • dbts-analytics.com

  • CPU: i7 4 cores 8 threads

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD graphics

  • Kernel: 5.x
I don't know how many icons you need to place, but rather than the desktop, you can enlarge the panel and add icons for applications to it easily, and select always visible, and the icons will never be hidden by opened windows. The panel can be at the top, bottom, or either side of the desktop. When I set up for public users I generally turn off desktop icons to avoid inadvertent desktop clutter and added unnecessary apps caused by inexperienced users. (add trash, web browser, and LOwriter to favorites in the start menu.) To make applications other than default LL applications available you first have to add them to the start menu >Menu>Settings>Main Menu then right click the item from the menu and add to panel.

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

 

-->
X Close Ad

Linux Lite 7.0 RC1 Released - See Release Announcement Section