You are Here:
Linux Lite 4.8 Final is now available for download and installation



[ SOLVED ] updates error

Author (Read 1509 times)

0 Members and 1 Guest are viewing this topic.

updates error
« on: September 10, 2019, 05:45:54 PM »
 

mweelrea

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit
Hi, when I try to run the Install Updates program, I get this message:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

This has never happened before. Can anyone help?
Thanks.
Last Edit: October 29, 2019, 09:44:48 PM by firenice03
 


Re: updates error
« Reply #1 on: September 10, 2019, 10:26:53 PM »
 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Country: gb
  • Reputation: 84
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium T3200@2.0GHz (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
Hi, when I try to run the Install Updates program, I get this message:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
This has never happened before. Can anyone help?
Thanks.

Hi mweelrea, and a warm welcome to the LL community  :)
 
Turning to your problem - this means the updating process was interrupted.
Sometimes this happened to me. With the Linux Lite updating process, it continues in the background, evidence for the ongoing process disappearing from your display, only showing again when the process has completed (which can take several minutes). So, it's easy with LL to accidentally shutdown your computer while updating is in progress.

To complete the updating, open a terminal.
Type the following:
Code: [Select]
sudo dpkg --configure -a
It might ask for your password, then let it run to completion.

Hope this helps.
Mike
Last Edit: September 10, 2019, 10:47:22 PM by m654321
64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ Arm710@1.2GHz - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ i3-3110M@2.4GHz - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom N455@1.66GHz - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel T3200@2.0GHz - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel T7100@1.8GHz - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 

Re: updates error
« Reply #2 on: September 11, 2019, 03:15:25 PM »
 

mweelrea

  • New to Forums
  • *
  • 6
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit
Great, that has sorted it, thanks very much indeed.
 


Tags:
 


Linux Lite 4.8 Final is now available for download and installation