You are Here:
Install Updates Gimp Error - see Security & Bug Fixes Section Sticky



[ SOLVED ] University WIFI

Author (Read 2224 times)

0 Members and 4 Guests are viewing this topic.

University WIFI
« on: June 14, 2019, 05:34:52 AM »
 

ian9114

  • New to Forums
  • *
  • 5
    Posts
  • Country: ke
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: intel core 2 duo 2.0Ghz

  • MEMORY: 3Gb
I can access the internet on firefox using the university WIFI which uses manual proxy configuration by configuring the proxy settings within firefox but the operating system itself such as the terminal cannot use that connection how can I bypass that because I have tried looking solutions online but with no positive results
Last Edit: June 23, 2019, 05:30:33 AM by ian9114
 


Re: University WIFI
« Reply #1 on: June 14, 2019, 10:48:00 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7087
    Posts
  • Country: nz
  • Reputation: 664
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Open a Terminal:

Code: [Select]
echo -e "http_proxy=http://192.168.43.100:3128/\nhttps_proxy=https://192.168.43.100:3128/" | sudo tee -a /etc/environment
Code: [Select]
sudo netplan apply
Replace IP address and proxy port with your University ones, then reboot.
 

Re: University WIFI
« Reply #2 on: June 14, 2019, 12:40:48 PM »
 

TheDead

  • Gold Level Poster
  • *******
  • 608
    Posts
  • Country: ca
  • Reputation: 53
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 3.8 32bit

  • CPU: HAL9000

  • MEMORY: 1Gb

  • VIDEO CARD: Oculus Rift v.5
Thanks Jerry.
Just for personal knowledge, can this be done in the network card "GUI"?
(not on linux machine at the moment).
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 

Re: University WIFI
« Reply #3 on: June 14, 2019, 03:39:11 PM »
 

ian9114

  • New to Forums
  • *
  • 5
    Posts
  • Country: ke
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: intel core 2 duo 2.0Ghz

  • MEMORY: 3Gb
===========================
Install Updates Error log
===========================
Install Updates could not successfully download and install available updates.
Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.

============ Log ===========

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.


this is a new problem i have encountered after configuring the proxy
 

Re: University WIFI
« Reply #4 on: June 14, 2019, 03:47:21 PM »
 

ian9114

  • New to Forums
  • *
  • 5
    Posts
  • Country: ke
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: intel core 2 duo 2.0Ghz

  • MEMORY: 3Gb
My system is upto date but i have not installed any upgrades there seems to be an error
 

Re: University WIFI
« Reply #5 on: June 14, 2019, 09:56:07 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7087
    Posts
  • Country: nz
  • Reputation: 664
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Open a Terminal, run:

Code: [Select]
sudo dpkg --configure -a
to fix the error.
 

Re: University WIFI
« Reply #6 on: June 23, 2019, 05:24:07 AM »
 

ian9114

  • New to Forums
  • *
  • 5
    Posts
  • Country: ke
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: intel core 2 duo 2.0Ghz

  • MEMORY: 3Gb
what do i need to do if i have to use my regular internet without proxy
 

Re: University WIFI
« Reply #7 on: June 23, 2019, 05:30:15 AM »
 

ian9114

  • New to Forums
  • *
  • 5
    Posts
  • Country: ke
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: intel core 2 duo 2.0Ghz

  • MEMORY: 3Gb
i figured that out i just ran  echo -e "http_proxy=no proxy/" | sudo tee -a /etc/environment
http_proxy=no proxy/
 

Re: University WIFI
« Reply #8 on: June 23, 2019, 06:01:51 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7087
    Posts
  • Country: nz
  • Reputation: 664
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Thanks Jerry.
Just for personal knowledge, can this be done in the network card "GUI"?
(not on linux machine at the moment).

I can't see an option for it, so I'm guessing no.
 


Tags: proxy port connections 
 


Install Updates Gimp Error - see Security & Bug Fixes Section Sticky