You are Here:
Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section



TRYING TO INSTALL BRAVE°

Author (Read 6864 times)

0 Members and 1 Guest are viewing this topic.

Re: TRYING TO INSTALL BRAVE°
« Reply #5 on: March 15, 2023, 09:17:45 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1470
    Posts
  • Reputation: 214
  • Linux Lite Member
    • View Profile
    • dbts-analytics.com

  • CPU: i7 4 cores 8 threads

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD graphics

  • Kernel: 5.x
One of the browser updates (likely brave) is using a hook to the wrong version of python. "/usr/lib/cnf-update-db" is a python 3 script. I think jammy uses python 3.10 as default but that may have changed since its first release. Before messing with update-alternatives I would disable the brave ppa and maybe deadsnakes too and try running updates. Again the error is caused by a hook calling for a version of python that is not correctly enabled (linked).
Paste "/usr/lib/cnf-update-db" into google and read up on the problem.

TC 
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: TRYING TO INSTALL BRAVE°
« Reply #4 on: March 14, 2023, 03:35:24 PM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 809
    Posts
  • Reputation: 146
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
One (or more) of the system files that the update script needs may have been lost.

Do you have any system backups made with the 'System Restore Utility' (Timeshift) that were made before the problem started ?

If so, this should allow you to restore the system files to the previous working state.
clueless
 

Re: TRYING TO INSTALL BRAVE°
« Reply #3 on: March 14, 2023, 03:06:40 PM »
 

F R G

  • New to Forums
  • *
  • 2
    Posts
  • Reputation: 0
    • View Profile
May be a problem with python loading a module which is very odd.
Was the system working and updating ok and then something changed ?
Can you explain what happened ?
Was it installing Brave ?

well what Im looking its that I cant install anything into my device now this error appair when I try to install some files from a packages soo maybe I need to reset my device any advice?? also this is the new error

===========================
Install Updates Error log
===========================
Install Updates could not fetch the package cache information lists.
Go to https://www.linuxliteos.com/forums/ and paste the log below into the Software - Support - Updates section for assistance.

============ Log ===========

Obj:1 http://archive.canonical.com/ubuntu jammy InRelease
Obj:2 http://us.archive.ubuntu.com/ubuntu jammy InRelease
Obj:3 http://repo.linuxliteos.com/linuxlite fluorite InRelease
Obj:4 https://deb.nodesource.com/node_18.x jammy InRelease
Des:5 http://us.archive.ubuntu.com/ubuntu jammy-updates InRelease [119 kB]
Obj:6 http://packages.microsoft.com/repos/code stable InRelease
Obj:7 https://deb.opera.com/opera-stable stable InRelease
Obj:8 https://brave-browser-apt-release.s3.brave.com stable InRelease
Des:9 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
Des:10 http://us.archive.ubuntu.com/ubuntu jammy-backports InRelease [107 kB]
Obj:11 https://ppa.launchpadcontent.net/deadsnakes/ppa/ubuntu jammy InRelease
Traceback (most recent call last):
  File "/usr/lib/cnf-update-db", line 3, in <module>
    import apt_pkg
ModuleNotFoundError: No module named 'apt_pkg'
Descargados 336 kB en 2s (202 kB/s)
Leyendo lista de paquetes...
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code


 

Re: TRYING TO INSTALL BRAVE°
« Reply #2 on: March 14, 2023, 07:29:03 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 809
    Posts
  • Reputation: 146
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
May be a problem with python loading a module which is very odd.
Was the system working and updating ok and then something changed ?
Can you explain what happened ?
Was it installing Brave ?
clueless
 

TRYING TO INSTALL BRAVE°
« Reply #1 on: March 11, 2023, 01:59:26 PM »
 

F R G

  • New to Forums
  • *
  • 2
    Posts
  • Reputation: 0
    • View Profile
===========================
Install Updates Error log
===========================
Install Updates could not fetch the package cache information lists.
Go to https://www.linuxliteos.com/forums/ and paste the log below into the Software - Support - Updates section for assistance.

============ Log ===========

Obj:1 http://repo.linuxliteos.com/linuxlite fluorite InRelease
Obj:2 http://us.archive.ubuntu.com/ubuntu jammy InRelease
Obj:3 http://archive.canonical.com/ubuntu jammy InRelease
Obj:4 http://packages.microsoft.com/repos/code stable InRelease
Des:5 http://us.archive.ubuntu.com/ubuntu jammy-updates InRelease [119 kB]
Obj:6 https://brave-browser-apt-release.s3.brave.com stable InRelease
Obj:7 http://security.ubuntu.com/ubuntu jammy-security InRelease
Obj:8 https://deb.opera.com/opera-stable stable InRelease
Obj:9 https://deb.nodesource.com/node_18.x jammy InRelease
Obj:10 https://ppa.launchpadcontent.net/deadsnakes/ppa/ubuntu jammy InRelease
Des:11 http://us.archive.ubuntu.com/ubuntu jammy-backports InRelease [107 kB]
Traceback (most recent call last):
  File "/usr/lib/cnf-update-db", line 3, in <module>
    import apt_pkg
ModuleNotFoundError: No module named 'apt_pkg'
Descargados 226 kB en 15s (15.2 kB/s)
Leyendo lista de paquetes...
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code

any adivice to solve this issue?! thanks...
 

 

-->
X Close Ad

Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section