Software - Support > Other

Screensaver interrupts fullscreen Firefox videos

(1/2) > >>

mulcahey:
*SIGH* False alarm  :( This is NOT fixed.

Latest update:

* After starting the computer, it will behave as desired: Staying awake while a video is fullscreen in Firefox. Great!
* Then, when I'm done with the video, I exit and walk away. My computer goes to sleep when it reaches the set timeout. Great!
* But then, the next time I wake my computer and try to watch a fullscreen video, then the issue comes back: The computer goes to sleep even when the video is fullscreen.
Here's what I'm trying now:

* Disable all Firefox add-ons.
* completely uninstall Firefox and all its supporting files. Reinstall.
* Reinstall pm-utils
* Reinstall gnome-power-manager
* Restart
Testing this now. Fingers crossed :(

Note: Still odd to me that this ONLY happens with Firefox, and not VLC. Why can my computer detect that VLC is fullscreen, but not the videos that play via Firefox?

mulcahey:
Ok, at long last, I think I've solved this.

The issue seems to be that Caffeine messed up something in my windows manager, and it remained messed up even after I uninstalled. I identified that I was running Lightdm, so I ran


--- Code: ---sudo apt-get reinstall lightdm
--- End code ---

And finally, FINALLY... full screen videos seem to run without being interrupted.

mulcahey:
Ok, I think I've made some progress and figured out that it's somehow related to Caffeine. But now I've uninstalled Caffeine and it's still not working.

Previously, I had installed Caffeine to keep the screen awake while viewing non-fullscreen webpages, but it never worked. My computer would got to sleep no matter what, even if I was playing a fullscreen video, with or without Caffeine.

Yesterday I uninstalled Firefox, and I was prompted to uninstall a bunch of other packages at the same time. I removed them all. (I should have kept a log. Oops.)

I re-installed Firefox, and fullscreen videos worked great! Fullscreen videos would KEEP my screen on, as intended! I didn't even enable Caffeine!

Then, I turned on Caffeine so I could keep a non-fullscreen webpage open. It didn't work. The computer went to sleep.

Then, the next time I tried to watch a fullscreen video, the computer ALSO went to sleep. So I think that enabling Caffeine screwed something up.

So, I uninstalled Caffeine, uninstalled Firefox, re-installed Firefox, but now things are back to NOT working.

Not sure what else I can do. Any thoughts? Thank you

stevef:
Perhaps check here
https://support.mozilla.org/en-US/kb/install-older-version-firefox
or maybe
https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr

As Firefox is part of the LL 5.x package it may be more complex to stop it updating.

mulcahey:
No backup, but I made a discovery: In its last update, Firefox "fixed" a bug that displayed the status bar in fullscreen mode. https://bugzilla.mozilla.org/show_bug.cgi?id=1853896

Fairly certain that this is the cause of the issue. I'll report it to Mozilla. Is there a way to downgrade my Firefox in the meantime, if I don't have a backup?  Thank you.

Navigation

[0] Message Index

[#] Next page

Go to full version