Software - Support > Other

Re-installing Xarchiver; Fixing broken filter in Synaptic Package Manager

<< < (2/2)

dayooper:
Rob,

I ended up re-installing Linux Lite and all is well for now.

I just downloaded the latest version of LibreOffice. The extracted file is "LibreOffice_4.2.3.3_Linux_x86_deb". How do I install this program?   

N4RPS:
Hello!

Sounds like you're tried to extract the latest xarchiver from a tarball. That's ALMOST never necessary. More often than not, it's bad karma to second-guess the repositories.

All this shouldn't be a major disaster; Xarchiver is just a GUI front end for tar.

Try this. Open a terminal window [CTRL-ALT-T] and type the following:


--- Code: ---sudo apt-get purge xarchiver
sudo apt-get install xarchiver
--- End code ---

If it bombs on a dependency, try this:


--- Code: ---sudo apt-get install -f
--- End code ---

THAT *SHOULD* fix the broken dependency or dependencies.

If not, sounds like things are REALLY bad. Maybe you deleted tar, in which case you can just type this in a terminal window:


--- Code: ---sudo apt-get install tar
--- End code ---

If all else fails, you can use Archive Manager/File Roller to extract tarballs, right click on it in Thunar, or use tar in a terminal. To extract the tarball 'fubar', type 'tar -xvzf fubar.tar.gz' in a termimal window.

Worst case scenario: Reinstall Linux Lite, and you may borrow my favorite phrase:

"Knows JUST ENOUGH Linux to be DANGEROUS."

As for myself, I'm (in)famous for goofing things up so badly sometimes, I have to 'nuke it and start over'. Mistakes are how we learn things...

73 DE N4RPS
Rob




dayooper:
I completely removed Xarchiver in Synaptic Package Manager so that I could install latest version of Xarchiver. Big mistake! After downloading the latest version of Xarchiver, I could not extract the files. Tried to re-install older version of Xarchiver in Lite Software Manager and received error message. Then tried to re-install Xarchiver in Synaptic Package Manager and also received error message that all files could not be retrieved.

Closed down and re-opened Synaptic Package Manager. Dialogue box stated that there was a broken filter in this program. Followed instructions to fix broken packages but it didn't work. Help!

Navigation

[0] Message Index

[*] Previous page

Go to full version