You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
[ SOLVED ] Problems with apt-get/apt when installing or removing packages.

Author (Read 2916 times)

0 Members and 1 Guest are viewing this topic.

Problems with apt-get/apt when installing or removing packages.
« on: December 19, 2020, 11:40:18 AM »
 

alexander06_1

  • New to Forums
  • *
  • 4
    Posts
  • Country: ni
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit
Hi there guys!  :)

I'm a newbie in Linux world and since a days ago I've had the following troubles when I want to install or remove packages:



I don't know what
Code: [Select]
xfce4-goodies : Depends: xfce4-whiskermenu-plugin but it is not going to be installed is or means. And I neither know what is the
Code: [Select]
apt-get -f install command use for.

When I run
Code: [Select]
apt-get -f install I have the following response:



By the way, I'm running Linux Lite 3.8 for 32bits. Thanks!! ;)
Last Edit: December 21, 2020, 01:14:51 PM by alexander06_1
 


Re: Problems with apt-get/apt when installing or removing packages.
« Reply #1 on: December 19, 2020, 04:32:25 PM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1309
    Posts
  • Country: us
  • Reputation: 201
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 5.6 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
Your terminal prompt looks like you're in the wrong file path. What command did you use to get to root and why are you running root at all?

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Problems with apt-get/apt when installing or removing packages.
« Reply #2 on: December 19, 2020, 06:15:28 PM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1034
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
Hi there guys!  :)

I'm a newbie in Linux world and since a days ago I've had the following troubles when I want to install or remove packages:

I don't know what
Code: [Select]
xfce4-goodies : Depends: xfce4-whiskermenu-plugin but it is not going to be installed is or means. And I neither know what is the
Code: [Select]
apt-get -f install command use for.

When I run
Code: [Select]
apt-get -f install I have the following response:

By the way, I'm running Linux Lite 3.8 for 32bits. Thanks!! ;)

Are you trying to modify/remaster Linux Lite .iso file? Looks like it. Mind you, everything is hard-coded and making a custom one might prove to be real difficult to achieve.
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 

Re: Problems with apt-get/apt when installing or removing packages.
« Reply #3 on: December 19, 2020, 11:30:44 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8132
    Posts
  • Country: nz
  • Reputation: 759
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
In 3.8 xfce4-whiskermenu-plugin is a dependency of xfce4-goodies. To remedy the problem, only install the xfce4-goodies features you will actually need.

Fix:

1. DON'T DO ANYTHING AS ROOT
2. REFER TO RULE 1

now:

1. Open a Terminal, do:

Code: [Select]
sudo apt-get remove xfce4-goodies
or:

Code: [Select]
sudo apt-get remove xfce4-goodies xfce4-whiskermenu-plugin
go here - https://packages.ubuntu.com/xenial/xfce4-goodies

install the actual software you need, eg:

Code: [Select]
sudo apt-get install xfce4-weather-plugin
3.8 will no longer get updates and be secure, consider moving to Series 4.x or 5.x soon.
 

Re: Problems with apt-get/apt when installing or removing packages.
« Reply #4 on: December 21, 2020, 01:02:01 PM »
 

alexander06_1

  • New to Forums
  • *
  • 4
    Posts
  • Country: ni
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit
Your terminal prompt looks like you're in the wrong file path. What command did you use to get to root and why are you running root at all?

TC

What do you mean with wrong path? I used sudo -i for root. I'm not an expert! Is there any problem when I'm running everything in root?
 

Re: Problems with apt-get/apt when installing or removing packages.
« Reply #5 on: December 21, 2020, 01:06:48 PM »
 

alexander06_1

  • New to Forums
  • *
  • 4
    Posts
  • Country: ni
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit
Hi there guys!  :)

I'm a newbie in Linux world and since a days ago I've had the following troubles when I want to install or remove packages:

I don't know what
Code: [Select]
xfce4-goodies : Depends: xfce4-whiskermenu-plugin but it is not going to be installed is or means. And I neither know what is the
Code: [Select]
apt-get -f install command use for.

When I run
Code: [Select]
apt-get -f install I have the following response:

By the way, I'm running Linux Lite 3.8 for 32bits. Thanks!! ;)

Are you trying to modify/remaster Linux Lite .iso file? Looks like it. Mind you, everything is hard-coded and making a custom one might prove to be real difficult to achieve.

No bro! I wasn't doing that. By the way, what do you mean with modify/remaster Linux Lite .iso file?
 

Re: Problems with apt-get/apt when installing or removing packages.
« Reply #6 on: December 21, 2020, 01:13:16 PM »
 

alexander06_1

  • New to Forums
  • *
  • 4
    Posts
  • Country: ni
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit
In 3.8 xfce4-whiskermenu-plugin is a dependency of xfce4-goodies. To remedy the problem, only install the xfce4-goodies features you will actually need.

Fix:

1. DON'T DO ANYTHING AS ROOT
2. REFER TO RULE 1

now:

1. Open a Terminal, do:

Code: [Select]
sudo apt-get remove xfce4-goodies
or:

Code: [Select]
sudo apt-get remove xfce4-goodies xfce4-whiskermenu-plugin
go here - https://packages.ubuntu.com/xenial/xfce4-goodies

install the actual software you need, eg:

Code: [Select]
sudo apt-get install xfce4-weather-plugin
3.8 will no longer get updates and be secure, consider moving to Series 4.x or 5.x soon.

That actually worked bro, thank you!! ;)

 

Re: Problems with apt-get/apt when installing or removing packages.
« Reply #7 on: December 21, 2020, 05:49:24 PM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1034
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
Quote
No bro! I wasn't doing that. By the way, what do you mean with modify/remaster Linux Lite .iso file?

I thought you were trying to do that since you removed/installed whisker-menu which is already installed by default, that and the fact you were using root to do such basic things. Remaster means modify the original .iso file; remove/install pkgs, make your own customizations, so it's a bit different.

Quote
What do you mean with wrong path? I used sudo -i for root. I'm not an expert! Is there any problem when I'm running everything in root?

Usually once should not use/become root unless strictly necessary, i.e. modify certain system files the regular user can't. It's a bit risky since you could damage your system beyond repair; root can do anything and that includes break things.
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 


 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements