Software - Support > Other

micro SD cards not recognized

(1/13) > >>

adml:
I have Linux Lite 5.2 installed on a Lenovo Ideapad 100s 14 inch notebook. After installation micro SD cards are not recognized, but they were recognized previously under Windows. I've tried 3 different cards, all of which are recognized on other PCs, so I'm sure that it's not the cards.

lspci shows the following:

00:12.0 SD Host controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SD Controller (rev 21)

Any ideas on how I can get Linux Lite to recognize micro SD cards ?

Thanks in advance for any help.

WytWun:
You're going to have to do some digging unfortunately to better understand exactly what is missing in the system config.

To try and gather more info about the card reader I'd go to the Lenovo website and try and identify the actual Windows card reader driver download package for your system - it is possible that it might actually be a Realtek device rather than the intel (the 100-14IBY appears to use a realtek card reader even though I think the intel chipset in that model includes SD card support...).

To learn more about your system start by opening a terminal window and running the command

--- Code: ---inxi -F
--- End code ---
before inserting a card into the reader and then again after inserting a card into the reader and comparing the output to see whether anything is different.

Some googling turned up this AskUbuntu article.  It is now quite old and likely not directly relevant, but many of the investigative suggestions on that page and the bug report linked in the second answer may be informative.  A look at a the kernel config on a Lite 5.2 system suggests that the necessary modules should have been built but they may not have been loaded on your system (perhaps the pinctrl module relevant to your system?).

adml:
Thank you for the reply. My model is a 100s-14IBR and the Lenovo support site shows that the card reader driver is indeed for a Realtek.

Running inxi -F both before and after inserting a micro SD card shows no differences, other than a 1% difference in memory usage and a 1 degree difference in CPU temp. The drive information is exactly the same, it appears that only the internal drive is being shown.

I read the post that you linked to, is pinctrl something that I can use to try and get the card reader recognized ?

WytWun:
I hadn't previously tried to use the microSD card slot in my Lenovo 100s-11IBY (currently running Lite 5.2) which I think is somewhat older than your machine.  I found a suitable card and much to my surprise the card was recognised and I could navigate the contents with the file manager.  As best I can tell, my machine is using the sdhci_acpi driver rather than the sdhci_pci driver mentioned in the AskUbuntu article.

Your machine seems to have an intel Braswell CPU which should be covered by the pinctrl_cherryview driver according to the source code; that driver is built into the kernel according to the config info I can find so there's nothing you can do with that :(.

What sized cards are you trying?  Are they cards you used when running Windows?  The card I tried was 16GB and I seem to recall 32GB being a relatively common limit for SD card readers until fairly recently...

adml:
The micro SD cards that I've tried are 32 GB, and are the exact ones that I used when Windows was installed. You're correct, anything above 32 GB was a no go on this PC under Windows. I'd really like to get the SD reader working as Linux Lite has given this PC new life and it's a night and day difference from Windows. I appreciate the help, please let me know if you have any other ideas.

Navigation

[0] Message Index

[#] Next page

Go to full version