You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
Keyboard not set to the correct layout

Author (Read 2104 times)

0 Members and 2 Guests are viewing this topic.

Keyboard not set to the correct layout
« on: February 25, 2021, 04:55:57 AM »
 

AcsPrime

  • New to Forums
  • *
  • 8
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.2 64bit
Hello,

I have the layout set to Portuguese (standard) and the keyboard is not mapped correctly.
I have to go into the Keyboard settings, change to a different layout and then change back to Portuguese to get the correct layout.

I have to do this every time I boot to get the correct layout. Can someone please tell me what I need to do to get this to stick?
 


Re: Keyboard not set to the correct layout
« Reply #1 on: March 18, 2021, 05:06:24 AM »
 

Şerban S.

  • Şerban
  • PayPal Supporter
  • Forum Regular
  • *****
  • 162
    Posts
  • Country: ro
  • Reputation: 9
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: Intel® Core™ i7-4790

  • MEMORY: 16Gb

  • VIDEO CARD: Intel® HD Graphics 4600 + NVidia GK107 (GeForce GT630 OEM)

  • Kernel: 5.x
[...] I have the layout set to Portuguese (standard) and the keyboard is not mapped correctly.
I have to go into the Keyboard settings, change to a different layout and then change back to Portuguese to get the correct layout. [...]

Hello! :)
Solving the problem, has TWO steps.
1. What type of keyboard do you have? Is it PORTUGUESE? If so, you made the wrong keyboard choice during installation.
2. In the keyboard setup GUI, you need to specify THE DEFAULT LAYOUT and set it for all applications.
That means this sequence:
Settings Manager --> Keyboard  --> Layout
On this interface, you have a list of options. First, is the HARDWARE layout. This will determine the behaviour of your keyboard so, if the keyboard has a portuguese layout, you have to choose accordingly. If it is an US Layout, leave it as it is, but you have to be aware that you have to know the portuguese layout BY HARD, in order to be able to get what you want, since what is written on the keys is different from what the key prints in the opened file (or console).
If you want the portuguese layout to be the default, you need to go to the "Keyboard Layout" option and MOVE the Portuguese Layout on the first place.
Than, using the [Alt+Shift] accelerator, you can switch back and forth through all installed layouts. The keyboard layout in the taskbar, will change accordingly, showing the country flag.
Good luck! :)
If this solves the problem, please, mark the thread [SOLVED].

Best regards! :)
"It's easy to die for an idea. It's way harder TO LIVE for your idea!"
Current Machine:
 Dell Precision T1700, 16 GB RAM, 240 GB SSD.
Laptop:
 Lenovo ThinkPad T400 + SSD Kingston A 400, 480 GB.
 

Re: Keyboard not set to the correct layout
« Reply #2 on: April 02, 2021, 05:11:47 AM »
 

AcsPrime

  • New to Forums
  • *
  • 8
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.2 64bit
Hey,

You can see my keyboard settings here: https://ibb.co/Ny57MzP
This is set as default, but when I boot up the machine I have to go in, choose another layout, and then choose Portuguese layout again to get it to correctly load.
Before I do this I can see that, even though the layout is set to Portuguese, the keys produced by the keyboard are not of Portuguese layout.

I've done this in other distros and during installation I set the Portuguese layout and had no issues.
 

Re: Keyboard not set to the correct layout
« Reply #3 on: May 10, 2021, 12:00:30 PM »
 

timbuck2

  • Patreon Supporter
  • Occasional Poster
  • *****
  • 66
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: AMD64

  • MEMORY: 8Gb

  • VIDEO CARD: NVIDIA GTX1070

  • Kernel: 5.x
How do I get the alternate keyboard setting to load at start?

I set the new keyboard layout to the top entry in the keyboard settings like this:



Then I added the keyboard plugin to the taskbar and chose the layout I wanted (intl with deadkeys).

But when I log out and log back in, the dead keys are turned off.  I have to click on the taskbar indicator to switch until it works.

What am I doint wrong?
 

Re: Keyboard not set to the correct layout
« Reply #4 on: May 10, 2021, 04:16:31 PM »
 

timbuck2

  • Patreon Supporter
  • Occasional Poster
  • *****
  • 66
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.4 64bit

  • CPU: AMD64

  • MEMORY: 8Gb

  • VIDEO CARD: NVIDIA GTX1070

  • Kernel: 5.x
Ok, fixed it by deleting the second entry in the keyboard layout box.  So now there is only one layout on the system, but it is the one I want.
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements