You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
[ SOLVED ] gui menu apps not launching

Author (Read 1613 times)

0 Members and 1 Guest are viewing this topic.

gui menu apps not launching
« on: May 29, 2021, 10:10:12 PM »
 

noweare

  • New to Forums
  • *
  • 22
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: Intel Celeron CPU @ 2.4GHz 1 processor, 2 cores

  • MEMORY: 4Gb

  • VIDEO CARD: 1440 x 900

  • Kernel: 4.x
Hello,

Running LL 4.8 but in system is says Debian GNU/Linux buster/sid
which may raise a red flag to someone in the know.

I am finding that some of my gui menu apps are not launching
for example, firewall, gufw, printers.

Don't know what I did but I did upgrade from LL 4.4 to LL 4.8
a little while ago but I don't know if I have used these items after
the upgrade till i just found some are not launching.

But the common thread between the errors i am getting is that some of
the python modules that the intrepreter is looking for are missing like
gi and dbus

I am using Python3.6 is the python version being used for the python scripts.

If any of this sounds familiar I am all ears, otherwise I will spend a couple of days on it
and see if I can figure it out.

Thank in advance
Joe

I know this is not much info but if it sounds familiar I'd be all ears.

Thanks
Last Edit: May 30, 2021, 09:52:39 AM by noweare
 


Re: gui menu apps not launching
« Reply #1 on: May 30, 2021, 09:28:27 AM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1056
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
Can you post the output of
Code: [Select]
inxi -Syxx run that in a terminal, then copy/paste the output in your reply.
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 

Re: gui menu apps not launching
« Reply #2 on: May 30, 2021, 09:51:07 AM »
 

noweare

  • New to Forums
  • *
  • 22
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: Intel Celeron CPU @ 2.4GHz 1 processor, 2 cores

  • MEMORY: 4Gb

  • VIDEO CARD: 1440 x 900

  • Kernel: 4.x
I found my problem, some of the bash scripts had python3 in them which for some reason I must of got rid of so it couldn't find python3.
I made a soft link to point python3 at python3.6 so now they are working. 

I ran you inxi -Syxx command but it returned Error 21: Width option requires an integer value of 80 or more.
You entered: xx

I looked at the command syntax and it seems like a very powerful command. At first glance I could not figure out what the
yxx respresented but I would like to get familiar with it. Seems like a good way to get system information from the command line.

Anyways thanks for responding. 
~Joe
 

Re: gui menu apps not launching
« Reply #3 on: May 30, 2021, 11:41:10 AM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1056
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
I found my problem, some of the bash scripts had python3 in them which for some reason I must of got rid of so it couldn't find python3.
I made a soft link to point python3 at python3.6 so now they are working. 

I ran you inxi -Syxx command but it returned Error 21: Width option requires an integer value of 80 or more.
You entered: xx

I looked at the command syntax and it seems like a very powerful command. At first glance I could not figure out what the
yxx respresented but I would like to get familiar with it. Seems like a good way to get system information from the command line.

Anyways thanks for responding. 
~Joe
You're welcome :) Glad you solved it. You shouldn't be getting that error, anyway, what those options do:
Sy = System info; Host, DE, Kernel in use, WM, distro, display manager, OS type(32 or 64), compiler (gcc), toolkit(GTK+, QT).
xx = adds more verbosity to the output.

By the way, I missed the r option, I wanted to see the output of this
Code: [Select]
inxi -Syrxx the r option is for repo, it gives info about those present in your system. I thought there could be something, but you figured it out for yourself and seems it has nothing to do with that :) 

Last Edit: May 30, 2021, 11:42:41 AM by Moltke
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 

Re: gui menu apps not launching
« Reply #4 on: May 30, 2021, 01:59:56 PM »
 

noweare

  • New to Forums
  • *
  • 22
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • CPU: Intel Celeron CPU @ 2.4GHz 1 processor, 2 cores

  • MEMORY: 4Gb

  • VIDEO CARD: 1440 x 900

  • Kernel: 4.x
I ran:
inxi -Srxxy80

that gave me:
System:    Host: linuxdesktop Kernel: 4.15.0-143-generic x86_64
           bits: 64 gcc: 7.5.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) dm: lightdm
           Distro: Ubuntu 18.04.5 LTS
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted universe multiverse
           deb http://us.archive.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main restricted universe multiverse
           deb http://us.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu bionic partner
           Active apt sources in file: /etc/apt/sources.list.d/linuxlite.list
           deb http://repo.linuxliteos.com/linuxlite/ diamond main
           Active apt sources in file: /etc/apt/sources.list.d/mosquitto-dev-ubuntu-mosquitto-ppa-bionic.list
           deb http://ppa.launchpad.net/mosquitto-dev/mosquitto-ppa/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/nodesource.list
           deb [signed-by=/usr/share/keyrings/nodesource.gpg] https://deb.nodesource.com/node_12.x bionic main
           deb-src [signed-by=/usr/share/keyrings/nodesource.gpg] https://deb.nodesource.com/node_12.x bionic main
           Active apt sources in file: /etc/apt/sources.list.d/otto-kesselgulasch-ubuntu-gimp-xenial.list
           deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/teejee2008-ubuntu-ppa-bionic.list
           deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/vscode.list
           deb [arch=amd64,arm64,armhf] http://packages.microsoft.com/repos/code stable main

So yea, works good, more stuff to learn ....    ;)   Thanks for this
 

Re: gui menu apps not launching
« Reply #5 on: May 30, 2021, 02:53:47 PM »
 

Moltke

  • Platinum Level Poster
  • **********
  • 1056
    Posts
  • Country: ve
  • Reputation: 120
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
I ran:
inxi -Srxxy80

that gave me:
System:    Host: linuxdesktop Kernel: 4.15.0-143-generic x86_64
           bits: 64 gcc: 7.5.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) dm: lightdm
           Distro: Ubuntu 18.04.5 LTS
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted universe multiverse
           deb http://us.archive.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main restricted universe multiverse
           deb http://us.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu bionic partner
           Active apt sources in file: /etc/apt/sources.list.d/linuxlite.list
           deb http://repo.linuxliteos.com/linuxlite/ diamond main
           Active apt sources in file: /etc/apt/sources.list.d/mosquitto-dev-ubuntu-mosquitto-ppa-bionic.list
           deb http://ppa.launchpad.net/mosquitto-dev/mosquitto-ppa/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/nodesource.list
           deb [signed-by=/usr/share/keyrings/nodesource.gpg] https://deb.nodesource.com/node_12.x bionic main
           deb-src [signed-by=/usr/share/keyrings/nodesource.gpg] https://deb.nodesource.com/node_12.x bionic main
           Active apt sources in file: /etc/apt/sources.list.d/otto-kesselgulasch-ubuntu-gimp-xenial.list
           deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/teejee2008-ubuntu-ppa-bionic.list
           deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/vscode.list
           deb [arch=amd64,arm64,armhf] http://packages.microsoft.com/repos/code stable main

So yea, works good, more stuff to learn ....    ;)   Thanks for this

Cool!   :54: You're welcome  :55: You can add more options to that:
Code: [Select]
inxi -SyCrMmDG
where:
C = how full CPU output, including per CPU clock speed and CPU max speed (if available).
M = Show machine data. Device, Motherboard, BIOS, and if present, System Builder (Like Lenovo).
m = Memory (RAM) data.
D = Show  Hard  Disk  info.  Shows  total disk space and used percentage.
G = Show Graphic device(s) information, including details of device and display drivers.
add xx at the end for more verbosity, you can have it like xxxx, yes, that's x four times! Just be careful when sharing in forums and the like. Read man inxi for more info.
By the way, I know why you got that error. I use my terminal with a custom size and its wide open, you're probably using the default size, and the y option changes that, from
Code: [Select]
man inxi
Quote
-y, --width [integer]
              This is an absolute width override which sets the output line width max.  Overrides COLS_MAX_IRC / COLS_MAX_CONSOLE globals, or the actual widths of the terminal. 80 is the
              minimum width supported.  -1 removes width limits. 1 switches to a single indented key/value pair per line, and removes all long line wrapping (similar  to  dmidecode  out‐
              put).

              If no integer value is given, sets width to default of 80.

              Examples: inxi -Fxx -y 130 or inxi -Fxxy or inxi -bay1
 
I forgot about that, sorry, my bad, so try again but remove the y or change the terminal size increasing its width, and by doing that you should get no errors.  :55:
Last Edit: May 30, 2021, 02:59:44 PM by Moltke
Without each others help there ain't no hope for us :)
Need a translation service? https://www.deepl.com/es/translator
 


Tags: python modules 
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements