You are Here:
Linux Lite 4.4 RC1 has been released. See the Release Announcements section for more information.



failed update : need command to run

Author (Read 1595 times)

0 Members and 1 Guest are viewing this topic.

failed update : need command to run
« on: May 04, 2017, 10:32:21 AM »
 

kahnkeller

  • New to Forums
  • *
  • 1
    Posts
  • Reputation: 0
  • Linux Lite Member

  • CPU: unknown

  • MEMORY: 256mb

  • VIDEO CARD: unknown
Hello....yesterday my update on linux lite 3.4 stopped and I shut my pc down....when I tried to update I got the following message:

E: dpkg was interrupted, you must manually run 'dkpg --configure - a' to correct the problem

I have tried all sorts of commands...but the system keeps telling me I am not doing what is needed..... could one of you computer gurus tell me the words to type.... thanks....Keller
 


Re: failed update : need command to run
« Reply #1 on: May 04, 2017, 12:18:06 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1393
    Posts
  • Country: us
  • Reputation: 225
  • * Forum Moderator *

  • Linux Lite: 4.2 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics
@kahnkeller,

You didn't mention the obvious...whether you actually tried running dpkg --configure -a, and if so, what was the output?

If you have run the command, consider using Lite Tweaks and running the Package System Repair fix.
Want to thank me?  Click my [Thank] link.
 

Re: failed update : need command to run
« Reply #2 on: May 23, 2017, 04:55:24 PM »
 

altaica

  • New to Forums
  • *
  • 1
    Posts
  • Country: gr
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 32bit

  • CPU: Intel Atom N570

  • MEMORY: 2Gb
Same problem here. And it's not first time i've seen this error.
I tried the command and System Repair Fix, but nothing.
It's really disappointing cause it happens after installing System updates.
 

Re: failed update : need command to run
« Reply #3 on: May 23, 2017, 06:17:20 PM »
 

supergamer

  • Forum Regular
  • ***
  • 112
    Posts
  • Country: us
  • Reputation: 24
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: AMD Phenom 565

  • MEMORY: 12Gb

  • VIDEO CARD: 550 ti
Please try these commands right after each other.

Code: [Select]
sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade


This should reload the package cache and install updates, afterwards you should be able to check for updates using the normal update icon. These are the commands I ran to fix and you can probably leave off the last one and use the update icon and have no issues.
Last Edit: May 23, 2017, 06:26:50 PM by supergamer
 

Re: failed update : need command to run
« Reply #4 on: May 24, 2017, 11:06:10 AM »
 

newtusmaximus

  • Gold Level Poster
  • *******
  • 618
    Posts
  • Country: gb
  • Reputation: 60
  • Paypal Supporter.

  • Linux Lite: 3.6 64bit

  • CPU: Intel Core duo 6300 1.86GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 82Q963/Q965
supergamer   
That worked for me.  Thanks.   Before that I was getting the install updates reminder , but only to be informed that I was up to date on initiating updates.
2006 - HP DC7700p ultraslim Desktop Intel 6300 cpu  4GB Ram LL3.6 64bit.
2007 - Fujitsu Siemens V3405 Laptop  2 GB Ram LL3.6 32bit. Now Trialling Alpha 32bit Debian.
2006 - Fujitsu Siemens Si1520 Laptop Intel T720 cpu 3GB Ram LL4.2 64bit
2003 - RETIRED Toshiba Satellite Pro A10 1 GB RAM LL2.8 32bit
 


Tags:
 


Linux Lite 4.4 RC1 has been released. See the Release Announcements section for more information.