You are Here:
Linux Lite 6.4 RC1 Released - See the Release Announcements Forum section



bind-home.conf not binding to /home on LL2.4/win8.1 UEFI dual boot set-up

Author (Read 7882 times)

0 Members and 1 Guest are viewing this topic.

 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Reputation: 86
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium [email protected] (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
Just to confirm again that everything is working well with the win8.1/LL dual-boot setup with UEFI enabled.
The directories in /mnt/DATA on sdb are accessible by both OSes, without any glitches,  & also accessible by win7 set up in a virtual machine (Oracle Virtualbox) within LL.
A good job done - many thanks again goldfinger  for your help - without it, I wouldn't have been able to achieve this... ;)

I am now ticking this thread as 'topic solved' 

Regards
Mike

PS. I'll put together a tutorial on the UEFI enabled dual-boot set up a bit later, when I have a bit more free time.
« Last Edit: May 04, 2015, 02:39:36 AM by m654321 »
64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ [email protected] - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ [email protected] - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom [email protected] - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel [email protected] - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel [email protected] - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 

 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
Glad symlinks worked.  Obviously there must be something about a UEFI install that causes the bind method to fail.  Not sure why that is, but something to keep in mind myself whenever I finally take the plunge and get a new computer with UEFI.  (Current computers suit my needs just fine, so could be another year or two before I do that though.)
Try Linux Beginner Search Engine for answers to Linux questions.
 

 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Reputation: 86
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium [email protected] (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
Many thanks goldfinger.
Success at last, but before I got there, here's a brief recount...

As my win8.1/LL2.4 dual-boot setup, with sdb's /mnt/DATA on an nfts partition, failed to boot after placing this setup back into the laptop (on two drives - sda & sdb), I then tried to boot into the live environment of Ubuntu 14.10 (DVD) in UEFI mode, to do the necessary boot repair that you suggested so I'd get my grub screen back. 

No luck: after initially downloading files from the Ubuntu live DVD, the process got stuck at the Ubuntu screen, and didn't boot, hanging indefinitely at the orange screen with Ubuntu + logo.  So, I deleted the LL partitions (again) on sda, and reinstalled LL to get the fully functional UEFI dual boot up & running again, with LL home directory installed as root.

When done, I then booted to Win8.1, gave sdb a drive label (i.e. D:), so that it was accessible in Windows, and did what you suggested and put a notepad file within one of the folders on D:, then tested for binding but LL failed to detect any notepad file in 'Testing': so again no binding.  I then did the symlink test you suggested, and it worked. 

Following the success with the symlink test,  I then deleted the contents of my bind-home.conf file, deleted all folders in Home (except Desktop), and symlinked all 12 folders in /mnt/DATA to Home.  It worked.  I'm now setting up win 7 in a virtual machine (VMs stored on sdb) and am curious to see if it all runs smoothly with the symlinking - so far so good...  Also interested to see if the VM will access the data folders on sdb.  I'll report back when this is done, before giving this thread a 'topic solved'.

Regards
Mike
« Last Edit: May 03, 2015, 06:56:22 AM by m654321 »
64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ [email protected] - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ [email protected] - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom [email protected] - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel [email protected] - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel [email protected] - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 

 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
That is strange -- I don't know why booting gets messed up when you switch out the drives.

Re-installing grub is different with UEFI.  Unfortunately, I can't remember the steps for that; but you can use your live Ubuntu DVD/USB again and run Boot-Repair from that.  Just make sure you boot the Ubuntu disk in UEFI mode, then follow instructions for installing Boot-Repair to live environment and running the "Recommended Repair" on this page:  https://help.ubuntu.com/community/Boot-Repair#A2nd_option_:_install_Boot-Repair_in_Ubuntu.  That should do the same thing as you manually entering the commands (that I can't remember).

Boot-Repair will spit out a pastebin page with its results after you run it.  Save that page's address just in case it doesn't fix things.  It may have clues as to what's wrong.  Run Boot-Repair a second time if first time didn't work.

P.s.  If you get booting sorted back out, after you test bind access to NTFS partition, test out symlinking to the partition too.  Just navigate to /mnt/DATA and make a new folder called "Testing" on it.  Then just make a random test text file in it.  When done, create a symlink to your home with this command (substitute real username):
Code: [Select]
ln -s /mnt/DATA/Testing /home/username
Open home folder in Thunar file manager and see if you have access to that folder and can open the test file.
« Last Edit: May 02, 2015, 06:24:16 PM by gold_finger »
Try Linux Beginner Search Engine for answers to Linux questions.
 

 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Reputation: 86
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium [email protected] (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
Thanks goldfinger.  I have to say something very strange has just happened, following everything going so smoothly.
I removed the sda/sdb drives for the setup where LL was only bound to sdb's /mnt/DATA (ext4 formatted). It was working very well in UEFI as I mentioned in previous post.  I replaced this with the sda/sdb drives for the setup where sdb's /mnt/DATA was ntfs formatted. They were then changed around a second time and now neither setup boots to the grub screen. How is it possible that when I remove the drives and put them back, after using drives for another setup, that  the grub screen doesn't show on booting? Most peculiar ...

In order to supply you with the information you asked for in the last post I need to obviously reinstall grub and then hopefully boot into LL. I know how to do this with MBR (you showed me previously) , but is this different for GPT with the EFI setup?  The instructions for MBR that you gave me previously were as follows, where X is the partition number for LL's root partition:

sudo mount /dev sdaX /mnt 
sudo grub-install --boot-directory=/mnt/boot /dev/sda
sudo umount /dev/sdaX

then sudo-update-grub on reboot.

Shall I run this on my setup?

Regards
Mike
64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ [email protected] - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ [email protected] - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom [email protected] - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel [email protected] - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel [email protected] - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 

 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
m654321,

Good job running your experiments. That's best way to learn and it sounds like you're now the resident expert on getting LL installed in UEFI mode.  Think it probably would be a good idea to write a tutorial spelling out the steps from that video to make it a little easier for people to follow.  If you want me to look at it first that's fine, but since you've succeeded at least three times now I'm sure whatever you write will be good.

I'm not sure why the binding doesn't seem to be working with the NTFS formatted partition.  That puzzles me.  Just to complete test with that setup, can you boot into Windows and create a few test files in the Documents folder on that DATA partition; then reboot into LL and go to Documents in your Home folder and see if they show-up there?  (If you've already got some files/folders in Documents, no need to create test docs.  Just see if they show up in your LL /home/username/Documents folder.)  If they don't show in home, can you see/access them by navigating directly to /mnt/DATA?  Report back results and then post back results of following terminal commands so I can double-check for anything that might be causing the problem:

Substitute your username where I have "username" below.
Code: [Select]
sudo blkid -c /dev/null
cat /etc/fstab
cat /etc/init/bind-home.conf
mount
ls -l /home/username
ls -l /mnt
ls -l /mnt/DATA
Try Linux Beginner Search Engine for answers to Linux questions.
 

 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Reputation: 86
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium [email protected] (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
Just before you sent your last reply (#17 above),  I had already made some progress yesterday with two cloned copies of the original pre-installed win8.1. 

I installed LL2.4 from scratch on each copy, with UEFI fully enabled in dual-boot.  Everything working beautifully as it did initially (i.e. prior to binding) in previous attempts, following Nehal J Wani's Youtube LL installation video.  For the two investigations described here, I followed Wani's video to the letter, so didn't have separate root and home partitions (as I previously had problems with a separate 'root' & 'home'). On sda I had just swap and root installed alongside the windows OS partitions.  I reserved sdb entirely for a single large DATA partition that takes up the whole drive.  GPT format used throughout as before. I ran two investigations, as follows:

***I should first mention two steps I took, in the present investigations, with each of the cloned copies: (1)  I left sdb as unallocated until  dual-boot was fully established and working in UEFI, and (2) when I carried out binding, I did this with UEFI enabled (fast & secure boot on) - I wondered if doing binding with CSM enabled (then UEFI enabled after binding), rather than UEFI enabled from the beginning of binding, had inadvertently led to the problem of me being unable to reboot into LL.  What I did seems to have worked, as I don't have any booting problems now for LL from the grub screen in either cloned copy, though establishing a real cause & effect is somewhat problematic (unless these things are repeated several times to confirm observations).

FIRST INVESTIGATION. 
I wanted to see if LL would bind to /mnt/DATA on sdb, if sdb was formatted as ext4 instead of ntfs.  Success - it does (the full formatted size of the sdb drive - around 920GB - appearing when I click Properties on each of the home folders).  But of course in using ext4, I am assuming that I've prevented win8.1 from sharing the folders on /mnt/DATA. So, though I have binding for LL, which is a result, I probably don't have folder sharing for win8.1. 

SECOND INVESTIGATION
I wanted to see if LL would bind to /mnt/DATA on sdb, if sdb was formatted as ntfs (as in the previous unsuccessful attempts), so that I could share DATA with win8.1.  What was different this time, compared to the unsuccessful attempts that didn't allow me to reboot into LL, was that I took the steps described in the paragraph marked *** above.   The success I had here was that I have no problems now in rebooting LL from the grub screen as in the first investigation above, but when I check properties for the home folders it's clear that binding hasn't occured.

I am keep the drives for both set-ups (described above) for further investigation.  However for now I need to use the 1st set-up as I need a computer for my work! Also I'm back to work on Tuesday 5th May so don't have much time to play around with this system after having a week off work.

Thankyou for your continued support... much appreciated as always
Regards
Mike

PS. When I've finally got the setup fully working I'd be happy to post a tutorial for this, if you would like (?), which would  include a transcript of Wani's video, just to make things easier. Obviously, I'd ask you, goldfinger, to check it before final posting, as I wouldn't like others to copy any of my 'bad practice'..!!
« Last Edit: May 02, 2015, 02:23:31 AM by m654321 »
64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ [email protected] - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ [email protected] - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom [email protected] - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel [email protected] - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel [email protected] - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 

 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
Goldfinger, you wrote to add the following 2 lines to fstab file...

# EFI System Partition
UUID=6E57-A726  /boot/efi   vfat   defaults   0   1

I regret to say, goldfinger, that this didn't work...

I'm stumped!  But doesn't matter now because you re-installed everything from scratch.


On sdb, where I have tried to set up a shared DATA partition (that we are having difficulty in binding), it was formatted as ntfs on a GPT drive. I formatted in ntfs so that I could share data between both win8.1 and LL. 

It has just occurred to me that as sdb  carries the flag 'msftdata', as a microsoft basic data partition, it might be protected by windows from being shared or bound to My Home Directory in LL..?  What do you think?

I kind of doubt that the "msftdata" flag is causing any problems and doubt that the NTFS formatting is the problem either.

I suppose you could change the formatting to FAT32 instead.  As long as none of the files you want to save there are bigger than 4GB, FAT32 will work and it's natively supported by Windows.  Or you could try the things N4RPS pointed to and format it as Ext3, or Ext4.  Personally, I don't think that's the issue and if I were you I'd wait to get booting sorted out first -- then try symlinks to the DATA partition instead of binding to it.  If symlinks work, just use those.  Follow instructions to create those in the tutorial you used originally.


It's worth noting that rebooting LL after a fresh install for a dual boot UEFI system also got stuck and hung indefinitely, when I ran the install so that /home and swap would go on on sdb (/ being on sda).  In the end, the only UEFI win8.1/LL set up so far that has appeared to work for me is one where I exclude sdb, and have the two OSes with LL's home installed as root, all on sda. So could the msftdata flag be interfering???

Again, I doubt it's the "msftdata" flag.  Something else is causing the problem.  A while back, forum member sysdrum reported on this having problems with installs whenever he put the Root and Home partitions on separate HDD's.  I've been meaning to test that out to see for  myself, but just haven't gotten around to it.  However, I don't doubt him -- he's not new to Linux -- I just am not sure if that is a blanket problem or one specific to certain machines/components.

With the above in mind and assuming that you followed the steps to complete the UEFI conversion just as you did before, but with no booting success -- can you do another LL install and put Root and Home on sda, leaving sdb for DATA and Swap?  That should work if you're a victim of same problem sysdrum encountered.  (Assuming that most of your data files end up on DATA partition, your Home partition can be fairly small -- 3-5GB should be more than enough.)


EDIT ADDED LATER:

From this post of yours, you said:
Quote
In the good fully functioning copy that I have of the UEFI dual boot (fast boot & secure boot enabled), that I didn't attempt to install binding on, it works amazingly: the grub screen comes up almost immediately and both LL and win8.1 load from the grub menu in less than 6 seconds!  It's the binding problem that's driving me absolutely crazy...  I am still going to work on this but await further feedback from you on next steps...  I wondered if you could reply on that thread for the binding, so that everything is kept together in one place.

Can you put that good copy back in the computer and run a quick test?

Assuming you have a DATA partition that you just did not setup for binding, can you at least choose it from file manager in LL, mount it and explore the contents on the partition?  If nothing on it, create a few test folders/files on it from within Windows, then see if you can read them in LL after mounting the partition?  Report back results.

Also, when booted into LL on good copy, can you post the output of these 4 terminal commands back here for us to see:
Code: [Select]
lsblk
sudo blkid -c /dev/null
cat /etc/fstab
[ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD"
« Last Edit: May 01, 2015, 02:31:25 PM by gold_finger »
Try Linux Beginner Search Engine for answers to Linux questions.
 

 

N4RPS

  • Donator
  • Platinum Level Poster
  • **********
  • 1149
    Posts
  • Reputation: 155
  • Knows JUST ENOUGH Linux to be DANGEROUS
    • Orphans for Christ, Self Advocates of Mecklenburg

  • Linux Lite: 2.6 64bit

  • CPU: Several Different 32-bit & 64-bit CPUs, 2-8 GB RAM

  • MEMORY: 8Gb

  • VIDEO CARD: Several Different AMD and Intel GPUs
Hello!

There are programs to let you access ext2/ext4 partitions from Windows, but they are read only.

More here: http://www.howtogeek.com/112888/3-ways-to-access-your-linux-partitions-from-windows/

73 DE N4RPS
Rob




A gun in your hand is worth more than a whole police force on the phone.
 

 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Reputation: 86
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium [email protected] (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
On sdb, where I have tried to set up a shared DATA partition (that we are having difficulty in binding), it was formatted as ntfs on a GPT drive. I formatted in ntfs so that I could share data between both win8.1 and LL. 

It has just occurred to me that as sdb  carries the flag 'msftdata', as a microsoft basic data partition, it might be protected by windows from being shared or bound to My Home Directory in LL..?  What do you think? 

If this is the case, then changing from an ntfs to an ext4 file structure on sdb should work, but then, presumably, I wont be able to share data with win8.1. 

It's worth noting that rebooting LL after a fresh install for a dual boot UEFI system also got stuck and hung indefinitely, when I ran the install so that /home and swap would go on on sdb (/ being on sda).  In the end, the only UEFI win8.1/LL set up so far that has appeared to work for me is one where I exclude sdb, and have the two OSes with LL's home installed as root, all on sda. So could the msftdata flag be interfering???

Mike

64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ [email protected] - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ [email protected] - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom [email protected] - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel [email protected] - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel [email protected] - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 

 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Reputation: 86
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium [email protected] (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
Goldfinger, you wrote to add the following 2 lines to fstab file...

# EFI System Partition
UUID=6E57-A726  /boot/efi   vfat   defaults   0   1

I regret to say, goldfinger, that this didn't work...
Thankfully, I have copies of the LL2.4/win8.1 UEFI dual boot on a separate disks, without
the binding, just in case anything goes wrong (which it has)!

I have to admit that out of frustration, I started again, setting up from scratch on
the SSD.  For this reason any UUID that you ask to look at will therefore be different from the above
except for the EFI system that appears to have the same UUID second time round.

With your continued support, I'll keep persevering...

Regards
Mike
« Last Edit: April 30, 2015, 03:03:31 PM by m654321 »
64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ [email protected] - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ [email protected] - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom [email protected] - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel [email protected] - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel [email protected] - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 

 

gold_finger

  • Documentation Writer
  • Platinum Level Poster
  • *****
  • 1094
    Posts
  • Reputation: 325
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Core2 Duo E7500 3.0GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 4 Series Integrated Graphics
Thanks Goldfinger, thanks Rob...

I tried what you both suggested, but with no luck.
If you are stuck too, I may just go for a single OS (LL2.4) install and have windows in a VM for when I need it

Don't give up yet.  I actually didn't expect those things to solve the problem -- I just wanted to eliminate various possibilities to narrow it down.

Main thing I saw missing in the fstab file was that there is no entry for the "EFI System Partition".  Assuming that your conversion to UEFI mode actually did work, (and from what you have answered, it did), there should be an entry for that partition in fstab.  Why it's not there now is a mystery?  Anyway, I'm pretty sure that once you add an entry for it the boot problem will be solved.

--  Boot with live LL again and open a terminal.

--  Open fstab as root with following command:

Code: [Select]
gksu leafpad /etc/fstab
--  Widen the size of the text editor window so that no lines wrap.  Do that to double-check that all lines beginning with "UUID=" are in fact one continuous line.  Only reason I want you to check that is because when I copy/pasted your original one here, the "UUID=" line for the DATA partition entry had a carriage return after "ntfs-3g" forcing the rest of that entry onto a new line.  That very well could just have been a quirk caused by the forum when you pasted it here and not something that is actually in your file on the computer.  I just want you to check to be sure.

--  Add this missing 2-line entry for the EFI partition to the end of the file:

Code: [Select]
# EFI System Partition
UUID=6E57-A726  /boot/efi   vfat   defaults   0   1

--  Save file, close everything out and reboot.  See if you can boot into installed LL now?  (This time, I am expecting it to work.)


Assuming you can now boot into LL, take ownership of the mount point for DATA partition with this command in a terminal (substitute your real username):
Code: [Select]
sudo chown -R username: /mnt/DATA
If that command spits out an error message saying it can't set permissions right, redo it without the "-R" part of command.  NTFS formatting doesn't set permissions like Linux formats (Ext4, Ext3, etc.), so it's possible the "-R" to recursively chown the subdirectories and files won't work.  (I haven't toyed with NTFS in quite a while, so not sure whether you'll see any errors or not.  Just covering bases.)  In any event, once you change ownership of the mount point itself, you shouldn't have any problems accessing things.


... I should add to reply#11 above that I did not delete the folders in /home before attempting binding. I can't see from my notes whether I should have done this or not, or is that something one only does with sym-linking, the alternative to binding?

Deleting pre-existing Home folders is only necessary when using symlinks.  If you didn't, then the symlink command would essentially be trying to create a second directory using the identical name as one that already exists -- and the command will fail.

When "binding", you're essentially re-mounting specific directories within the DATA partition to specific other locations within the file system -- in this case, to your Home directory.  So, just like you needed a mount point (/mnt/DATA) for the DATA partition; you need mount points for the bound directories.  Your current Home directories serve as those mount points.  Eg.  /home/username/Documents becomes the mount point for /mnt/DATA/Documents.

If you decided later that you want to add another folder (eg. "Miscellaneous") to the DATA partition and also have it show-up in Home, you'd need to make a folder named "Miscellaneous" in both /mnt/DATA and /home/username.  Then remember to add an entry for the binding of it to your bind-home.conf file in /etc/init.
« Last Edit: April 28, 2015, 01:15:35 PM by gold_finger »
Try Linux Beginner Search Engine for answers to Linux questions.
 

 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Reputation: 86
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium [email protected] (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
... I should add to reply#11 above that I did not delete the folders in /home before attempting binding. I can't see from my notes whether I should have done this or not, or is that something one only does with sym-linking, the alternative to binding?

Mike 
64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ [email protected] - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ [email protected] - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom [email protected] - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel [email protected] - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel [email protected] - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 

 

m654321

  • Gold Level Poster
  • *******
  • 891
    Posts
  • Reputation: 86
  • Linux Lite Member, 'Advocate' & Donator

  • Linux Lite: 4.6 64bit

  • CPU: Intel Pentium [email protected] (2cores) on an Asus X71Q

  • MEMORY: 4Gb

  • VIDEO CARD: Intel GM45 Express Chipset

  • Kernel: 4.x
Thanks Goldfinger, thanks Rob...

I tried what you both suggested, but with no luck.
If you are stuck too, I may just go for a single OS (LL2.4) install and have windows in a VM for when I need it
with /home on sdb1. Should I avoid a swap area with SSD drives - I've heard it can wear them out.
The UEFI Dual boot I have seems troublesome when I introduce binding.  Maybe windows is protecting sdb1?
Maybe something else...

Regards
Mike
64bit OS (32-bit on Samsung netbook) installed in Legacy mode on MBR-formatted SSDs (except pi which uses a micro SDHC card):
2017 - Raspberry pi 3B (4cores) ~ [email protected] - LibreElec, used for upgrading our Samsung TV (excellent for the task)  
2012 - Lenovo G580 2689 (2cores; 4threads] ~ [email protected] - LL3.8/Win8.1 dual-boot (LL working smoothly)
2011 - Samsung NP-N145 Plus (1core; 2threads) ~ Intel Atom [email protected] - LL 3.8 32-bit (64-bit too 'laggy')
2008 - Asus X71Q (2cores) ~ Intel [email protected] - LL4.6/Win8.1 dual-boot, LL works fine with kernel 4.15
2007 - Dell Latitude D630 (2cores) ~ Intel [email protected] - LL4.6, works well with kernel 4.4; 4.15 doesn't work
 

 

N4RPS

  • Donator
  • Platinum Level Poster
  • **********
  • 1149
    Posts
  • Reputation: 155
  • Knows JUST ENOUGH Linux to be DANGEROUS
    • Orphans for Christ, Self Advocates of Mecklenburg

  • Linux Lite: 2.6 64bit

  • CPU: Several Different 32-bit & 64-bit CPUs, 2-8 GB RAM

  • MEMORY: 8Gb

  • VIDEO CARD: Several Different AMD and Intel GPUs
Hello!

In Win8, Windows Key-X then A will open an administrative-level command prompt. You can then enter:

Code: [Select]
powercfg -h off
to disable the hibernation file.

The presence of hiberfil.sys definitely causes issues if you try to read from and write to a Windows partition in Linux. It also prevents those Windows password blankers (like pogostick.net) from working. Switching mine off made accessing files of a Windows partition in Linux MUCH easier.

Of course, Your Windows 8 boot time gets longer, but as they say, everything comes at a price...

73 DE N4RPS
Rob
« Last Edit: April 28, 2015, 01:22:03 AM by N4RPS »


A gun in your hand is worth more than a whole police force on the phone.
 

 

-->
X Close Ad

Linux Lite 6.4 RC1 Released - See the Release Announcements Forum section